Jump to content
Latest News: (loading..)

Recommended Posts

Hi everyone

 

I have installed the lastest Oscommerce bootstrap-3-in-2334-responsive-from-the-get-go and are wondering how to center the logo?

 

 

Another problem i have noticed is that the shop do not send out emails with the email transport method configured as sendmail, this works perfectly in my old Oscommerce installation. Have configured it as SMTP instead and now order confirmation emails gets sent out, but no emails get out using the contact form?

 

Hope someone can help, thanks.

 

Best regards

Kristian 

Share this post


Link to post
Share on other sites

I haven't tried it but I think you will need to set the width of the logo module to 12 and then add this to the user.css file:

#storeLogo {margin:auto; width:100%}

Please note that when you set the width to 12, none of the other modules that normally go in the header will fit. If you want something there, like the search bar, you will need to code that in. But that would make a centered image lose some of its appeal, I thnk.

Share this post


Link to post
Share on other sites

Hi Jack

Thank you very much for your reply.

Unfortunately it did not have an effect. I have the width set to 12 and have also tried another code in the user.css, but nothing happens.

Share this post


Link to post
Share on other sites

Hi Rainer

Thank you very much for replying.

I have tried different combinations without success. I don't really understand php programming, so i am justing grasping in the dark :0(

Would you mind being more specific as to how the code should look in logo.php?

 

Sorry to be a bother, i am really grateful for your help. 

Share this post


Link to post
Share on other sites

Sorry, I wasn't precise neither. It needs to be added to the image not div:

line 2 in the logo template:

  <?php echo '<a href="' . tep_href_link('index.php') . '">' . tep_image(DIR_WS_IMAGES . STORE_LOGO, STORE_NAME, '', '', '', true, 'center-block') . '</a>'; ?>

Share this post


Link to post
Share on other sites

Hola Rainier,

 

the sort order in the admin-> content modules does'n work at all !!! Brand NEW Installation.

No matter which sortorder you choose, 10 or 95.000 the logo will ALWAYS appear FIRST !!!

Even if you have other modules that have a lower digit then the logo, the logo always appaers first.

Let's say banner sort order : 10, logo : 20 the logo comes before the banner.

Remember "Sort order of display. Lowest is displayed first" tells the system.

 

 

It's seems to be an Colombian Order  :)

I'm the General, my wife the Colonel and our 3 daughters Officers, at the end I'm just a Soldier  :P

Edited by kozak

Share this post


Link to post
Share on other sites

Other functions that seems NOT to work like promised :

 

Bestsellers in Footer = NO Bestsellers in Footer.
Maybe because their no bestsellers?
 
What's New in Footer = NO What's New in Footer BUT STILL in Right Column??
Left = left, right = right but footer is also right column.
 
But I'm happy with the new system, It looks better on Mobile Devices.
No NEED of Mobile websiteversion
 
Saludos de Barranquilla, ya las 11.30 soleado y 32°C  :)  :)  :)

Share this post


Link to post
Share on other sites

@,

 

In my demo store it works:

http://www.sarplataygemas.com/osCommerce234bs/

 

see that the logo shows in the center, after the shop by price module

Shop by price is sort order 10

logo is sort order 20

 

There are no "What's new" and "Bestsellers" footer modules.

 

They are both boxes, where do you see the footer option for these box modules?

Another issue is that they show at the bottom of the page when viewed in xs (mobile/small screen) view.

 

Please, get first more familiar with 2.3.4 Bootstrap, before claiming that something doesn't work like "promised"

 

Meanwhile the last posts are offtopic in this forum, please see the title. You should open a new forum thread.

 

saludos desde la también hermosa costa mediterránea (aunque algo más frio, estamos en invierno)

Rainer

Share this post


Link to post
Share on other sites

Hi Rainier,

 

 

that's working because their ALL part of the Header, but you CANNOT choose to have First your Holiday Message BEFORE/ABOVE the Header where the logo is part of.

 

O and sorry for my mistake to mess up this topic with my boxes issues.

 

:)  :)  :)

Share this post


Link to post
Share on other sites

Rainier, I installed a complete new package and cannot move the customers greeting above the logo, how you explain that?

Then I installed front page and other addons from Jim Kymation that all works fine but there is NOTHING that I can place ABOVE the logo.

Till yet I did'n make any codechanges

 

Strange but happens to me

Share this post


Link to post
Share on other sites

@,

 

You have to analyze first in which groups the modules are organized.

Modules can only be moved by sort order within the same module group.

Customer greeting is part of the index page which is not modularized in the core files, only in the add on you mention, but even with the add-on still part of the index modules group.

Then there are the header modules, navbar, footer modules etc.

 

Just have a look in Admin => Modules => Content and see the group column.

 

Then open includes/template_top.php

see line 51:

  <?php echo $oscTemplate->getContent('navigation'); ?>

here the navigation group is included (only one module in core, the navbar)

and in line 58 you'll se the inclusion of the right and left column boxes.

 

In includes/header.php line 19 for the header modules:

  <?php echo $oscTemplate->getContent('header'); ?>

in includes/footer.php line 21 the footer modules and line 28 the footer_suffix modules.

 

The same in index.php for the index modules if you are using the modularized front page add-on and in product_info.php if you are using some other add ons which modularize the product page.

 

I hope that it is clear now that you can't get let's say a footer module to show in the header by changing sort order :).

 

regards

Rainer

 

PS: we are still going off topic. You should post your basic Bootstrap questions in the generic bootstrap forum:

http://forums.oscommerce.com/topic/396152-bootstrap-3-in-234-responsive-from-the-get-go/

Or search the related forums, I'm sure that this question about modules had already been answered in other posts.

Edited by raiwa

Share this post


Link to post
Share on other sites

Hola Rainier,

 

I think the reason I have something different is that I use the 234BS3 EDGE version of Burton which is already modified.

I downloaded the official version 2.3.4 but that still looks like 2.2  :(  :(  :(

 

Yes, again off topic

Share this post


Link to post
Share on other sites
On 2/19/2016 at 7:13 PM, raiwa said:

Sorry, I wasn't precise neither. It needs to be added to the image not div:

line 2 in the logo template:


  <?php echo '<a href="' . tep_href_link('index.php') . '">' . tep_image(DIR_WS_IMAGES . STORE_LOGO, STORE_NAME, '', '', '', true, 'center-block') . '</a>'; ?>

@raiwa   Hi

Still struggle with the Logo overlay the header video, tried JcMagpie suggestion but not working somehow, so google and found this post. Can you please explain what

'', '', '', true, 'center-block')

the meaning of ' ', ' ', ' ', true?

Many thanks!  Lyn

Share this post


Link to post
Share on other sites

Those are the parameters of the tep_image function as found in the html_output.php

////
// The HTML image wrapper function
  function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '', $responsive = true, $bootstrap_css = '') {
    if ( (empty($src) || ($src == 'images/')) && (IMAGE_REQUIRED == 'false') ) {
      return false;
    }

 

Share this post


Link to post
Share on other sites

Making the logo sit on top as an overly and making it sit in the centre are both quite simple! A big difference in it not working and you not being able to make it work don’t you think?

 

image.thumb.png.8db91170cd789d625db960d8b05fcae3.png


 

Share this post


Link to post
Share on other sites
6 hours ago, ce7 said:

 


'', '', '', true, 'center-block')

the meaning of ' ', ' ', ' ', true?

If you need to add the 'center-block' class to center the logo, you have to fill in all the parameters before the $bootstrap_css parameter. The 'true' is for the $responsive parameter, the others ($width, $height, $parameters) are unused and stay therefore empty. Instead of '' (empty) you can also see "null" in other examples.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×