Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

level8creative

Upgrading from 2.3.1 to 2.3.4

75 posts in this topic

Yes I saw your post and thank you, but my question is how?

I need an sql query ? Or is there an addon?

Share this post


Link to post
Share on other sites

I have installed 2.3.4 version my question is Can I transfer customers with their details etc and Products with their prices categories etc from Version 2.3.1???

 

The typical process for migrating a live store is something like this:

- take a copy of the live database for development

- for each of the following steps, keep notes and the files because you'll need to do it again later

- on the development copy, run the SQL that does the updates for each intervening version of standard osc, eg 2.3.2, 2.3.3, 2.3.3.1, 2.3.3.2 etc

  There is an addon that already has all the changes from  MS2.2 compiled into one file: http://addons.oscommerce.com/info/8731

- get the database changes for bootstrap gold from this thread: http://forums.oscommerce.com/topic/399678-234normal-to-234responsive-database-conversion-script/

- if you're using edge, there are some extra changes. If these are readily available, I don't know about it. You can find them out for yourself by comparing the SQL for gold and latest edge.

 

Now you have a database with real data to work on designing the new store. When you've finished the design part of the project you can do it all again with the latest customer and product data, and go live.

Share this post


Link to post
Share on other sites

@@danil0 In the edtras directory of the next version after your shop is an upgrade pdf. Open look at the part for the database changes, if they exist. Copy and run those commands into phpmyadmin, which is a program on your server, usually. You may need to ask your host how to find it. When that is done, do the same for the next version. You can do all of the database updates safely - no need to stop and make file changes.

Share this post


Link to post
Share on other sites

thank you for your detailed answer.

 

So here what I will do and I will inform you after.

 

I have installed a clean 2.3.4  allready and I m finished with design

on my old 2.3.1 copied db I will run all SQL queries from 2.3.2, 2.3.3, 2.3.3.1, 2.3.3.2 etc or the Adon you send 

and when finished I change the data base from Configure.php files (catalog and admin sides)

 

..I think it is the same ... ?

Share this post


Link to post
Share on other sites

That should work. Good luck. :)

I have not so good luck...:(

 

it looks like the 2.3.1 Database has no UTF8 encoding and I cannot import in an empty DB on mysqladmin.. I get sql errors all the time

It has also deferend collation (latin1_swedish_ci)

 

so with these circumstances do you believe that I can retrieve customers and products from 2.3.1 database and import on 2.3.4 I have installed?

Share this post


Link to post
Share on other sites

You may be going at it backwards. Try creating a copy of your existing shop with your existing database and make sure it works. Then go through and apply all of the database changes. The use that database with the 2.3.4 files.

Share this post


Link to post
Share on other sites

You may be going at it backwards. Try creating a copy of your existing shop with your existing database and make sure it works. Then go through and apply all of the database changes. The use that database with the 2.3.4 files.

I m trying to dublicate my utf8 database and when I import from the Sql file (2,5mb) I get this error

 

Error

SQL query:

# osCommerce, Open Source E-Commerce Solutions

# http://www.oscommerce.com

#

# Database Backup For Sport n Dog

# Copyright © 2016xxxxxxx

#

# Database:xxxxxxxxx

# Database Server: xxxxxxxxxxxxxx

#

# Backup Date: 21/09/2016 00:01:16

DROP TABLE IF EXISTS action_recorder;

 

MySQL said: b_help.png

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '

drop table if exists action_recorder' at line 1 

 

 

I can't import ...What am I missing?

Share this post


Link to post
Share on other sites

That's a valid command so I don't see why it is failing. Try running it just by itself to be sure it is not due to a missing end of line character.

danil0 likes this

Share this post


Link to post
Share on other sites

That's a valid command so I don't see why it is failing. Try running it just by itself to be sure it is not due to a missing end of line character.

you mean to run on an empty DB this sql query DROP TABLE IF EXISTS action_recorder;

?

Share this post


Link to post
Share on other sites

Your SQL query has been executed successfully (Query took 0.0039 sec)

SQL query:DROP TABLE IF EXISTS action_recorder;

Share this post


Link to post
Share on other sites

ok finaly I made it .. to convert from Latin1 to UTF8 I just used:

 

 ALTER DATABASE MyDb CHARACTER SET utf8;

 

the error before maybe was because the database was in UTF8 allready...I dont know for sure. I did from the begining and it worked

 

I m going now on design part etc .. thank you all for your help

Share this post


Link to post
Share on other sites

Please a last help..

 

Every think works fine but when I go to any product I get this error..

 

Warning: include(includes/languages/english/modules/social_bookmarks/sb_google_buzz.php): failed to open stream: No such file or directory in /hermes/bosnaweb06a/b2393/nf.645/public_html/dog4/includes/modules/boxes/bm_product_social_bookmarks.php on line 45 Warning: include(): Failed opening 'includes/languages/english/modules/social_bookmarks/sb_google_buzz.php' for inclusion (include_path='.:/usr/local/lib/php-5.3.29-amd64/lib/php') in /hermes/bosnaweb06a/b2393/nf.645/public_html/dog4/includes/modules/boxes/bm_product_social_bookmarks.php on line 45 Warning: include(includes/modules/social_bookmarks/sb_google_buzz.php): failed to open stream: No such file or directory in /hermes/bosnaweb06a/b2393/nf.645/public_html/dog4/includes/modules/boxes/bm_product_social_bookmarks.php on line 46 Warning: include(): Failed opening 'includes/modules/social_bookmarks/sb_google_buzz.php' for inclusion (include_path='.:/usr/local/lib/php-5.3.29-amd64/lib/php') in /hermes/bosnaweb06a/b2393/nf.645/public_html/dog4/includes/modules/boxes/bm_product_social_bookmarks.php on line 46 Fatal error: Class 'sb_google_buzz' not found in /hermes/bosnaweb06a/b2393/nf.645/public_html/dog4/includes/modules/boxes/bm_product_social_bookmarks.php on line 49

 

Have you any idea?

Share this post


Link to post
Share on other sites

It's saying you are missing the sb_google_buzz.php file(s). I don't recall that being part of the social bookmark module but it may be. In either case, you need to upload the files it wants. They may have been installed in your previous shop. If so, you will need to copy them to the new one, along with other missing files for addons you may have installed.

Share this post


Link to post
Share on other sites

It's saying you are missing the sb_google_buzz.php file(s). I don't recall that being part of the social bookmark module but it may be. In either case, you need to upload the files it wants. They may have been installed in your previous shop. If so, you will need to copy them to the new one, along with other missing files for addons you may have installed.

thank you all for your help on this procedure...it worked well

 

the only problem is that for some strange reason when I add products with "options" on the basket, the remove button is not working for them. For the other oroducts works like charm.

 

I noticed that this is happening on the old shop also wich means it is not a coding problem on file "shopping_cart.php"(I also test with original osc file)

 

Do you have any sujestions please??

Share this post


Link to post
Share on other sites

That doesn't happen on a stock installation so it must be some change you have made. But the only suggestion I can think of is to replace the file, which you've already done. To clarify, are you saying everything in the new shop is working fine except that you can't delete a product from the shopping cart that has attributes? If so, I can't think of anything useful. I wonder if you can place the order once the item is in the cart? Maybe do that and, assuming it works, trying adding a new product with attributes to the cart and see if the problem still exists. That might eliminate a session problem.

Share this post


Link to post
Share on other sites

Could this have anything to do with the use of braces { } in URIs for attributes? There has been a lot of discussion around here on something that has changed in servers, browsers, PHP, etc. where braces are now evaluated as subexpressions (?), or some strange thing like that. Some sort of security measure.

Share this post


Link to post
Share on other sites

That doesn't happen on a stock installation so it must be some change you have made. But the only suggestion I can think of is to replace the file, which you've already done. To clarify, are you saying everything in the new shop is working fine except that you can't delete a product from the shopping cart that has attributes? If so, I can't think of anything useful. I wonder if you can place the order once the item is in the cart? Maybe do that and, assuming it works, trying adding a new product with attributes to the cart and see if the problem still exists. That might eliminate a session problem.

it s not a session problem ... please check on my test installation http://645.netfirms.com/dog2

...maybe it is a php server version problem...let me see on my hoster

Share this post


Link to post
Share on other sites

Could this have anything to do with the use of braces { } in URIs for attributes? There has been a lot of discussion around here on something that has changed in servers, browsers, PHP, etc. where braces are now evaluated as subexpressions (?), or some strange thing like that. Some sort of security measure.

yes the problem is when these brackets are in the "remove product" link...

the funny thing is that when I add 0 pieces next to refresh button end hit enter then the product is removing ... do you thing that I should "hack" the remove action and make it the same action as the 0 + enter products? or do you thing that this whould be more dificult?

Share this post


Link to post
Share on other sites

it s not a session problem ... please check on my test installation http://645.netfirms.com/dog2

...maybe it is a php server version problem...let me see on my hoster

my php version is 5.3.29 and I all ready test on 5.5 and 5.6 where the "add to card" is not working at all

Share this post


Link to post
Share on other sites

thank you all for your help on this procedure...it worked well

 

the only problem is that for some strange reason when I add products with "options" on the basket, the remove button is not working for them. For the other oroducts works like charm.

 

I noticed that this is happening on the old shop also wich means it is not a coding problem on file "shopping_cart.php"(I also test with original osc file)

 

Do you have any sujestions please??

 

What happens if you click in the basket on the product that has options? Does it take you properly to the product with its options or not?

 

Some people have hit problems relating to the character '#' in the urls needing encoding.due to security tightening on their servers.

danil0 likes this

Share this post


Link to post
Share on other sites

What happens if you click in the basket on the product that has options? Does it take you properly to the product with its options or not?

 

Some people have hit problems relating to the character '#' in the urls needing encoding.due to security tightening on their servers.

no when I click on the product has options it is not take me to the product but on the home page instead of other products without options they are working fine...

I test to remove Greek characters from an atribute to see if this was the problem but it was not ... do you thing something else? do you want to check it by your self to see ? 645.netfirms.com/dog2

Share this post


Link to post
Share on other sites