Jump to content
Sign in to follow this  
rhercules

Language Pack Problem

Recommended Posts

Hi,

 

I have dowload and upload the portugues package. When i change it apears this message:

HTTP 500 error​

 

Now i cant enter in the admin anymore. What can i do ? I just put the package in the same dir as english.

I use ubuntu server and apache.

 

Best Regards

Share this post


Link to post
Share on other sites

The first thing I'd check is whether your language pack files (all .php, I think) were downloaded and uploaded correctly -- you didn't transfer them in binary or something. If you use your hosting file manager to browse the files, they should be correctly broken into lines and not all run together. In short, they should look much like all the other .php files. If they don't, erase them and try transferring them again.

 

If they appear to be OK, check for blank lines before the first <?php or after the last ?>. Remove the blank/empty lines and save the files. Check that you didn't introduce any Byte Order Marks in the files, if you end up editing them.

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the reply.

I have download fron the site and upload in Filezilla. The files look like the other .php but didnt look for spaces. I'll se that thanks. Lets se if this works :)

 

Regards

Share this post


Link to post
Share on other sites

Well i have look for the file and it apears like the english one. Everything looks fine. But then HTTP 500 error. I now se that we need files in Admin/includes/language and in include/language. Do i need to put the same on both dir ? What i have to do here ?

 

Regards

Share this post


Link to post
Share on other sites

The language files that go in includes/languages/ and admin/includes/languages/ will be different, so don't mix them up. Compare the English versions to see what's different, and then check that the Portuguese versions have the save defined names (obviously the text will be a different language).

 

Did your host make any changes at about the same time that you installed the new language files? If they updated PHP or the server itself, that might be why you're getting 500 errors (could be due to disallowed php_value, php_flag, Options, etc.). For the PHP files themselves, any blank or empty lines before the first <?php or after the last ?> can cause a 500 error. This includes lines with only a carriage-return (empty line).

 

Find out everything that has changed on your server and site since the last time it was running correctly. What osC version are you running?

Share this post


Link to post
Share on other sites

Thanks. I will se that and lets se. I think i put the same files in both dir so that might be a big problem.

Lets se if i correct that and things goes well.

 

Regards

Share this post


Link to post
Share on other sites

If you put 'admin' and 'catalog' files into the same directory, that would certainly cause problems. However, I don't think that will cause a 500 error. Did you edit any of the language files, perhaps leaving a blank or empty line before the first <?php or after the last ?> ? If after fixing those, you still get the error, here is a list of things that can cause 500 errors: http://www.catskilltech.com/freeSW/SMF/faqs/index.html#err500-- go through the list and see if anything there fixes your problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×