Jump to content

Archived

This topic is now archived and is closed to further replies.

don01234

Security add-ons for 2.3.4

Recommended Posts

Hi,

 

I am about start fresh with version 2.3.4 and trying find out if there are any extra security addons that I should put on it.

On my current shop, I had couple of different security addons like FWR security pro, BBB, and etc...

 

Any advice will be welcome. 

 

Don

Share this post


Link to post
Share on other sites

Im currently running Filesafe and OSC SEC on my 2.3.4 stores without issue.


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Consider the latest community version of osCommerce, mobile friendly and responsive. Click on the links in my sig.

Share this post


Link to post
Share on other sites

I just upgraded to fresh copy of MTS 1.5.0 responsive version which is osc 2.3.4 & MTS combined.  

I wanted to find out if there is any security add-ons that I should addon.  You like how I had to do with 2.3.1 where I started the store with...

Share this post


Link to post
Share on other sites

Hello to all,

       does it means there are no addons for osc 2.3.4? (I have standard osc 2.3.4, not the responsive).

On my 2.2 shop I had installed PHPIDS, but it doesn't work on osc 2.3.4 because phpids_installer.php returns an error like other user (I think because global vars).

Thanks

Share this post


Link to post
Share on other sites

I recommend Site Monitor and Osc Sec.

Thank you very much.

I just installed PHPIDS successfully (I made some manual entries into SQL reading the original php install program). But... during some searches about PHPIDS 0.7 (becuase phpids.org website is offline), I found that somebody have bypassed it. And.... so, now, I'm worried about the security.

Do you think OSC_SEC http://addons.oscommerce.com/info/8283 is better than PHPIDS http://addons.oscommerce.com/info/8217/v,23 ?

Take note that OSC_SEC officially should not support osc 2.3 (Am I right?)

Site monitor doesn't prevent intrusion, simply notify after mods (Am I right?).

Really many thanks again

Ciao!

Share this post


Link to post
Share on other sites

I'm not familiar with PHPIDS so I can't say anything about it. I don't understand what you mean by "OSC_SEC officially should not support osc 2.3" but osc sec will work with 2.3. There is a problem, as I recall, with it and the BS version, maybe 2.3.4 too, and it is no longer supported, from what I understand, but then neither is PHPIDS.

 

SiteMonitor does not prevent anything, it just lets you know something happened. If a hacker gets in, you need to know what files were changed and/or added. That is its purpose.

Share this post


Link to post
Share on other sites

I'm not familiar with PHPIDS so I can't say anything about it. I don't understand what you mean by "OSC_SEC officially should not support osc 2.3" but osc sec will work with 2.3.

Hi Jack,

    thanks again for your reply. I meant that If I search OSC_SEC for osc 2.3, there will be no results (I find it only for osc 2.2); if you go here: http://addons.oscommerce.com/info/8283

you'll read "osC_Sec - osCommerce Security Addon for osCommerce Online Merchant v2.2". So I understood it doesn't support osc 2.3.4

Thanks to notice me that it goes with osc 2.3.4

Ciao!

Share this post


Link to post
Share on other sites

The addons section has many problems and you can't determine what version an addon will work with just because of how it is posted. The name that shows up in addons is set when the addon is first uploaded and can't be changed. So the name you see was added in 2011 and 2.3 hadn't been widely used at that time.

Share this post


Link to post
Share on other sites

×