Jump to content

Recommended Posts

1 hour ago, yahalimu said:

Still getting many errors when using discount codes, mostly just 1pence out but this one many pence out.

The totals plainly do NOT add up to the grand total.

image.png.de1d286e3470e3a9be0475de065bb945.png

Total should be £362.96 according to the totals.

I think the VAT is calculating incorrectly as £363.06 is actually correct. (£308 - 5%)  + £9.95.... VAT should be  £60.51 which wpould then all add up to £363.06

 

Hello Iain,

I'll try to reproduce and check this when I'll find some time.

I would need more details:

  • Your tax rate
  • does shipping include tax
  • your tax decimals
  • other modifications you applied to related settings and/or files

 

rgds
Rainer

Share this post


Link to post
Share on other sites

Hi, That would be great if you have the time.

Normally its only 1 penny out but for some reason that one above was more..

 

Tax rate here is 20%.

Tax is applied to shipping.

No other mods applied that could affect it , its a 1.0.5.0 version. No extra order_total modules added.

Module Version
5.1.2. BS

Display Discount
True

Show shipping fee discounted
false

Base discount tax on prices excl.
true

Sort Order
3

Delete auto created tables when uninstalling
False

Not sure what you mean by 'Tax Decimals'. (20% = 0.2)

Iain

 

Share this post


Link to post
Share on other sites
5 minutes ago, yahalimu said:

Tax Decimals

This is a setting in Admin > Configuration > My Store.


Help shape the future of Phoenix; join the Phoenix Club

Share this post


Link to post
Share on other sites

@yahalimu,

forgot 2 more details:

  • discount is on order subtotal I guess?
  • please post the product list with prices (important is the number of products and each product price)

Share this post


Link to post
Share on other sites

@raiwa installing on Phoenix 1.0.5.0 without your modular shopping cart. The installation instructions for checkout_process are 

Quote

--------------------------------------------------------------
2. Modify the catalog/checkout_process.php file.
--------------------------------------------------------------
2.1. FIND:

  include 'includes/modules/checkout/after.php';


ADD BEFORE:

// Discount Codes
  echo $OSCOM_Hooks->call('checkout_process', 'DiscountCode');

However include 'includes/modules/checkout/after.php'; seems to refer to something in your modular shopping cart maybe?

Share this post


Link to post
Share on other sites
10 minutes ago, greasemonkey said:

However include 'includes/modules/checkout/after.php'; seems to refer to something in your modular shopping cart maybe?

https://github.com/gburton/CE-Phoenix/commit/ed074660e9c1b2c30200f8e5006fce1a53c08416#diff-8b27695473c9fdb061fe2a0d1f3d59d6

Which is just a fancy way of saying, not in 1.0.5.0. 

https://github.com/gburton/CE-Phoenix/commit/ccee9f7b75a9392325e10c4025360b7f0c630a92#diff-8b27695473c9fdb061fe2a0d1f3d59d6

In 1.0.5.0, you would probably put it right after

   tep_db_perform('orders_status_history', $sql_data_array); 

Or perhaps just before

// lets start with the email confirmation

If there are instructions for older versions of Phoenix or the BS edition, they are probably correct for 1.0.5.0.  The big changes to that file occurred in 1.0.5.1.  With some tweaks at 1.0.5.3. 


Always back up before making changes.

Share this post


Link to post
Share on other sites
40 minutes ago, ecartz said:

If there are instructions for older versions of Phoenix or the BS edition, they are probably correct for 1.0.5.0.  The big changes to that file occurred in 1.0.5.1.  With some tweaks at 1.0.5.3. 

👍

Share this post


Link to post
Share on other sites
12 hours ago, greasemonkey said:

@raiwa installing on Phoenix 1.0.5.0 without your modular shopping cart. The installation instructions for checkout_process are 

However include 'includes/modules/checkout/after.php'; seems to refer to something in your modular shopping cart maybe?

Yep, this is a wrong reference.

It should say:

2.1. FIND:

// lets start with the email confirmation
  $email_order = STORE_NAME . "\n" . 

Thanks for pointing out, I'll fix it in the next update.

Share this post


Link to post
Share on other sites

Hi dear;

It seems to not work on Phoenix 1.0.7.1, it does not accept any discount code on checkout_payment.php;

Can you please help me understand the issue and fix it...

Regds./

radhavallabh

Share this post


Link to post
Share on other sites
2 hours ago, rupruprup said:

it works with Phoenix v1.0.7.1 as it is, I even use it in my live store

As you said it worked dear but on the Order Total page, I am referring to the checkout payment page, I still re-uploaded all files but issue is there..

To be more precise the issue is that on checkout payment page when I insert the discount code in shows a red sign beside it in the box instead of a tick after it checks for the code-- although it gets added to the Order Total page...

Share this post


Link to post
Share on other sites
Posted (edited)

@Kavita I use it on the checkout payment page only, and it really works fine

Edited by rupruprup

Share this post


Link to post
Share on other sites
49 minutes ago, rupruprup said:

@Kavita I use it on the checkout payment page only, and it really works fine

It works but when I enter a discount code it shows a red color invalid symbol although it is a valid code and does get added on further checkout...

Share this post


Link to post
Share on other sites
1 hour ago, radhavallabh said:

It works but when I enter a discount code it shows a red color invalid symbol although it is a valid code and does get added on further checkout...

Please make sure you have all files uploaded and in the correct place.

Share this post


Link to post
Share on other sites
16 hours ago, raiwa said:

Please make sure you have all files uploaded and in the correct place.

I checked thoroughly...

Just now, rupruprup said:

are the discounts setup properly and active ?

Yes I created 3 of different types to check, all are active.. They do not display with a green tick on the checkout payment page when I enter them just get added on the checkout confirmation page..

Share this post


Link to post
Share on other sites
1 minute ago, rupruprup said:

are the discounts setup properly and active ?

Quote

although it is a valid code and does get added on further checkout...

Must be correct setup if it gets validated on checkout_confirmation.. What does not work is the ajax validation on checkout_payment.

Share this post


Link to post
Share on other sites

Then I can't help further within this thread. If it works for others it must be something with your store.

Share this post


Link to post
Share on other sites
1 minute ago, raiwa said:

Must be correct setup if it gets validated on checkout_confirmation.. What does not work is the ajax validation on checkout_payment.

So how to debug this dear.. Please help me..

Share this post


Link to post
Share on other sites
1 minute ago, raiwa said:

Then I can't help further within this thread. If it works for others it must be something with your store.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×