Jump to content
Latest News: (loading..)
jcall

OllaCart Point of Sale for osCommerce - ocPOS

Recommended Posts

Grep tells me that neither php_network_getaddresses nor getaddrinfo  appear on ocPOS code. Are you successfully running other PHP applications on that same server?

 

If this were my server, I'd create a file called aaaaa.php with the following contents:

  <?php phpinfo(); ?>

 

Then save, upload to the ocPOS folder, and try to access it in your browser, just for a sanity check.

 

I think that the problem is likely something other than ocPOS directly.

 

-jared

Share this post


Link to post
Share on other sites

is there a way when it shows the price when typing the product to show price inc VAT not price excluding vat?

 

example

 

it shows

Model # Product Name Price Quantity Total 569767246476 4000 WHITE 0.2g proball high grade ammo airsoft 6mm bbs 4.58

and would like it to show

 

 

Model # Product Name Price Quantity Total 569767246476 4000 WHITE 0.2g proball high grade ammo airsoft 6mm bbs 5.50

then a vat break down after?

Share this post


Link to post
Share on other sites

Hi friends, I am trying to use OllaCart with ZenCart. Locally working good but if I post this online. Getting error 

 

Warning: Cannot modify header information - headers already sent by (output started at /home/d/public_html/pos/includes/custom_header.php:9) in /home/d/public_html/pos/login.php on line 18

 

Also online it is working without login. If I open www.domain.com/pos it go straight to pos without asking about login.

 

Regards

Deep

Share this post


Link to post
Share on other sites

 

 

fixed

 

It's always more useful to the community if you can tell us what fixed the problem. That way, people searching around for a solution to a similar problem won't be wasting their time by finding this thread and coming here only to find "fixed". Even if it's just "I found I had accidentally deleted the last 10 lines of file X, and had to restore them from backup", that's somewhat useful. The only lower life form is someone who posts a question, gets solutions from the community, and then erases their original question (deliberately, so it won't be of help to potential competitors).


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Is it possible to utilize application_top.php or configure.php for db settings?

I tried to change the variables and include("../includes/application_top.php");

but that failed miserably.

I just hate to keep up the DB info in two separate sections.

Share this post


Link to post
Share on other sites

Is there any way to edit the order status of an order.

Just having the two order statuses does not work for my installation.

Please point me in the right direction. I need some orders to be pending, and some to be completed.

Any ideas?

Share this post


Link to post
Share on other sites

Anybody have some tax issues?  Just overview but I am using ZenCart as the base and when creating an item you define whether it is taxable.

 

When I use Ollacart if I add some of my items that are services to the cart, that are non-taxable in Zen, they get tax added in Olla.  If I do non-inventory and choose 0% tax, then the whole cart gets processed that way.  If I flip it and process a taxable item first then add non-taxable it taxes everything. 

 

Ideas?

 

Also still looking for anyone that has EPN or GoPai working in Ollacart.

Share this post


Link to post
Share on other sites

Anybody have some tax issues?  Just overview but I am using ZenCart as the base and when creating an item you define whether it is taxable.

 

When I use Ollacart if I add some of my items that are services to the cart, that are non-taxable in Zen, they get tax added in Olla.  If I do non-inventory and choose 0% tax, then the whole cart gets processed that way.  If I flip it and process a taxable item first then add non-taxable it taxes everything. 

 

Ideas?

 

Also still looking for anyone that has EPN or GoPai working in Ollacart.

 

Would this solve your tax problem? I haven't worked on Ollacart for a while.

 

http://forums.oscommerce.com/topic/407813-ollacart-point-of-sale-for-oscommerce-ocpos/page-4#entry1736882


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

Hi Guys,

 

Trying to get my head around the date format for OllaCart .

 

Installed and working well but the ERROR listed below still comes up.

 

"Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home16/rabhobbi/public_html/online/osPOS25/includes/functions.php on line 1034"

 

So the line of code of which i am not familiar to modify is ::

 

echo(date("m-d H:i", $this->PostTime) . " - ");

 

Another ERROR is ::

 

"Warning: Cannot modify header information - headers already sent by (output started at /home16/rabhobbi/public_html/online/osPOS25/index.php:21) in /home16/rabhobbi/public_html/online/osPOS25/includes/newheader.php on line 15"

 

 

 

Can any one suggest the fix for both  !

 

Cheers

Ren.

 

 

Share this post


Link to post
Share on other sites

Hi Guys,

 

Another issue is login from ADMIN window.

 

 

 

No Matter what i try .  I am unable to log in

post-155575-0-44006300-1473135750_thumb.jpg

 

 

 

Cheers

 

Ren

Share this post


Link to post
Share on other sites

@@milkman45 Have you tried this version? https://github.com/frankludriks/ocPOS25-Responsive

 

(make sure you create a new includes/db.php file according to these instructions https://github.com/frankludriks/ocPOS25-Responsive/issues/2)

Edited by frankl

Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

You need to set your time zone in either php.ini: date.timezone = 'Australia/Melbourne' or by adding date_default_timezone_set('Australia/Melbourne'); to application_top.php files.

 

The "headers already sent" message is a consequence of the timezone error message, and will go away once you fix the timezone issue.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Hi Guys,

 

Installed the RESPONSIVE version and still the same issues.

 

Unable to log into ADMIN as this is still stating "Login Error. * Username not alphanumeric. Please try again."  Even though the details are correct as i use OCPM with the same settings to log in.

 

Also php.ini  is correctly set with 'Australia/Melbourne'

 

Thoughts !

Share this post


Link to post
Share on other sites

The game has evolved.

 

I now have logging activated but this is the new error coming up. 

 

"Could not connect to the database! Please verify database settings in includes/db.php."

 

Created a new login name and password from the server side and verified the settings but still no good.  I think it might be the "SERVER" set at local host instead of 127.0.0.1  . Although i've never had thes type of issues setting up other data bases and connections .

Really, this has thrown me  :wacko: 

Share this post


Link to post
Share on other sites

Hi Guys,

 

Spend the last day working on issues in getting the OLLA CART working .  Big issue is the inability for the LOGIN window to recognize the login username.

 

"Login Error. * Username not found. Please try again."

 

Went through the parameters and reset evernything twice over.  Username and Password are he same as i use to login to my data base from other programs including my CONTROL PANEL to SERVER.

 

Any help would be greatly appreciated.

 

Kind regards,

 

Ren.

Share this post


Link to post
Share on other sites

The login image you showed 3 days ago... are you sure you're using the right ID? It looks like you gave the ID for your database (<account name>_<DB name> is a common format for shared server databases). Incidentally, it's not a good idea to publicly expose your account names and IDs to the world -- that could be useful to a hacker on your system.

 

 

Also php.ini  is correctly set with 'Australia/Melbourne'

 

What does that mean? Are you no longer getting the warning message about using a default timezone, or are you still? If you're still getting the message, perhaps you need additional information for the system. On mine, I have to put an entry (suPHP_ConfigPath) in .htaccess to tell PHP where to find php.ini. Ask your host.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Thanks for the info. 

 

No good. Still stating that the "Login Error. * Username not found. Please try again."  is still coming up. 

 

Cheers

Ren.

Share this post


Link to post
Share on other sites

Did you transfer the data from an old osC version, and that includes the password(s)? I seem to recall seeing something about password hashing methods being changed somewhere along the line, so a password hash stored from an old version would not work with the same password entered into a newer store. You might search around for discussion on that.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×