Jump to content

Archived

This topic is now archived and is closed to further replies.

tigerpaw

Security Header is not valid

Recommended Posts

I am setting up a new store for someone and have installed OS Commerce v 2.3.4 I have set up everything and have taken the site live.

 

While making a purchase, I click the Pay Pal Express checkout button and I get an "Security header is not valid" error.

 

I have entered in the API credentials numerous times (cut and paste via notepad to ensure no spaces) and the person does have PayPal Pro. I am NOT in sandbox mode but live.

 

Any suggestions or help would be greatly appreciated, thanks in advance!!! :)

Share this post


Link to post
Share on other sites

That error is usually due to the API credentials not being correct. Maybe you are using live ones in test mode or vice versa.

Share this post


Link to post
Share on other sites

Thanks for the reply.   I just verified the API settings today and am getting the same error.  I also tried to turn of the SSL certificate but that did not work.  I am currently in live mode with the OS Commerece site.  Based on your reply does PayPal have test and live API settings?  We contacted Paypal and we accessed the API settings through the profile link.  Any additional help would be appreaciated. Thanks in advance

Share this post


Link to post
Share on other sites

@@tigerpaw Paypal test environment is called the sandbox: sandbox.paypal.com - that's what the 'test' settings refer to. Have you tried setting up a different paypal payment module to see what happens?


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

@@BrockleyJohn, thanks so much for the reply.  Based on your answer I am using the live version, so that eliminates one thing.

What other PayPal Payment Modules can I use AND is there anything else I can check out??? Thanks so much

Share this post


Link to post
Share on other sites

OK, I decided to start completely over. (Sorry Jack_mcs, I did it before I saw your post)

I completely deleted the catalog folder. This is what I have done so far after deleting everything:

 

I reinstalled OS Commerce 2.3.4

I then installed the Pay Pal module in the install directory per directions

I configured OS Commerce (I did NOT do the post work yet, i.e. setting permissions, deleting install directory, etc...)

 

This is where I am CURRENTLY AT and have stopped.

 

 

I wanted to get some input from you all before proceeding any further but according to the instructions I'm supposed to :

 

In catalog/admin/includes/column_left.php, add the following to the collection of

existing boxes being included:

include(DIR_WS_BOXES . 'paypal.php');

 

OK, I found the file however is there a specific place I need to place the include command.  Also from looking around the column_left file, I DO NOT see any lines listed that has existing boxes (i.e. catalog, configuration, customers, etc). 

 

Also I have version 2.3.4, am I to also follow directions for  OS Commerce Online Merchant up to v2.2RC2a (30-Jan-2008) ?  The instructions would have me coping and over writing files from the docs/legacy/v22rc2a/admin over to catalog/admin/includes.

 

Any help is greatly appreciated, thanks again in advance!

Share this post


Link to post
Share on other sites

First, if you using the standard paypal modules that come in the oscommerce package, remove those and install the paypal app (search the addons for that name).

 

For the left column change, that only applies to older versions of oscommerce. For installations into 2.3.4 just skip that step.

Share this post


Link to post
Share on other sites

Thanks to everyone for your help.  I switched over to Pay Pal Standard.

For PayPal Standard, do I need to enter in the Key and certificate info?

I set it up and entered in a credit card number but I get a message that states I need to use another card but I have no issues with my card.

Share this post


Link to post
Share on other sites

×