Jump to content

Archived

This topic is now archived and is closed to further replies.

badbo

SSL installation on 2.3.4

Recommended Posts

I have been away a few years and the configs have changed, I have tried every config option I can find for SSL. Chrome says it is installed and entering admin section it is https and it is green, On front end secure pages have yellow triangle over the https. I wonder if I have some JS interfering. I have no non secure items on front end, I don't think i do . Thanks in advance

dedicated ssl dedicated server

 

 

 

 

 define('HTTP_SERVER', 'http://txomega.com');
  define('HTTPS_SERVER', 'https://txomega.com');
  define('ENABLE_SSL', true);
  define('HTTP_COOKIE_DOMAIN', '.txomega.com');
  define('HTTPS_COOKIE_DOMAIN', '.txomega.com');
  define('HTTP_COOKIE_PATH', '/');
  define('HTTPS_COOKIE_PATH', '/');
  define('DIR_WS_HTTP_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');
  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 
 
 define('HTTP_SERVER', 'https://txomega.com');
  define('HTTPS_SERVER', 'https://txomega.com');
  define('ENABLE_SSL', true);
  define('HTTP_COOKIE_DOMAIN', '.txomega.com');
  define('HTTPS_COOKIE_DOMAIN', '.txomega.com');
  define('HTTP_COOKIE_PATH', '/admin');
  define('HTTPS_COOKIE_PATH', '/admin');
  define('HTTP_CATALOG_SERVER', 'https://txomega.com');
  define('HTTPS_CATALOG_SERVER', 'https://txomega.com');
  define('ENABLE_SSL_CATALOG', 'true');
  define('DIR_FS_DOCUMENT_ROOT', 'C:/Inetpub/wwwroot/atx/');
  define('DIR_WS_ADMIN', '/admin/');
  define('DIR_WS_HTTPS_ADMIN', '/admin/');
  define('DIR_FS_ADMIN', 'C:/Inetpub/wwwroot/atx/admin/');
  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');
  define('DIR_FS_CATALOG', 'C:/Inetpub/wwwroot/atx/');

 

Share this post


Link to post
Share on other sites

@@badbo Try testing your site here. The poodle vulnerability it mentions is serious so you should ask your host to fix that. The other entries shows why the page is not secure. Templates are notorious for these kinds of problems. You need to trace each one down and fix the code before your page will be secure.

Share this post


Link to post
Share on other sites

@@badbo Try testing your site here. The poodle vulnerability it mentions is serious so you should ask your host to fix that. The other entries shows why the page is not secure. Templates are notorious for these kinds of problems. You need to trace each one down and fix the code before your page will be secure.

I had just ran the fix for poodle but it didn't work while you were posting. But I haven't restarted server yet. Be back soon. Thanks

Share this post


Link to post
Share on other sites

@@badbo Try testing your site here. The poodle vulnerability it mentions is serious so you should ask your host to fix that. The other entries shows why the page is not secure. Templates are notorious for these kinds of problems. You need to trace each one down and fix the code before your page will be secure.

Ok the poodle fixed worked, Need to move all my spirte images to images folders and change the References to them, what a chore and I haven't a clue how to do it do it. When it come to css I am lost but I will give it a whirl. Thanks for your help Jack.

Share this post


Link to post
Share on other sites

@@badbo Try testing your site here. The poodle vulnerability it mentions is serious so you should ask your host to fix that. The other entries shows why the page is not secure. Templates are notorious for these kinds of problems. You need to trace each one down and fix the code before your page will be secure.

Thanks Jack you are a life saver. Moved all the images and changed the references for them (87) and fixed a unsecure form and all is well.

Share this post


Link to post
Share on other sites

×