Jump to content
Sign in to follow this  
bmcewan

[Contribution] CC_CVV_start date plus credit card blacklist

Recommended Posts

just gone through install most of it working now have a few problems

 

cant find the credit card control in admin, to turn on and off accepted cards,

 

when i enter the blacklist section i get the following error

Blacklisted Credit Cards

 

Blacklisted Cards Action

1146 - Table 'web12-a-shopp-24.TABLE_BLACKLIST' doesn't exist

 

select count(*) as total from TABLE_BLACKLIST

 

[TEP STOP]

 

this i reckon i need to run sql query to create table can anyone give me the code

 

all help much appreciated

cheers for the contribution

Share this post


Link to post
Share on other sites

also got this error on checkout

Fatal error: Call to undefined function: changedatain() in /home/sites/deckbits.com/public_html/chandlers/checkout_process.php on line 61

 

part of this code addition i think but not sure what to do to resolve

// BMC CC Mod Start

if ( strtolower(CC_ENC) == 'true' ) {

$key = changeme;

$plain_data = $order->info['cc_number'];

$order->info['cc_number'] = changedatain($plain_data,$key);

}

// BMC CC Mod End

 

again all help appreciated

Share this post


Link to post
Share on other sites

still problems with this module anyone have it working with 2.2

 

every time i enter the credit card module and try to edit when i update it just reverts back to the defaults

someone must have an idea

Share this post


Link to post
Share on other sites
still problems with this module anyone have it working with 2.2

 

every time i enter the credit card module and try to edit when i update it just reverts back to the defaults

someone must have an idea

 

 

ME TOO! Can anyone help??

Share this post


Link to post
Share on other sites

has anyone got this contribution working or is it just a complete waste of time

has anyone also seen the chnage data in issues with checkouut_process

Share this post


Link to post
Share on other sites
Hope this helps someone:

 

I installed this module and all was well except that it wasn't recording the start date, CVV or issue number. I was pulling my hair out then realised that I am running a version of MS2.2 with the register_globals off mod.

 

To fix this simple find the following in your modded catalog/includes/classes/order.php:

 

// >>> BEGIN REGISTER_GLOBALS
   link_post_variable('cc_type'); 
   link_post_variable('cc_owner'); 
   link_post_variable('cc_number'); 
   link_post_variable('cc_expires'); 
   link_post_variable('comments'); 
// <<< END REGISTER_GLOBALS

 

and simply add:

 

	   link_post_variable('cc_start'); 
   link_post_variable('cc_issue'); 
   link_post_variable('cc_cvv');

 

All fixed!

 

What a relief!

 

-Christian

 

I was pulling my hair out until I see this. My admin was not showing the CVV but the order/customer end was and the SQL field was empty also for the CVV. It was not exacly as above but was the same file, so thanks as made me look in here and I made a typo on the Cvv somehow.! Phew! All working now. thanks for great mod and your handy post ;)

Share this post


Link to post
Share on other sites
has anyone got this contribution working or is it just a complete waste of time

has anyone also seen the chnage data in issues with checkouut_process

Same Problem here as well and have been thru a ton of forums No luck yet. Did you ever figure it out???

 

Thanks in advance

Share this post


Link to post
Share on other sites

has anyone got this contribution working or is it just a complete waste of time

has anyone also seen the chnage data in issues with checkouut_process

 

OK GOT IT! I MISSED PUTTING THE CALL IN CATALOG/INCLUDES/GENERAL.PHP AT THE BOTTOM BEFORE THE LAST <?. DID THE ADMIN/FUNCTIONS/GENERAL.PHP FOR DECRYPT BUT MISSED THE CATALOG ONE FOR ENCRYPT. HOPE THIS HELPS SOMEONE

 

include('includes/functions/encrypt.php');

Share this post


Link to post
Share on other sites

this looks like a great mod, but can anybody please help!

 

I may be being really stupid but i installed cc_cvv+uk_switch v1_31 and it appears to function correctly - apart from there are no fields on the checkout page??

 

I have looked at the readme file again and again, but see no changes being made to the checkout_payment.php page??

 

any ideas??

Share this post


Link to post
Share on other sites

I installed cc_cvv_start date + credit card blacklist. I receive no errors but in the admin panel I lost the "install" "edit" area to edit the payment modules. Any ideas??? >_<

Share this post


Link to post
Share on other sites

I installed everything and did a few test purchases and it works great. :thumbsup:

 

However, if I disable the start date and issue number (we don't use those in the US and it will just confuse the customers) the cvv popup help link is missing.

 

Does anyone know how I can still keep the popup help for the cvv number and have those two sections disabled? I am sure I just need to move the code to a more suitable location but I haven't a clue as to where to put it.

 

Thanks in advance!

K

Edited by shartlesville

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×