Jump to content
Sign in to follow this  
bmcewan

Purchase Without Account Updated & Admin Functionality

Recommended Posts

Hey all-

 

I'm working on a new release of this contribution. Below are all the changes that will be included-

 

v0.90 (by djmonkey1)

 

-Rolled includes/login_pwa.php and includes/login_acc.php into login.php [needs to be formatted for proper display]

-Renamed Order_Info.php to order_info.php

-Rolled Order_Info_Process.php and includes/modules/Order_Info_Check.php into order_info.php [getting email already exists error when trying to checkout using previously entered info] (credit for this and a huge thanks to Steve Lionel who did this as part of his contribution Country State Selector)

-Changed the verbage in includes/languages/english/login.php to remove wording which incorrectly stated that customer information not stored in database

-Included a mod to includes/languages/english/create_account.php to change the heading title of order_info.php to "My Billing Information"

-Cleaned up the way links are displayed in the header

-Included a new file pwa_install.sql for easy database mod

-Included line by line instructions for manual edits (big thanks to Mace- I had already done this when I realized that I'd duplicated his work, but his instructions gave me something to check against. Hopefully I got everything!)

-Besides the previous step, tweaked the install instructions

-In the extras/wpp/ folder included a special login.php file formatted for use with PayPal WPP (it does not include instructions on how to integrate both contributions, sorry)

-Included Bug Fix For Error 404 When using Search Engine safe URLs by Nathan Arendt

-Removed reference to and use of 'FILENAME_CHECKOUT'

 

I'm currently in the final testing phase. Along with tweaking the html of login.php I need to fix a bug I'm seeing when someone tries to checkout without an account and uses information previously stored by PWA. Right now it comes back with the email error- is this something that people have seen with v0.82 or do you think it's something new I've managed to create?

 

Also, for the update posted on 18 Aug 2005, PWA 0.82 ZIP with Patch files, are there a large number of patches in there or just the two it mentions on the contribution page? I didn't really understand the contents of the .patch file. My version is based on PWA 0.82 dated 10 November 2004.

 

Cheers,

Stew


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Ok, I think I've got it. v0.90 is now available on the contributions page. If some people would like to test it out and let me know how it goes that would be much appreciated.

 

Stew


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Does anyone have an idea on how to get this pwa working with the joomla Osc.

 

http://mamboforge.net/projects/moscommerce/

And Also

http://developer.joomla.org/sf/projects/joscommerce

 

In Joomla/mambo + osc the users will have account in both joomla/mambo And Osc

 

but when PWA happen there is no Osc account and thus it does have some problem...

 

Any suggestion?

 

This is the problem code that have problem with PWA

 

1) In application_top.php there is a section like this

 

// -- webMS Modification --

// If Customer is Logged into osCommerce but not Mambo, then LOGOFF

if (tep_session_is_registered('customer_id') && !$mosUser['validated']) {

tep_session_unregister('customer_id');

tep_session_unregister('customer_default_address_id');

tep_session_unregister('customer_first_name');

tep_session_unregister('customer_country_id');

tep_session_unregister('customer_zone_id');

tep_session_unregister('comments');

}

 

Anyone have any idea?

 

Regards?

Share this post


Link to post
Share on other sites

This is about the latest release .90

 

Anyway, I tired testing it on my localhost. It seems to not be showing the order totals, on checkout_porcess.php I have PayPal_Shopping_Cart_IPN 3.15 installed. I there may be a conflict somewhere.

 

What needs to be improved:

 

1. Create an account halfway through checkout. What is buyer changes their mind during checkout, I don't see a way they can go back to create an account.

2. Still really buggy and install instructions aren't great.

 

Someone need to come up with something that does this:

 

1. Checkout->Create account or not on same page as a checkbox (i've seen this done)

2. Shipping and Payment methods on one page --> Checkout confirmation >> done.

 

Anyway that's my 2 cents I hope this contribution get improved again soon.

Share this post


Link to post
Share on other sites
This is about the latest release .90

 

Anyway, I tired testing it on my localhost. It seems to not be showing the order totals, on checkout_porcess.php I have PayPal_Shopping_Cart_IPN 3.15 installed. I there may be a conflict somewhere.

 

What needs to be improved:

 

1. Create an account halfway through checkout. What is buyer changes their mind during checkout, I don't see a way they can go back to create an account.

2. Still really buggy and install instructions aren't great.

 

Someone need to come up with something that does this:

 

1. Checkout->Create account or not on same page as a checkbox (i've seen this done)

2. Shipping and Payment methods on one page --> Checkout confirmation >> done.

 

Anyway that's my 2 cents I hope this contribution get improved again soon.

 

I believe you're referring to Fast Easy Checkout:

http://www.oscommerce.com/community/contributions,3469


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

I'm getting a parse error in order_info.php. I followed the file overwrite procedure in the read-me and ran the mysql query. Is there something I missed? Here's the error, upon clicking on the checkout button:

 

Parse error: parse error, unexpected ';' in C:\Program Files\xampp\htdocs\test\catalog\order_info.php on line 586

 

I checked the file and everything looks ok... I haven't edited the file at all. Would it be possible that this contribution is confliction with another (I installed one to fix a register_globals problem upon installation)?

 

Thanks for your help...

Candace

Share this post


Link to post
Share on other sites
I'm getting a parse error in order_info.php. I followed the file overwrite procedure in the read-me and ran the mysql query. Is there something I missed? Here's the error, upon clicking on the checkout button:

 

Parse error: parse error, unexpected ';' in C:\Program Files\xampp\htdocs\test\catalog\order_info.php on line 586

 

I checked the file and everything looks ok... I haven't edited the file at all. Would it be possible that this contribution is confliction with another (I installed one to fix a register_globals problem upon installation)?

 

Thanks for your help...

Candace

 

An error like that is generally caused by something wrong with the code. Try this- at lines 585-587, delete the following:

 

 <?php // +Country-State Selector ?>
			<!--td class="main"><?php echo //tep_get_country_list('country',$country,'onChange="return refresh_form(create_account);"') . ' ' . (tep_not_null(ENTRY_COUNTRY_TEXT) ? '<span class="inputRequirement">' . ENTRY_COUNTRY_TEXT . '</span>': ''); ?></td-->
			<?php // -Country-State Selector ?>

 

 

You're using v0.90, right?

Edited by djmonkey1

Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

hello,

 

PURCHASE WITHOUT ACCOUNT v0.90

 

i just overwritted all files, ran the sql and value in admin is "true" but nothing have change, still the same as old. any idea as why nothing happen?

 

thanks

Share this post


Link to post
Share on other sites
hello,

 

PURCHASE WITHOUT ACCOUNT v0.90

 

i just overwritted all files, ran the sql and value in admin is "true" but nothing have change, still the same as old. any idea as why nothing happen?

 

thanks

 

For a user to see the PWA option there has to be something in the cart and the user can't already be logged in. Start a session as a guest, put something in your cart, then hit checkout. You should see three login options.

 

If not I would say there was some sort of mistake made in uploading the catalog/login.php file (sometimes the upload just doesn't work right, this has happened to me quite a bit).


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Hi guys,

 

 

I installed PWA 0.90

 

I went trhough the hole procedures of buying WA in my shop, and I got easily to the end

But my problem is that when I relog in ADMIN, the order does not show in there....

 

Nothing to append change status and so on...

Was it intended like that, I know some other version PWA does put the order in ADMIN, because in my old shop it worked.

 

Thanks to all Ray.

 

 

Can anyone help my case...


Martin Raymond

Xtreme Medias, Owner

Share this post


Link to post
Share on other sites
Hi guys,

I installed PWA 0.90

 

I went trhough the hole procedures of buying WA in my shop, and I got easily to the end

But my problem is that when I relog in ADMIN, the order does not show in there....

 

Nothing to append change status and so on...

Was it intended like that, I know some other version PWA does put the order in ADMIN, because in my old shop it worked.

 

Thanks to all Ray.

Can anyone help my case...

 

I haven't seen that problem and it doesn't occur on my test site or my live site.

 

The order should show up in your admin area. The only contribution that I know of that has such a problem is PayPal IPN.

 

Did you overwrite the existing files or do a manual edit?

Edited by djmonkey1

Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
I haven't seen that problem and it doesn't occur on my test site or my live site.

 

The order should show up in your admin area. The only contribution that I know of that has such a problem is PayPal IPN.

 

Did you overwrite the existing files or do a manual edit?

 

 

I just manual edited the files, Actually I guess that only Order.php in admin should be the problem

 

I am still trying to figure it out...

 

Any suggestions

 

You can go and try the shop if you want, it is not live yet!!!

 

Play as much as you want... I will also go check manually in the DB if the order is there...

 

 

Thanks again. Ray

 

 

 

************************

************************

 

OK ! ALL MY TEST ORDERS ARE IN THE DB, PWA HAS '0' FOR VALUE.

 

************************

 

AND WHEN I SEARCH IN ADMIN FOR THE SPECIFIC ORDER VALUE ID IT SHOWS THE ORDER

ITSELF, AS IF I HAD CLICKED ON IT IN THE ORDER TABLE PAGE....

 

aNY iDEA+++

 

 

Thanks again. Ray


Martin Raymond

Xtreme Medias, Owner

Share this post


Link to post
Share on other sites

Ray-

 

I put an order in- first/last name Test Test.

 

Check it and let me know how it goes.

 

My brain is slowly turning on this one, I've heard of this problem before...

Edited by djmonkey1

Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

OK, First I must apologize for something.. SORRY SORRY SORRY

My shop link in OSC data is wrong, old shop... but your order can be seen in the old one...

 

It shoul be

 

http://www.xtreme-medias.com/commerce/

 

This is the new shop,

I also encountered another problem maybe related...

When I log with an e-mail that already exist, it send a message to the red upper bar, in my case it is

 

PWA_FAIL_ACCOUNT_EXISTS

 

I think the problem is in catalog/order.php line 214 to 218

 

Anyway, everything seems find in the DB, but still cannot see the orders in admin, exept when i directly type the order number in the serach box...

 

I am still really trying to get !!

 

Thanks again for coop and help, Ray

 

Any new idea!@


Martin Raymond

Xtreme Medias, Owner

Share this post


Link to post
Share on other sites

Ray-

 

Did you perform this step:

 

OPEN AND MAKE CHANGES IN THIS FILE: /catalog/includes/languages/english/login.php

 

add the following:

 

// Begin PWA

define('PWA_FAIL_ACCOUNT_EXISTS', 'An account already exists for the email address {EMAIL_ADDRESS}. You must login here with the password for that account before proceeding to checkout.');

define('HEADING_CHECKOUT', 'Proceed Directly to Checkout');

define('TEXT_CHECKOUT_INTRODUCTION', 'Proceed to Checkout without creating an account. By choosing this option you will neither be able to review your order status nor keep track of your previous orders.');

define('PROCEED_TO_CHECKOUT', 'Proceed to Checkout without Registering');

// end PWA


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

yes I did !

 

I thought the same at first, maybe the field was not identified in

its own language to find out that it is there, just not getting it ! for being represented...

 

I will still double check, reply in a sec...

 

everything is where it is suppose to be !

 

Still get the same message...

 

PWA_FAIL_ACCOUNT_EXISTS

 

and no order yet appear in the admin side...

 

OOOOUUUIIIIINNN !

 

Thanks, Ray


Martin Raymond

Xtreme Medias, Owner

Share this post


Link to post
Share on other sites

same page as when you get the user info name address, email...

 

the message shows up at the top... I cannot say the page because i reverted my install in order to know exactly when the order problem occured...

 

ray..

 

this is the page link I have at the top when the message appears

 

https://www.xtreme-medias.com/commerce/logi..._ACCOUNT_EXISTS


Martin Raymond

Xtreme Medias, Owner

Share this post


Link to post
Share on other sites

Ray-

 

Under what circumstances do you get this error?

 

You mention in an earlier post that it happens

 

When I log with an e-mail that already exist, it send a message to the red upper bar

 

Is this a user that already has an account or a user that has checked out previously with PWA?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

The only users I have is me !!!!

 

When I purchase a product without account an use an e-mail address that already reside in the DB, its send the error message that I should be logging with my already registered account.

 

But instead of getting the message tag of PWA ERROR, I get the tag name itself like if it was not declared or indicate in the language login file. But it actually is !!!!

 

And still no freaking orders in admin. ! It could be possible that the problem does not reside in PWA... I dont know. !

Still looking

 

Ray


Martin Raymond

Xtreme Medias, Owner

Share this post


Link to post
Share on other sites

Ray-

 

Something is definitely wrong on your site, but I can't think of what it might be right now. Keep looking, there is a solution out there somewhere.

 

Stew


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

I have just installed PWA v0.90 on my developement site. This is exactly what I need! This is a great contribution.

 

I believe I have found a bug and it could prevent me from going live on my production site. The contribution is allowing multiple entries into the Customers database that have the same e-mail address. If one of the users decides to abort purchase, multiple e-mail addresses can remain in the customer database and the real customer that has registered cannot change his contact information and receives an error. Here is how to reproduce the issue:

 

1) Go to your osCommerce site and create a new Account with a new e-mail address.

2) Verify that this Account exists in Admin, Customers and is unique.

3) In the osCommerce site, logout this customer from the osCommerce site.

4) In your osCommerce site, select a product as a Guest and proceed to checkout.

5) When provided with the three options:

Proceed Directly to Checkout

New Customer

Returning Customer

Select the Checout button in the Proceed Directly to Checkout section.

6) Fill in the Personal Details but spell the first name of the person differently than was created in step 1 above. Put your Wife's first name this time for example. Make sure to use the same e-mail address. Click Continue.

7) Jump to your Admin, Customers screen. You will see two customers that have the same e-mail address listed.

8) Be a normal finicky customer with cold feet and abort the Checkout process. Just close your browser.

9) Open a fresh browser and access your osCommerce site. Login with the original Account e-mail address and password listed in step 1.

10) Click My Account.

11) Select View or Change my Account Information.

12) Attempt to change your phone number and click Continue.

13) You should receive the following error

Your E-Mail Address already exists in our records - please log in with the e-mail address or create an account with a different address.

 

At this point ocCommerce seems confused by the two identical e-mail addresses in the customer database and it prevents the person with the real account from making changes to his contact information.

 

Let me know if you experience this too or if you think it happens only on my site...

 

Hope this helps.

 

Joe

Share this post


Link to post
Share on other sites

I found the code in /catalog/order_info.php that is allowing multiple e-mail address entries into the customer database:

 

$check_customer_query = tep_db_query("select customers_id, purchased_without_account,

customers_firstname, customers_password, customers_email_address,

customers_default_address_id from " . TABLE_CUSTOMERS . "

where upper(customers_email_address) = '" . strtoupper($HTTP_POST_VARS['email_address']) . "' and

upper(customers_firstname) = '" . strtoupper($HTTP_POST_VARS['firstname']) . "' and

upper(customers_lastname) = '" . strtoupper($HTTP_POST_VARS['lastname']) . "'");

 

The query seems to be true only if the e-mail address AND the First Name AND the Last Name all match. If at the "Proceed Directly to Checkout" screen, the first or last name is different but the e-mail address is the same, then duplicate e-mail addresses get entered into the database because of the AND statements.

 

I am definately not a php programmer here but I modified the database query to check only for e-mail address. This resolved the problem as far as I can tell and only allows one entry, keying on e-mail address only, into the database. If a user has already registered (e-mail address is in the database already), they must login and have the option to click on the Forgotten Password link to remember their password, which is sent to the same e-mail address. Basically, once you register with an Account, you are forced to use that account (e-mail address) forever and cannot ever go directly to Checkout without an account. I think this is normal by design.

 

Here is the change I made. Please let me know if this could cause another issue that I am unaware of and I hope this helps all using this contribution. It really is a great add-on. I sure do like it.

 

$check_customer_query = tep_db_query("select customers_id, purchased_without_account,

customers_firstname, customers_password, customers_email_address,

customers_default_address_id from " . TABLE_CUSTOMERS . "

where upper(customers_email_address) = '" . strtoupper($HTTP_POST_VARS['email_address']) . "'");

 

Joe

Share this post


Link to post
Share on other sites
I found the code in /catalog/order_info.php that is allowing multiple e-mail address entries into the customer database:

 

$check_customer_query = tep_db_query("select customers_id, purchased_without_account,

customers_firstname, customers_password, customers_email_address,

customers_default_address_id from " . TABLE_CUSTOMERS . "

where upper(customers_email_address) = '" . strtoupper($HTTP_POST_VARS['email_address']) . "' and

upper(customers_firstname) = '" . strtoupper($HTTP_POST_VARS['firstname']) . "' and

upper(customers_lastname) = '" . strtoupper($HTTP_POST_VARS['lastname']) . "'");

 

The query seems to be true only if the e-mail address AND the First Name AND the Last Name all match. If at the "Proceed Directly to Checkout" screen, the first or last name is different but the e-mail address is the same, then duplicate e-mail addresses get entered into the database because of the AND statements.

 

I am definately not a php programmer here but I modified the database query to check only for e-mail address. This resolved the problem as far as I can tell and only allows one entry, keying on e-mail address only, into the database. If a user has already registered (e-mail address is in the database already), they must login and have the option to click on the Forgotten Password link to remember their password, which is sent to the same e-mail address. Basically, once you register with an Account, you are forced to use that account (e-mail address) forever and cannot ever go directly to Checkout without an account. I think this is normal by design.

 

Here is the change I made. Please let me know if this could cause another issue that I am unaware of and I hope this helps all using this contribution. It really is a great add-on. I sure do like it.

 

$check_customer_query = tep_db_query("select customers_id, purchased_without_account,

customers_firstname, customers_password, customers_email_address,

customers_default_address_id from " . TABLE_CUSTOMERS . "

where upper(customers_email_address) = '" . strtoupper($HTTP_POST_VARS['email_address']) . "'");

 

Joe

 

That's not a bug, it's a feature!

 

Ha- I've always wanted to say that.

 

That is the way the contribution is written, Joe. I suppose the reason is so someone who shares an email address can still checkout without an account, while their husband/wife/buddy/whatever can have a regular account, or also use PWA, etc, and also to cover the remote possibility of a recycled email address, although I don't know if anyone would ever take that into account for something like this but you never know. I noticed it myself when testing v0.90 and then noted this at the bottom of the install instructions:

 

The system will not create another duplicate account if first/last name and e-mail address match up (that is also if the password is either blank or what you set it to). in which case, if those first 3 match up, it will call up the information from the customer database (so it actually doesn't matter what other informaton (state, zip, etc) that they fill out after those 3 match up).

 

Besides that, does it work ok?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Wait-

 

I didn't read your entire first post. You're right, that is a bug.

 

I think your solution might do the trick to get rid of this problem.

 

Thanks,

Stew


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×