Jump to content
Sign in to follow this  
bmcewan

Purchase Without Account Updated & Admin Functionality

Recommended Posts

Hi.

 

I just installed this contribution and all appeared to have gone well - no parsing errors etc when I fired up OSC with the new contrib installed. However, although it seems to be doing everything it should, my items are showing up with a price of '0'. When I check in the Admin area under 'Categories > Products' the prices etc are all still there as previously entered. I'm reasonably sure I followed the install instructions correctly....any suggestions as to where I might start looking would be gratefully received!

Share this post


Link to post
Share on other sites

Can someone please post a hack to disable the requirement of email addresses having to be different? Some of us want to disable accounts all together and we cant since repeat customers generally will enter their same email address over and over again...

Share this post


Link to post
Share on other sites
Can someone please post a hack to disable the requirement of email addresses having to be different? Some of us want to disable accounts all together and we cant since repeat customers generally will enter their same email address over and over again...

 

Good idea .... Anyone ?

Share this post


Link to post
Share on other sites
Can someone please post a hack to disable the requirement of email addresses having to be different? Some of us want to disable accounts all together and we cant since repeat customers generally will enter their same email address over and over again...

 

To my understanding, at least with PWA 0.82, this is already in place ?! When a customer uses PWA and completes the order the only thing left in the database is the order and not the customer details record. Only when they do not go all the way through ordering there is a data record left for the customer details.

Share this post


Link to post
Share on other sites

Just edit the error message to say something to the effect of "That address is currently associated with an account on this website. Please use the Forgotten Password link or use a different email address."

Share this post


Link to post
Share on other sites

Hey there,

 

I was just wondering if anybodys got this contrib installed with Auto Login.

 

I need to add this code snippet below the password field:

<?php // HMCS: Begin Autologon	**********************************************************
     if(ALLOW_AUTOLOGON != 'false') {
?>
                <tr>
          <td>
  	 </td>
          <td align="left" class="smalltext"><?php echo tep_draw_checkbox_field('remember_me','on', (($password == '') ? false : true)) . ' ' . ENTRY_REMEMBER_ME; ?></td>
                 </tr>
<?php     }
// HMCS: End	Autologon	**********************************************************  ?>

 

Any ideas?

 

Cheers

Fatmcgav

Share this post


Link to post
Share on other sites

Hmm...

 

Do any of you know how I can remove Gender and DOB from the log in page? Requiring these fields is rather odd.

 

I've tried deleting the feilds, but then it just gets stuck on the confirm info page. Probably still trying to write the unavailable info to the db.

 

In any case, if you've done this successfully-please post how.


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites
Hmm...

 

Do any of you know how I can remove Gender and DOB from the log in page?  Requiring these fields is rather odd.

 

I've tried deleting the feilds, but then it just gets stuck on the confirm info page.  Probably still trying to write the unavailable info to the db.

 

In any case, if you've done this successfully-please post how.

 

Hey -

Easy fix - just go to Customer Details in your Admin > Configuration panel, and change those values to a "O".

 

 

Blessings,

Fred

Share this post


Link to post
Share on other sites

<head>thump, thump, thump...</desk>

 

Why is that I must exhaust the process of elimination before arriving at the simplest possible conclusion? LOL

 

Thanks for your help, and blessings right back on you,

 

-akmac


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites
Hey there,

 

I was just wondering if anybodys got this contrib installed with Auto Login.

 

I need to add this code snippet below the password field:

<?php // HMCS: Begin Autologon	**********************************************************
     if(ALLOW_AUTOLOGON != 'false') {
?>
                <tr>
          <td>
  	 </td>
          <td align="left" class="smalltext"><?php echo tep_draw_checkbox_field('remember_me','on', (($password == '') ? false : true)) . ' ' . ENTRY_REMEMBER_ME; ?></td>
                 </tr>
<?php     }
// HMCS: End	Autologon	**********************************************************  ?>

 

Any ideas?

 

Cheers

Fatmcgav

 

Anybody know how to do this?

 

Cheers

Fatmcgav

Share this post


Link to post
Share on other sites

I managed to get the PWA working (well almost!) but I have a slight problem.

 

If I add a product, go to checkout, I get the three options (ok so far) I then choose PWA now I'm on Order_info.php and I enter my details. I continue (to Order_info_process.php) and I get this error:

 

Your County/State must contain a minimum of 2 characters.

 

Now I realised that on Order_info.php I don't get a drop down with all the UK counties in it like I should, I have a normal text box. I do however have the drop down on Order_info_process.php and when I add a county from the drop down list I proceed as normal. So the problem is why no dropdown on Order_info.php?

 

Hope someone can hep me with this.

 

Sarah.

Share this post


Link to post
Share on other sites
I managed to get the PWA working (well almost!) but I have a slight problem.

 

If I add a product, go to checkout, I get the three options (ok so far) I then choose PWA now I'm on Order_info.php and I enter my details. I continue (to Order_info_process.php) and I get this error:

 

Your County/State must contain a minimum of 2 characters.

 

Now I realised that on Order_info.php I don't get a drop down with all the UK counties in it like I should, I have a normal text box. I do however have the drop down on Order_info_process.php and when I add a county from the drop down list I proceed as normal. So the problem is why no dropdown on Order_info.php?

 

Hope someone can hep me with this.

 

Sarah.

 

 

 

Arrrrgggghhhh!!! I've discovered this is normal function if the county or state does not match any of the zones, in other words if you enter a miss-spelled county or one that does not exist. All works ok when a corrent count/stste is entered. So NOTHING to do with PWA - How did I ever doubt it!! Right back to testing . . .

 

Sarah

Share this post


Link to post
Share on other sites
Arrrrgggghhhh!!! I've discovered this is normal function if the county or state does not match any of the zones, in other words if you enter a miss-spelled county or one that does not exist. All works ok when a corrent count/stste is entered. So NOTHING to do with PWA - How did I ever doubt it!! Right back to testing . . .

 

Sarah

 

Any chance u could post the code changes you made to login_pwa and login_acc?

 

Also, i think i might have a fix for the county problem u mentioned, but i havent had a chance to test it yet.

Give me 10mins or so and i'll let you know.

 

Cheers

Fatmcgav

Share this post


Link to post
Share on other sites
Any chance u could post the code changes you made to login_pwa and login_acc?

 

Also, i think i might have a fix for the county problem u mentioned, but i havent had a chance to test it yet.

Give me 10mins or so and i'll let you know.

 

Cheers

Fatmcgav

 

Just ignore me Sarah, i thought u meant to got PWA workin with Autologin :blush: :blush:

 

Anyhow, i'm lookin at the code now to see if it's possible to incorporate [urlhttp://www.oscommerce.com/community/contributions,2028/category,all/search,Country+State]this contrib[/url] into the code.

 

I'll let you all know if i get anywhere.

 

Also, back to my first question - has anyone managed to get PWA workin with Auto-login???

 

Cheers

Fatmcgav

Share this post


Link to post
Share on other sites
Just ignore me Sarah, i thought u meant to got PWA workin with Autologin  :blush:  :blush:

 

Anyhow, i'm lookin at the code now to see if it's possible to incorporate [urlhttp://www.oscommerce.com/community/contributions,2028/category,all/search,Country+State]this contrib[/url] into the code.

 

I'll let you all know if i get anywhere.

 

Also, back to my first question - has anyone managed to get PWA workin with Auto-login???

 

Cheers

Fatmcgav

 

Sorry about the confusion!! I tend to jump right in without thinking, but it does seem like that contrib you mentioned will do the trick-thanks.

 

Tell me, with regards to the whole PWA thing, why, if visitors choose to use PWA, do they STILL need to enter their details? If they also use Paypal or other payment gateways won't they have to enter their details AGAIN? I'm trying to make the ordering as painless as possible for people but even PWA could be problem. Sarah.

Share this post


Link to post
Share on other sites

Correct me if i'm wrong, but whatever payment method they choose, dont you need to know where to post the item ;) ;). Thats why they enter their name and address on your site, and then if they choose Paypal as the payment method, dont they get forwarded straight onto the ppal site and enter their card details there, rather than on your site?

 

Does ppal actually use their address, other than to verify the card details?

 

Just tested it, and with ppal, you get to the payment method screen, and it then forwards you onto the ppal site, where they enter card details.

 

Hope this helps.

 

 

Fatmcgav

Share this post


Link to post
Share on other sites
Correct me if i'm wrong, but whatever payment method they choose, dont you need to know where to post the item ;) ;). Thats why they enter their name and address on your site, and then if they choose Paypal as the payment method, dont they get forwarded straight onto the ppal site and enter their card details there, rather than on your site?

 

Does ppal actually use their address, other than to verify the card details?

 

Just tested it, and with ppal, you get to the payment method screen, and it then forwards you onto the ppal site, where they enter card details.

 

Hope this helps.

Fatmcgav

 

 

Yes, I you're right, at least partly and what you said I'd expect of course. There is a possible caveat however, if the user does not have a Paypal account, which is an option now, then they do have to re-enter the shipping details.

 

I've tried this.

 

Using PWA user add's something to their cart then enters shipping info then selects paypal as payment method and then confirmation then to paypal who give two options, continue with existing paypal membership or pay without a paypal account. Select that and paypal want shipping info!

 

It all feels a bit clunky to me, what does the user feel??

 

What do you make of all that?? Am I feeling unjustifiably unimpressed?

 

Sarah

Share this post


Link to post
Share on other sites

Hello all. I installed the PURCHASE WITHOUT ACCOUNT v0.80 Contrib. but my

 

"login.php" page is blank everytime I click the "login" link when testing.

 

Fortunately, the "create account" link is working properly. The install instructions

 

were followed carefully but I'm new to php. Any help will be appreciated.

Share this post


Link to post
Share on other sites
Yes, I you're right, at least partly and what you said I'd expect of course. There is a possible caveat however, if the user does not have a Paypal account, which is an option now, then they do have to re-enter the shipping details.

 

I've tried this.

 

Using PWA user add's something to their cart then enters shipping info then selects paypal as payment method and then confirmation then to paypal who give two options, continue with existing paypal membership or pay without a paypal account. Select that and paypal want shipping info!

 

It all feels a bit clunky to me, what does the user feel??

 

What do you make of all that?? Am I feeling unjustifiably unimpressed?

 

Sarah

 

 

Just to respond o my own post, using the Paypal IPN will transfer address contents. Nothing to do with PWA I'm aware, but posted just for the sake of closure on that paypal issue. Sarah

Share this post


Link to post
Share on other sites

Hi guys, When i reached the step 3 to step 4 after confirm my order using PWA. It shows the error below. Please advise. Thank you in advance!

 

 

1054 - Unknown column 'purchased_without_account' in 'field list'

 

update orders set purchased_without_account = '1' where orders_id = '3'

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×