Jump to content
Sign in to follow this  
bmcewan

Purchase Without Account Updated & Admin Functionality

Recommended Posts

I couldn't find an obvious way to bypass the shipping page. Are you sure the information entered is getting into the database?

Share this post


Link to post
Share on other sites

Well, the rest of the order is. And I don't think (I'll have to look) that it's EVERY SINGLE order - or maybe it is every order where they don't create an account. Hmmm, you may have pointed me in the right direction!


Tara Lang

Share this post


Link to post
Share on other sites

Nope, I did a purchase without account and the information for delivery address came through just fine. SO it's not all the time. Somehow someone isn't putting in a delivery address, but I don't know how!


Tara Lang

Share this post


Link to post
Share on other sites
Nope, I did a purchase without account and the information for delivery address came through just fine.  SO it's not all the time.  Somehow someone isn't putting in a delivery address, but I don't know how!

Have you checked the database to see if there is a delivery address for the order that does not show one in admin?

Share this post


Link to post
Share on other sites
Have you checked the database to see if there is a delivery address for the order that does not show one in admin?

 

Yes, the fields are blank in the database as well. But, as I said, it's not ALL purchase without accounts just maybe 1 in 3. But only if they purchase without an account.

 

Could there be a browser or cookie setting that this mod isn't working with?


Tara Lang

Share this post


Link to post
Share on other sites
Yes, the fields are blank in the database as well.  But, as I said, it's not ALL purchase without accounts just maybe 1 in 3.  But only if they purchase without an account.

 

Could there be a browser or cookie setting that this mod isn't working with?

Do you have this version installed:

 

10 Nov 2004 - PWA v0.82 Author: Didier Debbaut

Bug fixed that could lead to a PHP error in the order confirmation page. Result : delivery address would not be displayed correctly

 

Changelog of v0.82 (by Didier Debbaut)

- fixed bug in Order_Info_Process.php so that client is directed to shipping page instead of payment page

 

Didier.

 

D

Share this post


Link to post
Share on other sites

First, thanks for this contribution !

I have just installed PWA 0.82 and there is a few things I might have missed or which might be a problem.

One thing is when I choose pwa it checks for email, first name, last name (I think) but when I make a typo in the first name or last name while using an email for an existing customer I can just continue as being a pwa customer and no warning is shown.

The question is if the check shouldn't be on the email address only as that should be unique by itself ? Now someone might use someone elses email with bogus names to send orders.

Related to this; there is no way I can start over once I have choosen to be a pwa customer. That is, only after the session ends I can start over. What if someone decides he/she wants to create a normal account afterall or an existing customer by accident takes the pwa route ?

Share this post


Link to post
Share on other sites

Thank you! No, this store was installed last summer, so I am using version .80.

 

I just hope it doesn't mess me up upgrading it, I remember .80 had many bugs I found when I installed it.

 

Hopefully this will fix my problem, thanks :)


Tara Lang

Share this post


Link to post
Share on other sites

Scarlet: I had that problem as well (in 0.7 actually)... it happened when the customer entered something wrong and PWA took them to the "change the error" page... the delivery address would then be entered as blank.

 

installing .82 fixed the issue

Share this post


Link to post
Share on other sites
Scarlet: I had that problem as well (in 0.7 actually)... it happened when the customer entered something wrong and PWA took them to the "change the error" page... the delivery address would then be entered as blank.

 

installing .82 fixed the issue

 

Well, so far so good, seems to be working.


Tara Lang

Share this post


Link to post
Share on other sites

Hi All,

I have been reading this and the print order forum, looking for a solution to make these two work together.

The one solution that sounded right, was the idea to make the session destroy when the continue button is pushed on checkout_success.php.

I was wondering if anyone has tried this or knows how to code it?

 

The destroy code from checkout_success.php is:

 

// PWA: Added a check for a Guest checkout and cleared the session - 030411 v0.71

if (tep_session_is_registered('noaccount')) {

$order_update = array('purchased_without_account' => '1');

tep_db_perform(TABLE_ORDERS, $order_update, 'update', "orders_id = '".$orders['orders_id']."'");

// tep_db_query("insert into " . TABLE_ORDERS . " (purchased_without_account) values ('1') where orders_id = '" . (int)$orders['orders_id'] . "'");

tep_db_query("delete from " . TABLE_ADDRESS_BOOK . " where customers_id = '" . tep_db_input($customer_id) . "'");

tep_db_query("delete from " . TABLE_CUSTOMERS . " where customers_id = '" . tep_db_input($customer_id) . "'");

tep_db_query("delete from " . TABLE_CUSTOMERS_INFO . " where customers_info_id = '" . tep_db_input($customer_id) . "'");

tep_db_query("delete from " . TABLE_CUSTOMERS_BASKET . " where customers_id = '" . tep_db_input($customer_id) . "'");

tep_db_query("delete from " . TABLE_CUSTOMERS_BASKET_ATTRIBUTES . " where customers_id = '" . tep_db_input($customer_id) . "'");

tep_db_query("delete from " . TABLE_WHOS_ONLINE . " where customer_id = '" . tep_db_input($customer_id) . "'");

tep_session_destroy();

}

 

Ideas anybody, or did anyone find an alternative they would care to post?

 

TIA

Erin :)

Share this post


Link to post
Share on other sites

Wondered if anyone could help

 

We have installed: PURCHASE WITHOUT ACCOUNT v0.82 November 10, 2004

 

On our admin/orders.php it gives this error:

 

Parse error: parse error, unexpected ')' in /home/pleasure/public_html/store/admin/orders.php on line 52

 

This is the line it's refering to:

 

tep_db_input($oID) . "'");$pwa_check= tep_db_fetch_array($pwa_check_query); if ($pwa_check['purchased_without_account'] != '1'){

 

 

Our shop is:

My Webpage - Pleasure Zone

 

It is also a concern as to whether a customer would encounter any problems, and we could be losing orders, but don't know.

 

Thank you for your help.

 

Steve


Hope it helps...

PC Planet

Share this post


Link to post
Share on other sites
Wondered if anyone could help

 

We have installed: PURCHASE WITHOUT ACCOUNT v0.82  November 10, 2004

 

On our admin/orders.php it gives this error:

This is the line it's refering to:

 

tep_db_input($oID) . "'");$pwa_check= tep_db_fetch_array($pwa_check_query); if ($pwa_check['purchased_without_account'] != '1'){

Our shop is:

My Webpage - Pleasure Zone

 

It is also a concern as to whether a customer would encounter any problems, and we could be losing orders, but don't know.

 

Thank you for your help.

 

Steve

 

You missed some part of the changes in that area. In the installation instructions it says:

// start pwa changes  $pwa_check_query= tep_db_query("select purchased_without_account from " . TABLE_ORDERS . " where orders_id = '" . tep_db_input($oID) . "'");$pwa_check= tep_db_fetch_array($pwa_check_query); if ($pwa_check['purchased_without_account'] != '1'){           $email = STORE_NAME . "\n" . EMAIL_SEPARATOR . "\n" . EMAIL_TEXT_ORDER_NUMBER . ' ' . $oID . "\n" . EMAIL_TEXT_INVOICE_URL . ' ' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT_HISTORY_INFO, 'order_id=' . $oID, 'SSL') . "\n" . EMAIL_TEXT_DATE_ORDERED . ' ' . tep_date_long($check_status['date_purchased']) . "\n\n" . $notify_comments . sprintf(EMAIL_TEXT_STATUS_UPDATE, $orders_status_array[$status]); } 
else {   $email = STORE_NAME . "\n" . EMAIL_SEPARATOR . "\n" . EMAIL_TEXT_ORDER_NUMBER . ' ' . $oID . "\n" . EMAIL_TEXT_DATE_ORDERED . ' ' . tep_date_long($check_status['date_purchased']) . "\n\n" . $notify_comments . sprintf(EMAIL_TEXT_STATUS_UPDATE, $orders_status_array[$status]); }           tep_mail($check_status['customers_name'], $check_status['customers_email_address'], EMAIL_TEXT_SUBJECT, $email, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

          $customer_notified = '1';         }

You missed the

$pwa_check_query= tep_db_query("select purchased_without_account from " . TABLE_ORDERS . " where orders_id = '" .

before

tep_db_input($oID) . "'");

and therefore a missing '('

 

I went for a quick tour through your site as a PWA customer and found a few things you might look into:

1) Somehow it is always required to fill in the address 2 field.

2) Whether I am a customer from the UK or from Turkmenistan, the shipping costs are the same (but maybe that is how you want it ?).

 

Nice site by the way !

Share this post


Link to post
Share on other sites

Thank you for your 'speedy' reply and help.

 

Worked great.

 

We will look into changing shipping costs worldwide and also a 'not required' field set to non important aspects of customer details.

 

Any other advice on site greatly accepted.

 

Steve


Hope it helps...

PC Planet

Share this post


Link to post
Share on other sites

I've done a search and not found a good answer to this question.

 

Is there an easy way to remove PWA customers/details from the database?

 

It can be done through direct db access (eg phpMyAdmin) and search for customers with a PWA setting of 1. However, to delete the customers you then have to delete not only from the customers table but customers_info, matching up customer ids.

 

Is there an easier way? A "one button" solution?

Share this post


Link to post
Share on other sites

We are using only PayPal. Is there any way at all to make the "purchase without account" checkout button on catalog/login.php go to PayPal? I guess what I would like to do is skip the catalog/checkout_shipping.php, catalog/checkout_payment.php and catalog/checkout_confirmation.php pages, so that the button on the login page does what the "confirm order" button on the checkout_confirmation page does. Is there a way to do this that wouldn't mess everything up?

Edited by maialee

Share this post


Link to post
Share on other sites

This contribution looks great... my only questions are - has anybody tried this with the download controller contrib? And, which version is the most stable? v.82?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Just wondering how critical the change in admin/orders.php is?

 

I have another mod installed,,, which,, changes that section of the file, and I cant quite figure out how to add this to it.

 

I need this mod for another mod, and so the cycle continues,, lol

 

What would happen if the change in this file wasnt done?

would it fail altogher? or would an email just not be sent?

 

Regards

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites

Actually,, I have given it a go,, no errors,, just hope i didnt break something

 

Regards

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites

Hi guys i have just installed this contrubition, and all seems good apart from i seem to have two menu systems now at the top of my site. These come from the header.php but i have checked and checked the insatllation but cant see what i have done wrong...

 

the area where i think that it is in my header.php is:

?>
<table border="0" width="100%" cellspacing="0" cellpadding="0">
 <tr class="header">
   <td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'oscommerce.gif', 'Wi-Fi Gear') . '</a>'; ?> </td>
   <td align="right" valign="middle"><b><font color="#FFFFFF" size="5">0845 000 XXX    </font></b></td><tr></table>
<table border="0" width="100%" cellspacing="0" cellpadding="1">
 <tr class="headerNavigation">
   <td class="headerNavigation">  <?php echo $breadcrumb->trail(' » '); ?></td>
   <td align="right" class="headerNavigation"><?php if (tep_session_is_registered('customer_id')) { ?><a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?></a>  |  <?php } ?><a href="<?php echo tep_href_link(FILENAME_ACCOUNT, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?></a>  |  <a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CART_CONTENTS; ?></a>  |  <a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CHECKOUT; ?></a>   </td>
 
<?php if ((tep_session_is_registered('customer_id')) && (!tep_session_is_registered('noaccount'))) 
// DDB - PWA - 040622 - no display of logoff for PWA customers
  { ?>
    	 <a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?> 
     </a>  |  
     <?php } ?>

     <?php if (!tep_session_is_registered('noaccount')) // DDB - PWA - 040622 - no display of account for PWA customers
  { ?>
    	 <a href="<?php echo tep_href_link(FILENAME_ACCOUNT, 'my_account_f=1', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?>      </a>  |  
  <?php } ?>

 <a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CART_CONTENTS; ?></a> 
      |  <a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CHECKOUT; ?> | </a></td>
 </tr>
</table>
<?php

my site is at http://www.yourwirelessworld.co.uk its not live yet so have a play, you will see the new menu under my logo. the only difference i can see that it perfroms is that the new My account which has a href of account.php?=my_account_f=1. this is different to the normal my account link.

 

Can anyone point me in the right direction..

 

cheers

Share this post


Link to post
Share on other sites
Hi guys i have just installed this contrubition, and all seems good apart from i seem to have two menu systems now at the top of my site.  These come from the header.php but i have checked and checked the insatllation but cant see what i have done wrong...

 

the area where i think that it is in my header.php is:

?>
<table border="0" width="100%" cellspacing="0" cellpadding="0">
?<tr class="header">
? ?<td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'oscommerce.gif', 'Wi-Fi Gear') . '</a>'; ?> </td>
? ?<td align="right" valign="middle"><b><font color="#FFFFFF" size="5">0845 000 XXX    </font></b></td><tr></table>
<table border="0" width="100%" cellspacing="0" cellpadding="1">
?<tr class="headerNavigation">
? ?<td class="headerNavigation">  <?php echo $breadcrumb->trail(' » '); ?></td>
? ?<td align="right" class="headerNavigation"><?php if (tep_session_is_registered('customer_id')) { ?><a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?></a>  |  <?php } ?><a href="<?php echo tep_href_link(FILENAME_ACCOUNT, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?></a>  |  <a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CART_CONTENTS; ?></a>  |  <a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CHECKOUT; ?></a>   </td>
?
<?php if ((tep_session_is_registered('customer_id')) && (!tep_session_is_registered('noaccount'))) 
// DDB - PWA - 040622 - no display of logoff for PWA customers
? { ?>
? ? ?	<a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?> 
? ? ?</a>  |  
? ? ?<?php } ?>

? ? ?<?php if (!tep_session_is_registered('noaccount')) // DDB - PWA - 040622 - no display of account for PWA customers
? { ?>
? ? ?	<a href="<?php echo tep_href_link(FILENAME_ACCOUNT, 'my_account_f=1', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?> ? ? ?</a>  |  
? <?php } ?>

?<a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CART_CONTENTS; ?></a> 
? ? ? |  <a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CHECKOUT; ?> | </a></td>
?</tr>
</table>
<?php

my site is at http://www.yourwirelessworld.co.uk  its not live yet so have a play, you will see the new menu under my logo. the only difference i can see that it perfroms is that the new My account which has a href of account.php?=my_account_f=1. this is different to the normal my account link.

 

Can anyone point me in the right direction..

 

cheers

 

Fixed the problem had to remove the code

<?php if (tep_session_is_registered('customer_id')) { ?><a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?></a>  |  <?php } ?><a href="<?php echo tep_href_link(FILENAME_ACCOUNT, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?></a>  |  <a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CART_CONTENTS; ?></a>  |  <a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CHECKOUT; ?></a>   </td>

 

which is the code for the origional menu.

 

cheers

Share this post


Link to post
Share on other sites

If I want to check if the current user are using "purchase without account" and hide some information, what flag should I validate with?

 

The things I wants to hide are the links "My Account", "Logout" and "My account information..."

 

BR

Joacim


BR

Joacim

Share this post


Link to post
Share on other sites

Can my guest just skip directly to the ikobo payment page ? Because I don't think that if he didn't want to make an account, he will just complete his info on my store's non-secured page. How can this be done ? Thank you.

Share this post


Link to post
Share on other sites
Hi All,

I have been reading this and the print order forum, looking for a solution to make these two work together.

The one solution that sounded right, was the idea to make the session destroy when the continue button is pushed on checkout_success.php.

I was wondering if anyone has tried this or knows how to code it?

 

 

Ideas anybody, or did anyone find an alternative they would care to post?

 

TIA

Erin :)

 

Erin, if you have find a solution for this, please let me know.

 

// Fredrik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×