Jump to content
Sign in to follow this  
bmcewan

Purchase Without Account Updated & Admin Functionality

Recommended Posts

4..Typo error. All files are delivered and must be updated for this contribution.

 

I found another typo in the install instructions - change to the file admin/orders.php include

if ($pwa_check['purchased_without_account'] != '1'){ $email = STOR_NAME .

 

where STOR_NAME should read STORE_NAME

 

In case you have a plain OSC installation, you can replace your files with these ones but in most cases you must use a tool like Winmerge or Beyond Compare to compare these files with your OSC files and make the necessary changes.

I got winmerge - thanks for the tip on that one.

 

I've got paypal ipn as well as nochex apc, and all three make changes in the checkout_success file, but I got it to hang together in the end. Is that the kind of thing that other ppl might be interested in?

 

Often with OSC contributions, people include the changed files *.php plus indicate in the readme.txt what changes have to be done.

 

Hm, I'm very much an osc newbie, so trying to be a little tactful here, but I've now installed 5 contributions, 4 successfully (1 I've had to roll back and give up on for the mo) and each one of them has taken a different approach to how to do it. Hohum, makes for an interesting evening or two ;)

 

Good luck !

 

thanks, but turned out I didn't need it in the end.

 

Thanks for your work on this.

 

:thumbsup:

 

Jax

Share this post


Link to post
Share on other sites
I've got paypal ipn as well as nochex apc, and all three make changes in the checkout_success file, but I got it to hang together in the end.? Is that the kind of thing that other ppl might be interested in?

 

Hm, I'm very much an osc newbie, so trying to be a little tactful here, but I've now installed 5 contributions, 4 successfully (1 I've had to roll back and give up on for the mo) and each one of them has taken a different approach to how to do it.? Hohum, makes for an interesting evening or two? ;)

 

Jax

 

Definitely post your code. Even if nobody needs it right now you can be sure somebody will eventually.

 

I've been trying to get 23 contribs to all play together nicely and so far PWA is the only one I haven't been able to lick. There's a post back a page or two from me. Every new contrib makes the whole deal more complicated. I've redefined my definition for "fun" because of it :lol:

 

Iggy

Edited by Iggy

Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites
Definitely post your code. Even if nobody needs it right now you can be sure somebody will eventually.

 

Well, you asked for it :lol:

 

This is the section of catalog/checkout_success.php where pwa and paypal ipn meet up. This particular configuration of it seems to work OK:

 

 if (strlen($notify_string) > 0) $notify_string = substr($notify_string, 0, -1);

// PWA Added a check for a Guest checkout and cleared the session - 030411 
if (tep_session_is_registered('noaccount')) { 
tep_session_destroy(); 
tep_redirect(tep_href_link(FILENAME_DEFAULT, '', 'NONSSL')); 
} 
else { //end of pwa addition
   //begin PayPal_Shopping_Cart_IPN
    tep_redirect(tep_href_link(FILENAME_DEFAULT, $notify_string)); }
  } else if ((isset($HTTP_GET_VARS['action']) && $HTTP_GET_VARS['action'] == 'success')) {
    PayPal_osC::reset_checkout_cart_session();
  }
//end PayPal_Shopping_Cart_IPN
 //}

 

I've been trying to get 23 contribs to all play together nicely and so far PWA is the only one I haven't been able to lick. There's a post back a page or two from me. Every new contrib makes the whole deal more complicated. I've redefined my definition for "fun" because of it  :lol:

 

My personal bugbear is QTPro, but there you go. Feels very house of cards ish though to me as I put each new contribution on there...

 

very new to me though this - first time I've worked with open source stuff. Fun is one word I've used :rolleyes:

 

Jax

Share this post


Link to post
Share on other sites

Hi there....

 

When pwa is activated and you go to "checkout" 3 boxes are showing, login, create account and proceed directely to chekout. (Logical and correct)

 

But when you choose "My Account" 3 boxes are also showing and at this point it would be more logical to show only 2 boxes, login and create account.

 

Any help about a fix for this issue would be greately appriciated.. :-)

Edited by toyicebear

Share this post


Link to post
Share on other sites

Good remark ! I did some coding this evening by passing an argument (my_account_f) from the header.php to the login_pwa.php page.

 

Try this :

 

1. change header.php and add "my_account_f" to the php line behind the "my account" button :

 

<a href="<?php echo tep_href_link(FILENAME_ACCOUNT, 'my_account_f=1', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?> </a>  | 

 

2. change account.php and add "my_account_f" in the beginning of the file :

 

if (!tep_session_is_registered('customer_id')) {

$navigation->set_snapshot();

tep_redirect(tep_href_link(FILENAME_LOGIN, 'my_account_f=' . $HTTP_GET_VARS['my_account_f'], 'SSL'));

}

 

3. change login_pwa.php where you display the third block. This is my "IF" statement when to display the PWA box :

 

if (($cart->count_contents() > 0) && (!isset($HTTP_GET_VARS['my_account_f']) || $HTTP_GET_VARS['my_account_f'] !=1))

 

Now the PWA box is displayed only if you have articles in your shopping cart and when not coming from the header "my account" link.

 

Try it and tell me if it works for you (I need some beta-testers here..hehe).

 

Didier.

Share this post


Link to post
Share on other sites

Great contrib, the PWA, but I decided to reverse the process since it's not something I need for my shop.

 

I reversed everything, but don't recall if I had restored my backup database or had forgotten to do so at that time. In my admin control panel, I still have the "Accounts" link under configuration section and the link choice "Purchase without Account" to select enable/disable there.

 

QUESTION 1 - is this code that I can't seem to find to remove in a file (thought i had reversed everything though) or is this in my database.

 

QUESTION 2 - how can i best remove the links in the admin control panel ? do i alter the database directly (i am familiar with myphpadmin)? if so, what would i need to do ?

 

Here's the relevant code from the admin page (view source type)... for reference...

 

Please advise...

Thank you...

 

 

<!-- body_text //-->

<td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td class="pageHeading">Accounts</td>

<td class="pageHeading" align="right"><img src="images/pixel_trans.gif" border="0" alt="" height="1"></td>

</tr>

</table></td>

</tr>

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr class="dataTableHeadingRow">

<td class="dataTableHeadingContent">Title</td>

<td class="dataTableHeadingContent">Value</td>

<td class="dataTableHeadingContent" align="right">Action </td>

</tr>

<tr id="defaultSelected" class="dataTableRowSelected" onmouseover="rowOverEffect(this)" onmouseout="rowOutEffect(this)" onclick="document.location.href='http://www.MYDOMAINHERE.com/adminss/configuration.php?gID=40&cID=165&action=edit'">

<td class="dataTableContent">Purchase Without Account</td>

<td class="dataTableContent">true</td>

<td class="dataTableContent" align="right"><img src="images/icon_arrow_right.gif" border="0" alt=""> </td>

</tr>

</table></td>

<td width="25%" valign="top">

<table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr class="infoBoxHeading">

<td class="infoBoxHeading"><b>Purchase Without Account</b></td>

</tr>

</table>

<form name="configuration" action="http://www.DOMAINHERE.com/adminss/configuration.php?gID=40&cID=165&action=save" method="post">

<table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td class="infoBoxContent">Please make any necessary changes</td>

</tr>

<tr>

<td class="infoBoxContent"><br><b>Purchase Without Account</b><br>Allow Customers to purchase without an account<br><br><input type="radio" name="configuration_value" value="true" CHECKED> true<br><input type="radio" name="configuration_value" value="false"> false</td>

</tr>

<tr>

Share this post


Link to post
Share on other sites

Hi,

 

I have installed PWA and it works great, until I try it with an email address that already has an account set up. It gives me the following error

 

Not Found

The requested URL

 

/login.php/login/fail/reason/An+account+already+exists+for+the+email+address+<i>iannn@247showroom.co.uk</i>.++You+must+login+here+with+the+password+for+that+account+before+proceeding+t

o+checkout.

 

was not found on this server.

 

 

 

I am sure I have missed something when installing it but have been over and over it without any success.

 

Ian :'(

Share this post


Link to post
Share on other sites
Great contrib, the PWA, but I decided to reverse the process since it's not something I need for my shop. 

 

I reversed everything, but don't recall if I had restored my backup database or had forgotten to do so at that time.  In my admin control panel,  I still have the "Accounts" link under configuration section and the link choice "Purchase without Account" to select enable/disable there. 

 

QUESTION 1 - is this code that I can't seem to find to remove in a file (thought i had reversed everything though) or is this in my database. 

 

QUESTION 2 - how can i best remove the links in the admin control panel ?  do i alter the database directly (i am familiar with myphpadmin)?  if so, what would i need to do ?

 

Here's the relevant code from the admin page (view source type)...  for reference...

 

Please advise...

Thank you...

 

You have to delete the entries in tables configuration_group and configuration. Drop the group and underlying records linked to "PWA".

 

Didier.

Share this post


Link to post
Share on other sites

Thanks to spaceboy for the fix about showing the box or not, i did actually use another way to achive this result, but i will also test out the mentioned fix and report back on the result as asked....

Share this post


Link to post
Share on other sites
I resolved my error by chaning the filename information to point directly to Order_Info.php rather than going through login.php.  It's not a true fix, simply a bypass, but it works for me.

 

 

hi tina

 

can you tell me where you changed the filename information for your bypass for this mod.

 

thanks

 

 

mark

Share this post


Link to post
Share on other sites
Spaceboy,

and this is what i recieve:

i dont need login.php to come up, and i dont need any membership options for my customers.

 

thanks

 

 

 

hi

 

did you work out why you got the Fatal error: Cannot redeclare tep_db_connect() (previously declared in ......

 

im still having problems with this too

 

mark

Share this post


Link to post
Share on other sites

Hi !

I installed the contrib in my modiefied system (searched all changes in the contrib) and made the changes in my system.

 

All is running, but at the end of the order there is noch checkou_confirmation page animore.

 

After confirming the order the customer gets directly back to the maipage without "Thank you" page.

 

Did I miss something ?

 

Who can help ?


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
Hi !

I installed the contrib in my modiefied system (searched all changes in the contrib) and made the changes in my system.

 

All is running, but at the end of the order there is noch checkou_confirmation page animore.

 

After confirming the order the customer gets directly back to the maipage without "Thank you" page.

 

Did I miss something ?

 

Who can help ?

 

And another curious thing:

 

When I go directly to "/catalog/login.php" (without an item in the shopping-cart)than is the last box "continue shopping without account" and I come to the "/catalog/Order_Info.php" - why does the script not check if something is in the shopping-cart ?

Edited by runweb

OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites

Hello,

 

I've installed the PWA contrib, followed the instructions (made changes to admin/orders.php), done the SQL query and here is my problem.

I've made some orders via PWA method and normal user checkout.

I cannot see those orders while on page admin/orders.php !

But if I pass the Order ID I get info about the order (I've inspected the tables via phpmyadmin and these orders do really exist in the database).

Same problem is when I login as a normal user and try to see my previous orders or pending one, I just cannot see them (the History of orders page is empty)

Anybody ? :) thanks in advance

Share this post


Link to post
Share on other sites
And another curious thing:

 

When I go directly to "/catalog/login.php" (without an item in the shopping-cart)than is the last box "continue shopping without account" and I come to the "/catalog/Order_Info.php" - why does the script not check if something is in the shopping-cart ?

 

Check my post #581 (a couple of posts above this) . I've published a fix that if you come directly from the "My account" link with an empty shopping cart, the PWA box is not displayed.

 

Didier.

Edited by Spaceboy

Share this post


Link to post
Share on other sites

I did just publish a new version of PWA version 0.81 including some remarks mentioned on this forum. Thanks to all !

 

Changelog :

 

v0.81 (by Didier Debbaut)

- fixed some Install_Instructions.txt typo errors + cleanuped really this file

- fixed header.php, account.php, login_pwa.php pages so that the PWA box is only displayed if you have items in your shopping cart and if you are NOT coming from the "my account" link in the header (the PWA customer has no account)

- added comment in checkout_process.php

- added file /catalog/account.php in this package

 

URL : PWA v0.80

 

Didier.

Share this post


Link to post
Share on other sites

First, a great contribution! Your modification works fine"

 

in the Order_Info.php there is the field with "Date of Birth". Is it posible to show the Date of Birth of the customer in the "order page" of the admin? Maybee under the customers details? So you can make a statistic of the age of the buyers. excuse my english ... :'(

Share this post


Link to post
Share on other sites

Hi Mark,

 

I did some coding to add the customer date of birth in the Order page. Here are the following changes to perform in the admin files :

 

1. /includes/[language]/orders.php

---------------------------------------

- add line define('ENTRY_CUSTOMER_DOB', 'Date of birth');

 

2. /includes/classes/order.php

-----------------------------------

- change the $order_query by adding the customers_id in the column list

- around line 47, add this line

 

$this->customer = array('customers_id' => $order['customers_id'], // DDB - 041104 - add customers_id

'name' => $order['customers_name'],

'company' => $order['customers_company'],

 

3. /orders.php

----------------

- around line 205, add these lines :

 

<tr>

<td class="main"><b><?php echo EMAIL_TEXT_DATE_ORDERED; ?></b></td>

<td class="main"><?php echo tep_datetime_short($order->info['date_purchased']); ?></td>

</tr>

<?php

// DDB - 041104 - add customers_id

$customer_query = tep_db_query("select customers_dob from " . TABLE_CUSTOMERS . " where customers_id = '" . $order->customer['customers_id'] . "'");

$customer_array = tep_db_fetch_array($customer_query);

?>

<tr>

<td class="main"><b><?php echo ENTRY_CUSTOMER_DOB; ?></b></td>

<td class="main"><?php echo tep_date_short($customer_array['customers_dob']); ?></td>

</tr> </table></td>

 

You can use the same principle in all admin code as we added the customers_id in the order class. With this query, you can display almost any customer information where you want.

 

Give it a try !

 

Didier.

Share this post


Link to post
Share on other sites

hello everyone,

first of all please excuse my bad english...

i am just going crazy because of this a little function i am trying to type for about 3 days... :(

i installed pwa 0.81 and i would want to receive the shopping cart of my customer WITHOUT using the shipping and payment modules

as soon as the customer has typed in his address and confirmed it the cart shall be sent to its receiver (me)...

can just anyone please help me with this ?

 

thx moxi

Share this post


Link to post
Share on other sites

Hi everybody,

 

Just taken over a project which uses osCommerce. I had nothing to do with the installation, configuration etc. (this was done by another company).

 

PWA is installed but when a user purchases without an account, this does not show up in the orders in Admin. The only way to get the order detail is by using the 'Recover Carts' contrib.

 

Is this normal?

 

Thank you in advance.

Share this post


Link to post
Share on other sites

I just installed 0.81 (had a previous version of PWA but don't recall exactly what that is) and now I'm getting an error on the "Confirm order" page:

 

Warning: htmlspecialchars() expects parameter 1 to be string, array given in /includes/functions/general.php on line 42

 

Warning: htmlspecialchars() expects parameter 1 to be string, array given in /includes/functions/general.php on line 42

 

(The directories have been edited.)

 

It has something to do with the customer's address, as it appears in the Delivery Address box on the order confirmation page.

 

This is the offending part of general.php:

 

  function tep_output_string($string, $translate = false, $protected = false) {
   if ($protected == true) {
     return htmlspecialchars($string);
   } else {
     if ($translate == false) {
       return tep_parse_input_field_data($string, array('"' => '"'));
     } else {
       return tep_parse_input_field_data($string, $translate);
     }
   }
 }

 

Since general.php was working fine before, I know it's not that. It's some change that PWA has made.

 

Any ideas?

Share this post


Link to post
Share on other sites
I just installed 0.81 (had a previous version of PWA but don't recall exactly what that is) and now I'm getting an error on the "Confirm order" page:

(The directories have been edited.)

 

It has something to do with the customer's address, as it appears in the Delivery Address box on the order confirmation page.

 

This is the offending part of general.php:

 

 ?function tep_output_string($string, $translate = false, $protected = false) {
? ?if ($protected == true) {
? ? ?return htmlspecialchars($string);
? ?} else {
? ? ?if ($translate == false) {
? ? ? ?return tep_parse_input_field_data($string, array('"' => '"'));
? ? ?} else {
? ? ? ?return tep_parse_input_field_data($string, $translate);
? ? ?}
? ?}
?}

 

Since general.php was working fine before, I know it's not that. It's some change that PWA has made.

 

Any ideas?

 

me too !!

 

I got the same problem sometimes in the checkout_confirmation page, in the delivery address box. But I could never reproduce it :( I will do some testing this evening. Can you reproduce it all the time ? Do you use a PWA order then ? What is the address you use ?

 

Didier.

Share this post


Link to post
Share on other sites

It appears every time. I use both PWA and Accounts (I call them Profiles for marketing purposes ;) ). For testing I just make up an address, so I don't replicate something I've used before. Though supposedly that's not an issue with .81 of PWA...

 

It's a pain in the butt. When the shop went live PWA was working, then suddenly I started getting the blank page problem after entering details (NAV_TITLE_BAR2 or whatever the missing text definition was) so I decided to upgrade PWA to the latest version. It was fiddly trying to follow the install for an upgrade, but I got there. :)

 

Now though, I get that error.

 

The orders DO work and come through though, but I just hope no customers get scared off by the PHP error.

Share this post


Link to post
Share on other sites
Hi everybody,

 

Just taken over a project which uses osCommerce. I had nothing to do with the installation, configuration etc. (this was done by another company).

 

PWA is installed but when a user purchases without an account, this does not show up in the orders in Admin. The only way to get the order detail is by using the 'Recover Carts' contrib.

 

Is this normal?

 

Thank you in advance.

 

nop..the PWA order is just like another order with a customer etc. The client has no account however.

 

I do not know this Recover Carts contrib...Are they compatible ?

 

Didier.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×