Jump to content
kh1noo

As add wysiwyg in Oscommerce 2.3.4

Recommended Posts

Working on setting up Bootstrap with 234 site.  I have added ckeditor to root of the site and under admin/ext.  How do I get red of the double spacing and make it not show <p> </p> and other signs?

Share this post


Link to post
Share on other sites

Click the Source icon in the upper left of the CKEditor frame. Are the tags now encoded? CKEditor may have ignored the existing HTML and made the tags safe to display. If so, the only fix that I know is to copy the contents out to a text editor, making sure everything is cleared out, then switch CKEditor to Source mode and paste it back in. If that doesn't work you'll have to enter the contents again and reformat them.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi JIm @@kymation

 

Thanks for getting back to me.  I went on a hunt to find a solution to the extra spacing and the <p> signs showing up.

 

Found this to pass along .  Tested and using on CKeditor 4.4.7

 

To remove CKE from showing HTML code, make the following change to the two files, catalog/includes/functions/html_output.php  & catalog/admin/includes/functions/html_output.php

 

Find:

} elseif (tep_not_null($text)) {

$field.=tep_output_string_protected($text);

}

 

Replace with:

} elseif (tep_not_null($text)) {

$field.=$text;

}

 

To remove the large spacing in CKE, open the sites ckeditor/ckeditor.js in Notepad++.  Change both files in catalog/ckeditor and admin/ext/ckeditor

 

Around line 181

Search for forceEnterMode

Change the following:

enterMode:CKEDITOR.ENTER_P,forceEnterMode:!1,shiftEnterMode:CKEDITOR.ENTER_BR,

 

into:

enterMode:CKEDITOR.ENTER_BR,forceEnterMode:!1,shiftEnterMode:CKEDITOR.ENTER_P,

 

I’m not a programmer, and offer this without any warranty.  Hope this will help others.

Share this post


Link to post
Share on other sites

I'm getting error following attempt to install ckeditor in 2.3.4. Appears to be something in the template_top file regarding the ability to turn on/off the ability to use the editor. If I comment that out the error goes away but the editor is not available.

 

 

1366 - Incorrect integer value: '' for column 'configuration_id' at row 1

insert into configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added, set_function) values ('', 'Use CKEditor', 'USE_CKEDITOR_ADMIN_TEXTAREA','true','Use CKEditor for WYSIWYG editing of textarea fields in admin',1,99,now(),'tep_cfg_select_option(array(\'true\', \'false\'),' )

[TEP STOP]

Share this post


Link to post
Share on other sites

Try replacing the SQL code with this:

insert into configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added, set_function) values (NULL, 'Use CKEditor', 'USE_CKEDITOR_ADMIN_TEXTAREA','true','Use CKEditor for WYSIWYG editing of textarea fields in admin',1,99,now(),'tep_cfg_select_option(array(\'true\', \'false\'),' )

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×