Jump to content
Latest News: (loading..)
burt

Bugs in GOLD version of 2.3.4-Responsive

Recommended Posts

Yes it will be a long road. Porting add ons and a ton of custom code patches I wrote will be hard to achieve the same funtionality, so I was waiting for something like bootstrap.

Share this post


Link to post
Share on other sites

Something else I'm not sure if is a normal behaviour or not: if you click on Site setiings at the top bar from checkout language options doesn't display.

Share this post


Link to post
Share on other sites

That is correct and expected behaviour.  We should probably move the defunct <ul into the (substr(basename($PHP_SELF), 0, 8) != 'checkout') though. 

Not a bug exactly, but needs attention.  Thanks for spotting.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

@@frankl - does it happen with a core file (eg authorize.net).


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

For the bugs that are marked solved, if you can spare a few moments please test the given solution and post your results...thanks.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

red required star is misplaced on gender input issue...looks resolved in chrome and firefox

 

post-231701-0-67182300-1421264645_thumb.jpg


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Continue button on checkout_shipping.php - Should be btn-success

 

Looks good

 

post-231701-0-73977600-1421265866_thumb.jpg


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

For the misplaced div, after updating the code to this:

      $search_box .=  tep_hide_session_id() . '</form>';
      $search_box .= '</div>';

 No noticeable display change but did notice that when installing the search box content module the language files were not being found for some reason.

 

Getting this during the install process:

 

post-231701-0-92012300-1421267650_thumb.jpg

 

This is on a fresh install on Uniserver 

Edited by altoid

I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

check box issue, account_newsletters.php

 

Looks good

 

post-231701-0-13688900-1421268883_thumb.jpg

 

Will work on the others...summoned to domestic duty 

Edited by altoid

I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Thanks for taking the time @@altoid, much appreciated.

I'll take another look at the search box problem tomorrow.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

FOOTER_TEXT_BODY is defined in both

 

catalog/includes/languages/english.php

 

and

 

catalog/includes/languages/english/modules/content/footer_suffix/cm_footer_extra_copyright.php


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

@@frankl - does it happen with a core file (eg authorize.net).

 

@@burt

 

I couldn't get any fields to show up for any of the other payment methods. I tried

 

Authorize.net Advanced Integration Method (AIM)        

Authorize.net Direct Post Method (DPM)

Authorize.net Server Integration Method (SIM)

iPayment (Credit Card)

2Checkout

Sage Pay Direct

Stripe

 

so I can't say.

 

I thought it may have been because I have an altered version of checkout_payment.php, so I copied over the version from Gold but still no luck. Perhaps it is something else, but before I go further can you get the fields to show up for credit card payments on your test store (http://www.template.me.uk/2334bs3)?


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

check boxes in account_notifications, advanced_search and create_account look good after updating fix codes

 

post-231701-0-99829800-1421281144_thumb.jpg

 

post-231701-0-81615000-1421281165_thumb.jpg

 

post-231701-0-79330000-1421281202_thumb.jpg


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

How does one navigate to the address_book_details.php file in the shop?


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

How does one navigate to the address_book_details.php file in the shop?

@@altoid

 

"catalog\\includes\modules\" is where you'll find the file.


My Add-ons
Advanced Cache Control Tool for osCommerce 2.3.x (non-bootstrap) Download Support
Ajax Product Listing for osC 2.3.4 (bootstrap) Download Support
Category New Products Carousel for osC 2.3.4 (bootstrap) Download Support
Category Popular Products Carousel for osC 2.3.4 (bootstrap) Download Support
Customer Testimonials for osCommerce 2.3.4 (bootstrap and non-bootstrap) Download Support
Front Page New Products Carousel for osC 2.3.4 (bootstrap) Download Support

Index Nested - Product Listing for osC 2.3.4 (bootstrapDownload Support
Match Categories in Search Results for osCommerce versions 2.3.x (non-bootstrap) Download Support
Modular Category Page for osC 2.3.4 (bootstrap)
Download Support

NEW Australia Post Shipping Modules for osCommerce 2.3.x (non-bootstrap) Download Support
NEW Equal Height Module for osC 2.3.4 (bootstrapDownload Support
Products Low Stock Report for osC 2.3.x (bootstrap and non-bootstrap) Download Support
Twitter Typeahead Autocomplete Search for osCommerce 2.3.4 (bootstrap and non-bootstrap)
Download Support

Upcoming Products Modules for osC 2.3.4 (bootstrap) Download Support

 
Assisted Add-ons
Scroll Boxes for osCommerce 2.3.x (bootstrap and non-bootstrap) Download Support
 
Bootstrap Add-ons created by other members
osCommerce Bootstrap Addons and Code

Share this post


Link to post
Share on other sites

For the misplaced div, after updating the code to this:

      $search_box .=  tep_hide_session_id() . '</form>';
      $search_box .= '</div>';

 No noticeable display change but did notice that when installing the search box content module the language files were not being found for some reason.

 

Getting this during the install process:

 

attachicon.gifsearchbox.jpg

 

This is on a fresh install on Uniserver 

 

@@altoid - I can't recreate this.  Could you navigate (in Uni) to:

/includes/languages/english/modules/content/header/cm_header_search.php

and:

1.  ensure it's there

2.  ensure it consists of:

 

 

<?php
/*
  $Id$
 
  osCommerce, Open Source E-Commerce Solutions
  http://www.oscommerce.com
 
  Copyright (c) 2014 osCommerce
 
  Released under the GNU General Public License
*/
 
  define('MODULE_CONTENT_HEADER_SEARCH_TITLE', 'Search Box');
  define('MODULE_CONTENT_HEADER_SEARCH_DESCRIPTION', 'Adds your Search Box into the Header Area of your site.');

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

@@burt

 

I couldn't get any fields to show up for any of the other payment methods. I tried

 

Authorize.net Advanced Integration Method (AIM)        

Authorize.net Direct Post Method (DPM)

Authorize.net Server Integration Method (SIM)

iPayment (Credit Card)

2Checkout

Sage Pay Direct

Stripe

 

so I can't say.

 

I thought it may have been because I have an altered version of checkout_payment.php, so I copied over the version from Gold but still no luck. Perhaps it is something else, but before I go further can you get the fields to show up for credit card payments on your test store (http://www.template.me.uk/2334bs3)?

 

I've enabled the old CC module - as this one has form inputs but does not need an account with a 3rd party.  Select CC on the payment page, the input boxes are then in the confirmation page.  You can use 4111111111111111 as a test card.

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

How does one navigate to the address_book_details.php file in the shop?

 

This is not a directly accessible file.  It is included in a couple of other files..


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

FOOTER_TEXT_BODY is defined in both

 

catalog/includes/languages/english.php

 

and

 

catalog/includes/languages/english/modules/content/footer_suffix/cm_footer_extra_copyright.php

 

Confirmed Bug


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

The language file is there.  I tried totally replacing the code in both the module file and the language file using the raw text on git.  Still there.

 

I'll move on to testing the other fixes.

 

 

@@altoid - I can't recreate this.  Could you navigate (in Uni) to:

/includes/languages/english/modules/content/header/cm_header_search.php

and:

1.  ensure it's there

2.  ensure it consists of:

<?php
/*
  $Id$
 
  osCommerce, Open Source E-Commerce Solutions
  http://www.oscommerce.com
 
  Copyright (c) 2014 osCommerce
 
  Released under the GNU General Public License
*/
 
  define('MODULE_CONTENT_HEADER_SEARCH_TITLE', 'Search Box');
  define('MODULE_CONTENT_HEADER_SEARCH_DESCRIPTION', 'Adds your Search Box into the Header Area of your site.');

I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

The language file is there.  I tried totally replacing the code in both the module file and the language file using the raw text on git.  Still there.

Let's see if anyone else has a chance to test and if they see similar to you...and we can then address it.

For now I'm stumped on this one :(


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Let's see if anyone else has a chance to test and if they see similar to you...and we can then address it.

For now I'm stumped on this one :(

 

OK on that.

 

for the check box issue in cm_cs_product_notifications.php, after updating check box in the "Please notify me ...." was centered vertically.

 

post-231701-0-75783600-1421330827_thumb.jpg


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites
Hide dropdown

 

Inside the checkout, hide "site setting" dropdown entirely as it has no value.

 

After updating, the drop down disappears...

 

post-231701-0-42972100-1421331541_thumb.jpg


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×