Jump to content
Latest News: (loading..)
burt

Bugs in GOLD version of 2.3.4-Responsive

Recommended Posts

Please report any bugs here.   Also if you learn that any external libraries have been updated (eg bootstrap, jquery and so on) please post.

Please note that this thread is definitely not for "feature requests" unless that feature is something you found lacking in our implementation of Bootstrap.

CONFIRMED BUGS AND OTHER REQUIRED CHANGES

WEEK 1

  • red required star is misplaced on gender input
     
  • Continue button on checkout_shipping.php - Should be btn-success
     
  • Misplaced div
     
  • checkbox misaligned in forms 
     
  • Move UL into (substr(basename($PHP_SELF), 0, 8) != 'checkout') in Navbar content module
     
  • Double use of FOOTER_TEXT_BODY
     
  • Unwanted Payment Icons
     
  • Extra required input not needed on checkout_new_address

All of the above bugs were fixed and committed to Master on 16/01/2015.  

WEEK 2

  • Typo in account_notifications
     
  • Newsletter text in address module
     
  • Update Bootstrap to v3.3.2

All of the above bugs were fixed and committed to Master on 22/01/2015.  
 
WEEK 3

  • Hardcoded glyphicons in /includes/modules/pages/tp_account.php
     
  • Update photosetgrid to v1.0.1

All of the above bugs were fixed and committed to Master on 30/01/2015.  
 
WEEK 4

  • make flag icons non responsive
     
  • Datepicker Localization
     
  • Update Fontawesome

SOLUTION TESTING
 
Please note that if a Confirmed Bug has been marked as "solved" that solution might not yet be in Master
download, as waiting for users to test them and report back.
 
To test, simply click the [solved] link, and make the changes to your live shop.
Report back any inconsistencies, thank you.
 
Thank you to @@altoid and @@Tsimi for testing.
 
CONFIRMED OTHER CHANGES - will be dealt with at future date

  • Template changes @@GLWalker
     
  • Amend price "button" on product_listing module
     
Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Hi Gary,

 

Thought I would take a look at the bs version, not sure if this is a bug or not, but it looks odd...

 

When viewing action movies in grid view on an android tablet, all is well when the tablet is held landscape (3rows of 3 movies). But if I hold in portrait view, the format seems to be pushed out by the length of the die hard movies title taking up 2 lines. In this view the grid is 1 row of 3, then 1 row of 2, then 1 row of 3, with the last movie being on the 4th row. Below the die hard movie there is a space.


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

@@Mort-lemur

 

Hi Heather,

 

Check if you have "Equal Height Divs" module installed in "admin->modules->header tags".

 

"index.php" should be ticked under "Pages" for the "Equal Height Divs" setting.

 

cheers


My Add-ons
Advanced Cache Control Tool for osCommerce 2.3.x (non-bootstrap) Download Support
Ajax Product Listing for osC 2.3.4 (bootstrap) Download Support
Category New Products Carousel for osC 2.3.4 (bootstrap) Download Support
Category Popular Products Carousel for osC 2.3.4 (bootstrap) Download Support
Customer Testimonials for osCommerce 2.3.4 (bootstrap and non-bootstrap) Download Support
Front Page New Products Carousel for osC 2.3.4 (bootstrap) Download Support

Index Nested - Product Listing for osC 2.3.4 (bootstrapDownload Support
Match Categories in Search Results for osCommerce versions 2.3.x (non-bootstrap) Download Support
Modular Category Page for osC 2.3.4 (bootstrap)
Download Support

NEW Australia Post Shipping Modules for osCommerce 2.3.x (non-bootstrap) Download Support
NEW Equal Height Module for osC 2.3.4 (bootstrapDownload Support
Products Low Stock Report for osC 2.3.x (bootstrap and non-bootstrap) Download Support
Twitter Typeahead Autocomplete Search for osCommerce 2.3.4 (bootstrap and non-bootstrap)
Download Support

Upcoming Products Modules for osC 2.3.4 (bootstrap) Download Support

 
Assisted Add-ons
Scroll Boxes for osCommerce 2.3.x (bootstrap and non-bootstrap) Download Support
 
Bootstrap Add-ons created by other members
osCommerce Bootstrap Addons and Code

Share this post


Link to post
Share on other sites

@@auzStar Thanks Dominic that sorted it.


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

@@Mort-lemur thanks for taking a look, as @@auzStar advice. This was covered in depth in the other thread, lost in the mists of time no wonder you did not see it.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

I have a tiny overlap in account_notifications.php between the title, checkbox and the description

 

Need more info, eg screenshot.  In what size viewport, in what browser.

Does it happen at the http://www.template.me.uk/2334bs3/ test site ? 


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Think that may be the one we were talking about in chat I called the <p> bug but I got confused about which lines as I was updating at the time

 

you can see on

 

http://www.template.me.uk/2334bs3/account_newsletters.php
http://www.template.me.uk/2334bs3/account_notifications.php

 

where a tick box is present the writing overlaps slghtly the tick box

 

not sure  margin  or  <p> </p>  or  ... best answer ??

 

it is mini but guess time to clean up

 

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Think that may be the one we were talking about in chat I called the <p> bug but I got confused about which lines as I was updating at the time

 

Yes, I recall the chat - I thought I had recoded it...


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

In cm_header_search.php

 

We seem to have an out of order div

$search_box = '<div class="searchbox-margin">';
      $search_box .= tep_draw_form('quick_find', tep_href_link('advanced_search_result.php', '', $request_type, false), 'get', 'class="form-horizontal"');
      $search_box .= '  <div class="input-group">' .
                          tep_draw_input_field('keywords', '', 'required placeholder="' . TEXT_SEARCH_PLACEHOLDER . '"') . '<span class="input-group-btn"><button type="submit" class="btn btn-info"><i class="glyphicon glyphicon-search"></i></button></span>' .
                      '  </div>';
      $search_box .= '</div>';
      $search_box .=  tep_hide_session_id() . '</form>';

Should be:

      $search_box = '<div class="searchbox-margin">';
      $search_box .= tep_draw_form('quick_find', tep_href_link('advanced_search_result.php', '', $request_type, false), 'get', 'class="form-horizontal"');
      $search_box .= '  <div class="input-group">' .
                          tep_draw_input_field('keywords', '', 'required placeholder="' . TEXT_SEARCH_PLACEHOLDER . '"') . '<span class="input-group-btn"><button type="submit" class="btn btn-info"><i class="glyphicon glyphicon-search"></i></button></span>' .
                      '  </div>';
      $search_box .=  tep_hide_session_id() . '</form>';
      $search_box .= '</div>';

Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

We seem to have an out of order div

Added to bugs list :thumbsup:


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

All bugs reported so far are now solved.  

Any more inconsistencies found ?

 

Thanks all.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

One very minor thing, when viewing on pc screen, in create account, the "required astrixes" next to the sex check boxes (male / female, not yes please!) appear to be pushed downwards.

 

No real issue for me as I dont ask for this info

 

Whoos!! thanks Gary missed bug 1 above, please ignore

Edited by Mort-lemur

Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

That would be be "confirmed bug #1" in the list above...


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

I've found a weird behavior when checking stock.

 

The newly added rich snippets work fine. Google structured data testing tools sees the products as "out of stock" when Check stock level is enabled; but on the client eye there's no warning about those items until he adds to the cart. In my experience many novice customers get confused when they add to the cart a discontinued item. A disabled buy button or at least a warning would be helpful; I'm not sure if this can be considered a bug, but I see logical that if you can't checkout you shouldn't have a buy now button.

Share this post


Link to post
Share on other sites

I've found a weird behavior when checking stock.

 

The newly added rich snippets work fine. Google structured data testing tools sees the products as "out of stock" when Check stock level is enabled; but on the client eye there's no warning about those items until he adds to the cart. In my experience many novice customers get confused when they add to the cart a discontinued item. A disabled buy button or at least a warning would be helpful; I'm not sure if this can be considered a bug, but I see logical that if you can't checkout you shouldn't have a buy now button.

 

@@piernas 

 

No Juanma it's not a bug. This is standard osc function. But I agree. It would be logical for the customer to know if products are out of stock before they add to cart. (Hopefully it may be included in osc 2.4 version)

 

You can use the code below (osc 2.3.4bs) to disable the "Add to Cart" button in products info page (and sets colour to btn-danger ie red) when product has zero stock. This applies when admin->config->stock settings are "Check stock level" is 'true' and "Allow Checkout" is 'false'.

 

Or you can use this code to hide the button or do what ever you want to do with it.

 

Problem with this code is you would have to apply something similar where ever you can add products to cart. Or you could code something in application top that re-directs customers to products info page, with an out of stock message, similar to how products with attributes are re-directed to product info.

 

There is also this addon "Product Availability Options for 2.3.1" http://addons.oscommerce.com/info/8460 (history says there is an osc 2.3.4 version, probably needs to be adapted to bootstrap) which sounds like it allows you to place stock availalibilty messages. Not sure if the addon has similar code to below. If not, it could be used in conjunction with the code.

 

in product_info.php replace lines 207 to 212:

?>

  <div class="buttonSet row">
    <div class="col-xs-6"><?php echo tep_draw_button(IMAGE_BUTTON_REVIEWS . (($reviews['count'] > 0) ? ' (' . $reviews['count'] . ')' : ''), 'glyphicon glyphicon-comment', tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params())); ?></div>
    <div class="col-xs-6 text-right"><?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_draw_button(IMAGE_BUTTON_IN_CART, 'glyphicon glyphicon-shopping-cart', null, 'primary', null, 'btn-success'); ?></div>
  </div>

with


    $out_of_stock = false;
    if ( (STOCK_CHECK == 'true') && (STOCK_ALLOW_CHECKOUT != 'true') ) {
      if ($product_info['products_quantity'] < 1) {
        $out_of_stock = true;
      }
    }

?>

  <div class="buttonSet row">
    <div class="col-xs-6"><?php echo tep_draw_button(IMAGE_BUTTON_REVIEWS . (($reviews['count'] > 0) ? ' (' . $reviews['count'] . ')' : ''), 'glyphicon glyphicon-comment', tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params())); ?></div>
    <div class="col-xs-6 text-right"><?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_draw_button(IMAGE_BUTTON_IN_CART, 'glyphicon glyphicon-shopping-cart', null, 'primary', ($out_of_stock ? array('params' => 'disabled=true') : null), ($out_of_stock ? 'btn-danger' : 'btn-success')); ?></div>
  </div>

To do it in application top use built-in function:

$stock_left = tep_get_products_stock($HTTP_GET_VARS['products_id']);

 

 

cheers

Edited by auzStar

My Add-ons
Advanced Cache Control Tool for osCommerce 2.3.x (non-bootstrap) Download Support
Ajax Product Listing for osC 2.3.4 (bootstrap) Download Support
Category New Products Carousel for osC 2.3.4 (bootstrap) Download Support
Category Popular Products Carousel for osC 2.3.4 (bootstrap) Download Support
Customer Testimonials for osCommerce 2.3.4 (bootstrap and non-bootstrap) Download Support
Front Page New Products Carousel for osC 2.3.4 (bootstrap) Download Support

Index Nested - Product Listing for osC 2.3.4 (bootstrapDownload Support
Match Categories in Search Results for osCommerce versions 2.3.x (non-bootstrap) Download Support
Modular Category Page for osC 2.3.4 (bootstrap)
Download Support

NEW Australia Post Shipping Modules for osCommerce 2.3.x (non-bootstrap) Download Support
NEW Equal Height Module for osC 2.3.4 (bootstrapDownload Support
Products Low Stock Report for osC 2.3.x (bootstrap and non-bootstrap) Download Support
Twitter Typeahead Autocomplete Search for osCommerce 2.3.4 (bootstrap and non-bootstrap)
Download Support

Upcoming Products Modules for osC 2.3.4 (bootstrap) Download Support

 
Assisted Add-ons
Scroll Boxes for osCommerce 2.3.x (bootstrap and non-bootstrap) Download Support
 
Bootstrap Add-ons created by other members
osCommerce Bootstrap Addons and Code

Share this post


Link to post
Share on other sites

Gary, when clicking on the fields to fill out credit card details the payment method radio button gets deselected. VERY confusing for the customer  :)

 

You can check on my site.


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

@@auzStar - please stop telling people to change core code in this version of osCommerce,  It is what we want to get away from.  The correct advice would be "build a module, use hooks".  

 

@@frankl - which payment method ?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

oops! sorry did it again. :x

Stuck in the past.
 
You can remove that post.
 
I'll try and come up with something better.
 
cheers :)
Edited by auzStar

My Add-ons
Advanced Cache Control Tool for osCommerce 2.3.x (non-bootstrap) Download Support
Ajax Product Listing for osC 2.3.4 (bootstrap) Download Support
Category New Products Carousel for osC 2.3.4 (bootstrap) Download Support
Category Popular Products Carousel for osC 2.3.4 (bootstrap) Download Support
Customer Testimonials for osCommerce 2.3.4 (bootstrap and non-bootstrap) Download Support
Front Page New Products Carousel for osC 2.3.4 (bootstrap) Download Support

Index Nested - Product Listing for osC 2.3.4 (bootstrapDownload Support
Match Categories in Search Results for osCommerce versions 2.3.x (non-bootstrap) Download Support
Modular Category Page for osC 2.3.4 (bootstrap)
Download Support

NEW Australia Post Shipping Modules for osCommerce 2.3.x (non-bootstrap) Download Support
NEW Equal Height Module for osC 2.3.4 (bootstrapDownload Support
Products Low Stock Report for osC 2.3.x (bootstrap and non-bootstrap) Download Support
Twitter Typeahead Autocomplete Search for osCommerce 2.3.4 (bootstrap and non-bootstrap)
Download Support

Upcoming Products Modules for osC 2.3.4 (bootstrap) Download Support

 
Assisted Add-ons
Scroll Boxes for osCommerce 2.3.x (bootstrap and non-bootstrap) Download Support
 
Bootstrap Add-ons created by other members
osCommerce Bootstrap Addons and Code

Share this post


Link to post
Share on other sites

Found that when images are different aspect ratio in reviews get mangled. Tried to apply equal div heights but it seems not to work in these.

 

Also there's no space between image and commentaries.

post-181458-0-40173900-1421147876_thumb.jpg

Edited by piernas

Share this post


Link to post
Share on other sites

Found that when images are different aspect ratio in reviews get mangled. Tried to apply equal div heights but it seems not to work in these.

 

This is not a bug.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

You decided to use images that are not standardised, even though the admin area specifically asks for standardised images (100 by 80 if I recall correctly, and changeable to other dimensions if I recall correctly).  As you decided to ignore that, you now need to sort out any problems this brings in your shop.

 

Again:  not a bug in this version of osCommerce.  

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Thank you for pointing it out and sorry for my mistake. I come from 2.2 and didn't notice the main image specs in admin.

Edited by piernas

Share this post


Link to post
Share on other sites

2.2 to bootstrapped2.3 is a big leap, you are doing well to make that leap :thumbsup:


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×