Jump to content
Sign in to follow this  
rjay

Downloads Controller

Recommended Posts

Hello All,

I am working on updating osCommerce 2.2 Milestone 2 Update 060817 to v2.2 RC2a. This is on a php5 system I orginally had a problem with a 1054 tep stop error you can see that thread Here. The problem that I am having now is that the download link is not showing on check out. There is nothing wrong with the configuration of the store as the links would show previous to the update and the configuration has not changed I also checked the download controller to update it to ver. 5.3.

Any and all suggestions are appreciated.

Thanks


On your last day only you will have to approve or disaprove of how your life has been.

Share this post


Link to post
Share on other sites

Hello All,

I checked that the code in all the modified pages match the newest version of Downloads Controller and that all the files on the server are updated. Yet I still can not get the download button to show. Neither in the checkout_success page nor the order_history_info page

Any help would be appreciated.

Thanks


On your last day only you will have to approve or disaprove of how your life has been.

Share this post


Link to post
Share on other sites

hey people

 

i'm still a newbie to the osc, so please bare with me, i recently uploaded the download contrib to my osc store, and keep getting a fatal error on the admin side, within the payment / shipping module(s) sections, it seems the freeshipper.php and freecharger.php declare an error on line 15 which will not allow the modules to apper on my admin side.

 

example:

 

Fatal error: Cannot redeclare class freeshipper in /data/members/paid/s/o/soundvybe.com/htdocs/shopping/includes/modules/shipping/freeshipper.php on line 15

 

Fatal error: Cannot redeclare class freecharger in /data/members/paid/s/o/soundvybe.com/htdocs/shopping/includes/modules/payment/freecharger.php on line 15

 

as i have no copies of these php files stored in the same directories, i'm totally confused, and would be grateful for any help

 

p.s. i have deleted the freeshipper.php and freecharger.php and the shipping and payment module worked fine, but as soon as i upload these files the module will not display all the php located in there directories.

 

thanks in advance.

Share this post


Link to post
Share on other sites

hi sir

i need your help please

 

i use xp system and i have may site throught lunarpages company ..

i installed your os commerce scripte to sell digital products

 

in the administraion page and under the configurations menue i enabled the download true and redirected false

g zip false

 

and from the file manger i did the permision for download catalog and pub 777 and create tmp fplder and his permission also 777

 

when i mad a test and buy from my self an item i did not found any thing in my account

 

what is the wrong setting i did

please help me

thanks

Share this post


Link to post
Share on other sites

HI Linda,

 

I have installed the download controller and everything is working fine.

 

However, when I test to buy more than one product at the same time, only one product will display teh download link?

 

Do you or anyone else have any idea why there is no download links to other products?

 

BR,

John

Share this post


Link to post
Share on other sites
HI Linda,

 

I have installed the download controller and everything is working fine.

 

However, when I test to buy more than one product at the same time, only one product will display teh download link?

 

Do you or anyone else have any idea why there is no download links to other products?

 

BR,

John

 

HI Again,

 

I managed to fix this by changing the Download by redirect -> true

 

BR,

J

Share this post


Link to post
Share on other sites

Hi,

 

After several hours of reading this thread I have eventually got the download controller to work and allow downloads. However I now have other issues with the admin area of the site.

 

Firstly and most importantly - I cannot edit the payment modules - e.g. when I click on edit for the PayPal module and enter my details, when I click on Save they return to the default settings.

 

Second - no orders are now showing up under the Customer Orders - the page shows no info other then the standard menus and options.

 

Also I have noticed on the Downloads Config page, that the new options for this module are appearing 3 times for each.

 

Any suggestions please?

 

PS - I am using a new install (only last month) so I'm sure it's version 2.2 of osc

Edited by W3net

Share this post


Link to post
Share on other sites

Ok - I've got the Orders area working by replacing it with the original file - didn't really need the extra info anyway...

 

But I'm still having problems entering details on the Payment & Shipping modules - it just won't let me change anything, they always return to default after clicking "Update"....

Share this post


Link to post
Share on other sites

I don't believe this.......

 

In my impatience to get this sorted, I entered my SQL manager and manually changed the values of the PayPal data to what I needed, but now when I go to the stores ULR - I just get a totally blank page - no errors nothing.... even viewing page source gives a blank page...

 

What have I done.....?

Share this post


Link to post
Share on other sites

My bad - I uploaded the wrong configure.php file to the wrong directory - I placed the one from the admin directory in the normal one... Re-uploaded the correct file and all is good - even the paypal option is now correct after manually editing the database...

 

Would still like to know why I can't change these options in the back-end admin area though...

Share this post


Link to post
Share on other sites

Having problems with Downloads Controller...

 

I have installed everything according to instructions. I am getting no error messages, HOWEVER, When I go to purchase a download, (I am using Paypal Website Payments Standard for my payment module) the Paypal screen pops up, payment is made, and then the user is prompted by Paypal to return to the site, where they reach the "checkout_success.php" page saying "Your Order Has Been Processed!" but I do not see a download link or the on hold message on this checkout_success.php page.

 

When customer clicks through to view their order, it says PENDING still.

 

 

In OSC Admin Configuration>Download> Enable Download=true, Download by redirect=true, Downloads Controller Update Status Value=4, Downloads Controller Order Status Value=2.

 

In PayPal Website Payments Standard, Payment Module "Set preparing order status"=PENDING

In PayPal Website Payments Standard, Payment Module "Set PayPal Acknowledged Order Status"= DEFAULT

 

Am I missing something here? How do I get the link to appear or pending message saying pay up? When Payment is made in paypal i thought status was supposed to get changed automatically to 3? Meaning a value greater than 2, so I would get a link right? Please help! Currently I have to go in and manually change status to DELIVERED for link to appear in user area. Is this where link appears using this Controller or will it also appear on checkout_success.php page?

 

Thanks in advance.

Edited by sincitywiz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×