Jump to content

Archived

This topic is now archived and is closed to further replies.

Warp

Version Checker Internal 500 error, fresh install.

Recommended Posts

Hi,

 

Fresh install of oscommerce 2.3.4 and in the admin / Version Checker - it generates a Internal 500 error with a core dump file.

 

Webhost says its a problem with oscommerce.

 

Any suggestions? As I am also having another Internal 500 error with an Australian Post shipping module and I need to see if they are linked.

 

Webhost has asked me to ask osCommerce...

 

Would copy of core file help?

If yes I have uploaded it to here: http://wikisend.com/download/167754/core.216921

 

Thanks


luke

Share this post


Link to post
Share on other sites

osC is known to work perfectly well on PHP 5.4 and (I think) 5.5. Were you trying to use PHP 5.6 or something bleeding edge? Your host should not be trying to make customers run on development-level PHP. If it was PHP 5.5 or lower, that means that their configuration is screwed up somehow. You should not have to drop down to PHP 5.2 (which is obsolete) for any reason.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozenpatches or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

FYI, I develop on PHP5.6.3, where osCommerce runs happily.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Luke had reported a similar error here http://forums.oscommerce.com/topic/398158-contribution-new-australia-post-shipping-modules-for-osc-23x/#entry1709851 where he thought this add-on may have caused the issue. I informed him that the add-on has been tested with osCommerce versions 2.3.1 to 2.3.4 with PHP versions 5.3 and 5.6 without issue and also that osc 2.3.4 is PHP ver 5.4 compatible (and obviously 5.5 and 5.6).

 

He replied with "Yeah I am sure something else is at play".

 

cheers


My Add-ons
Advanced Cache Control Tool for osCommerce 2.3.x (non-bootstrap) Download Support
Ajax Product Listing for osC 2.3.4 (bootstrap) Download Support
Category New Products Carousel for osC 2.3.4 (bootstrap) Download Support
Category Popular Products Carousel for osC 2.3.4 (bootstrap) Download Support
Customer Testimonials for osCommerce 2.3.4 (bootstrap and non-bootstrap) Download Support
Front Page New Products Carousel for osC 2.3.4 (bootstrap) Download Support

Index Nested - Product Listing for osC 2.3.4 (bootstrapDownload Support
Match Categories in Search Results for osCommerce versions 2.3.x (non-bootstrap) Download Support
Modular Category Page for osC 2.3.4 (bootstrap)
Download Support

NEW Australia Post Shipping Modules for osCommerce 2.3.x (non-bootstrap) Download Support
NEW Equal Height Module for osC 2.3.4 (bootstrapDownload Support
Products Low Stock Report for osC 2.3.x (bootstrap and non-bootstrap) Download Support
Twitter Typeahead Autocomplete Search for osCommerce 2.3.4 (bootstrap and non-bootstrap)
Download Support

Upcoming Products Modules for osC 2.3.4 (bootstrap) Download Support

 
Assisted Add-ons
Scroll Boxes for osCommerce 2.3.x (bootstrap and non-bootstrap) Download Support
 
Bootstrap Add-ons created by other members
osCommerce Bootstrap Addons and Code

Share this post


Link to post
Share on other sites

×