Jump to content
DamienH

Stripe - Installed but not showing up in 'install module'

Recommended Posts

Hi there, I was wondering if anybody can help. We are tring to install Stripe as a payment system, and have installed the addon from here: http://addons.oscommerce.com/info/9078

 

The site runs version 2.3.3 of osCommerce, and I know that it is included in the 2.3.4 version core files, but the addon look pretty simple to install, so we were hoping to be able to use it with 2.3.3 for the moment.

 

I have followed the folder structure within the addon zipped files and placed the files here:

 

/ext/modules/content/account/stripe/cards.php
/includes/languages/english/modules/content/account/cm_account_stripe_cards.php
/includes/languages/english/modules/payment/stripe.php
/includes/modules/content/account/cm_account_stripe_cards.php
/includes/modules/payment/stripe.php

 

So after uploading the correct files to the correct folders, we are supposed to see the module @ Administration Tool -> Modules -> Payment -> Install Module page. There are many other payment gateways available on that page, but Stripe has not appeared within that list.

 

Is there something Im missing here?

 

Any help greatly appreciated!

 

p.s. please note that the folder structure outlined in your online installation help guide (http://library.oscommerce.com/Package&en&stripe&oscom23&stripe_js) and in the similar PDF included in the zipped file itself (http://addons.oscommerce.com/info/9078) are different to the folder structure containing the files themselves within the zipped addon. So this did cause some minor confusion as to where the new files should be placed. In the end I went with the actual structure containing the files within the zipped folder itself, not the guide's structure.

 

Share this post


Link to post
Share on other sites

@@wHiTeHaT Cheers for the input, just noticed the portion on the linked page (http://library.oscommerce.com/Package&en&stripe&oscom23&stripe_js) about requiring the 'content' modules functionality.

 

THE SOLUTION: So it looks like we need to upgrade from 2.3.3 to 2.3.4 or add that new 'content' functionality, to enable the Stripe payment module to install/work.

 

Also looks like you can also add it manually to older versions of osCommerce:

http://library.oscommerce.com/Online&en&oscom_2_3&release_notes&v2_3_4#upg15

Content Modules (6+ files) [Perform Steps 1-4]

Edited by DamienH

Share this post


Link to post
Share on other sites

Cheers again for that link Henry, but it was already included by myself in the original 1st post above - twice - so in fairness, it may have been more helpful if you told me why you were sharing that link.

 

I worked it out myself; as I explained in my reply, I had missed the 'Content Modules' release notes link, and I wasnt aware that content modules were only introduced for 2.3.4, therefore 'Content Modules' need to be added to any pre-2.3.4 versions to allow Stripe (and some other payment modules) to work.

 

I hope my own replies explain the solution 100% clearly for any other folks who are having the same issue. Particularly those who are not experts with osCommerce :)

Share this post


Link to post
Share on other sites

@@wHiTeHaT Cheers for the input, just noticed the portion on the linked page (http://library.oscommerce.com/Package&en&stripe&oscom23&stripe_js) about requiring the 'content' modules functionality.

 

THE SOLUTION: So it looks like we need to upgrade from 2.3.3 to 2.3.4 or add that new 'content' functionality, to enable the Stripe payment module to install/work.

 

Also looks like you can also add it manually to older versions of osCommerce:

http://library.oscommerce.com/Online&en&oscom_2_3&release_notes&v2_3_4#upg15

Content Modules (6+ files) [Perform Steps 1-4]

Goodness Damien!! Would it not have been easier to alter the STRIPE files to work with an older version! hahahaa I'm going to have to read all that modification carefully to see where I want to go with this install.. yes I run a much older version of oscMAX with tons of custom mods, so I;m not about to go running off to install a new cart just to use this module! Did you get it working with your cart now??

Edited by wkdwich

Debbie D
Franklin County, VA "Moonshine Capitol of the World"
osCmax Mobile Template oscmaxtemplates.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×