Jump to content
ArtcoInc

Purchase without account for 2.3.4 and BS2334

Recommended Posts

Yes, I forgot to update the version numbering. But the reviews error has gone?

Share this post


Link to post
Share on other sites
1 minute ago, raiwa said:

Yes, I forgot to update the version numbering. But the reviews error has gone?

No Still there. I've tried re-uploading all the files.

Share this post


Link to post
Share on other sites

It works with 1.0.7.5. Newer versions require an update. Coming soon, please be patient. 😉

Share this post


Link to post
Share on other sites
3 minutes ago, raiwa said:

It works with 1.0.7.5. Newer versions require an update. Coming soon, please be patient. 😉

Thank you. Will await your update.

Share this post


Link to post
Share on other sites
22 hours ago, discxpress said:

Thank you. Will await your update.

Hi Lecarl,

Here the admin hook with the fix.

It goes in: includes/hooks/admin/siteWide/

swPwa.php

Please check and report back. I'll then upload the update.

It wasn't related to Phoenix 1.0.7.7 version. This error trhows in all versions.

Thanks and best regards
Rainer

Share this post


Link to post
Share on other sites
Posted (edited)

Please double check that you replaced the file. I got the error with the old version and it disappeared with this one.

line 133 must be:

      if ( !isset($action) || ($action != 'edit' && $action != 'new') ) {

 

Edited by raiwa

Share this post


Link to post
Share on other sites
10 minutes ago, raiwa said:

Please double check that you replaced the file. I got the error with the old version and it disappeared with this one.

line 133 must be:


      if ( !isset($action) || ($action != 'edit' && $action != 'new') ) {

 

Yes that line is correct.

Share this post


Link to post
Share on other sites
Posted (edited)

In the file you downloaded here or also in the file you have uploaded/replaced in your store, please check.

Edited by raiwa

Share this post


Link to post
Share on other sites

Thanks, that helped.

Please change that line 133 to:

      if ( !isset($action) || ($action != 'edit' && $action != 'new' && $action != 'preview') ) {

 

Share this post


Link to post
Share on other sites

Uploaded PWA 4.3.2

Purchase without account 4.3.2

Compatibility:
OSCOM CE Phoenix 1.0.7.5.+.
Tested with Phoenix 1.0.7.7
PHP 7.0-7.3

Changes Version. 4.3.2
- fixed error in admin reviews hook. Thanks to @discxpress
- updated version info in login module. Thanks to @discxpress

Share this post


Link to post
Share on other sites

Hi Rainer,

I tested this on Phoenix 1.0.7.7. I get an empty default address (albeit with a little comma character) during checkout. Upon trying to edit a new address, I get this as shown in the screenshot below.

 

Untitled.thumb.png.6a583461d7af08ae0c6679e3d1b1f6a3.png 

 

Can this be prevented from showing up? Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, kgtee said:

Hi Rainer,

I tested this on Phoenix 1.0.7.7. I get an empty default address (albeit with a little comma character) during checkout. Upon trying to edit a new address, I get this as shown in the screenshot below.

 

Untitled.thumb.png.6a583461d7af08ae0c6679e3d1b1f6a3.png 

 

Can this be prevented from showing up? Thanks!

Hi @kgtee,

I can't reproduce it in my test store. It shows all correct there.

Please check your customer data modules.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×