Jump to content
Harald Ponce de Leon

Looking For Testers: New PayPal App

Recommended Posts

iPad Air, and after disabling return and removing return url, results are the same: "Could not verify the PayPal transacton.  Please try again."  Checked twice.   I can test with Android if need be.

Share this post


Link to post
Share on other sites

I can confirm the problem with the mobile PayPal Payments Standard checkout flow not returning any GET or POST parameters when the customer returns back to the store, and am looking into it.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

With PDT disabled, mobile checkouts do not return any parameters back to the store to verify the transaction and order with. This only happens for mobile checkouts.

 

We've never required PDT however until this is fixed, it will be required and the next module update will support PDT parameters.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

v4.027 has been pushed out with Payments Standard PDT support and admin order transactions for Payments Standard and Hosted Solution.

 

This release also introduces a new known issue where refunds are not working for orders paid with Payments Standard and will be looked into.

Edited by Harald Ponce de Leon

:heart:, osCommerce

Share this post


Link to post
Share on other sites

Herald,  what's your thoughts on putting this on a live shop for "testing" purposes at this point?  It would be a 2.3.4 shop I'd use.

Edited by altoid

I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Herald,  what's your thoughts on putting this on a live shop for "testing" purposes at this point?  It would be a 2.3.4 shop I'd use.

Go ahead :thumbsup: The testing phase was primarily for the migration of module parameter values, automatic retrieval of API Credentials, and the online update feature.

 

The App will be pushed out publicly in the coming days, which you'll be able to update to.

 

It would be great if you could post your thoughts and feedback about the App here :)


:heart:, osCommerce

Share this post


Link to post
Share on other sites

I took a look at the PayPal app and I'll need to some code clean up in this one shop before I install that.  I'll get working on that and get the PP app installed then.  Thanks.


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Hi Shawn..

 

The "apply update" button does not seem to do anything for me.  I have catalog/includes/apps set 777 recursively.

Can you check in catalog/includes/apps/paypal/work/ if any update logs have been saved? It should have the filename of update_log-VERSION.php.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

@@Supertex, that's strange. A lot of error checking has been added to the App to make sure at least some feedback is presented when an error occurs.

 

Could you check the webserver and/or php error log to see if anything is recorded there?


:heart:, osCommerce

Share this post


Link to post
Share on other sites

No relevant entries of any kind on server log.  I haven't seen a php error log, so I'm unsure about that one.  

 

But it's not as though an error is occuring...the 'apply update' simply does nothing at all, and when I mouseover it, the url displayed at the bottom of the browser is just domain.com/admin/#

 

When I click on it, the browser doesn't react at all...no refresh...it behaves as though I didn't do anything.

Share this post


Link to post
Share on other sites

@@Supertex, the button link is loaded through javascript which is why no url is showing for the button. Could you see if any javascript errors are being reported in your browser?

 

Chrome: More Tools -> Javascript Console

Internet Explorer: Developer Tools -> Console

 

An error could be shown when first clicking on the Apply Update button.

Edited by Harald Ponce de Leon

:heart:, osCommerce

Share this post


Link to post
Share on other sites

From IE:

-------------------------------------------------------------------------------------

SCRIPT438: Object doesn't support property or method 'fail'

 

paypal.php, line 436 character 5

 

436      $.get('http://www.mydomain.com/development/admin/paypal.php?action=checkVersion' function (data) {

437      var error = false;
-------------------------------------------------------------------------------------
 
From Chrome:
 
Uncaught TypeError: undefined is not a function                                                        paypal.php?action=update:512
OSCOM.APP.PAYPAL.getUpdates                                                                              paypal.php?action=update:512
(anonymous function)                                                                                                  paypal.php?action=update:512
c.extend.ready                                                                                                             jquery-1.4.2.min.js:26
L                                                                                                                                  jquery-1.4.2.min.js:33
Edited by Supertex

Share this post


Link to post
Share on other sites

@@Supertex Could you post the jQuery version being used on your admin installation? It should be visible in the html source code of the page, something like:

 

<script type="text/javascript" src="https://store/ext/jquery/jquery-1.11.1.min.js"></script>

:heart:, osCommerce

Share this post


Link to post
Share on other sites

@@Supertex I just noticed your updated post. You're using jQuery 1.4.2 which a jQuery function is not available to. I will add in some code to detect this to prevent the error happening to someone else.

 

Until you update your jQuery version you won't be able to apply online updates automatically :( Would you be able to update your jQuery version to at least 1.5? You could use a newer jQuery version for your admin side and keep 1.4.2 for your catalog side.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

Here is the url to try jQuery 1.5:

 

http://code.jquery.com/jquery-1.5.min.js
Download that and copy it to catalog/ext/jquery/ and update the url in your admin template.

 

You could also use the latest jQuery version however I don't know if that will conflict with your template.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

k...copied the text in the address above, saved as 1.4.2 after changing the extension on the original.

 

Now, the button reacts by changing to "Applying Updates" but appears to hang.

 

IE console: 

 

SCRIPT438: Object doesn't support property or method 'getElementsByTagName' 
jquery-1.4.2.min.js, line 16 character 59008
 
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×