Jump to content

Archived

This topic is now archived and is closed to further replies.

oscarfellini

Mystery application_top.php error - Store Down

Recommended Posts

I get the following error when trying to load my store. Any thoughts?  I've opened a ticket with my host but they are notoriously slow. Could this be a PHP error? Perhaps they made a change that affects my shop?

 

Running OSCommerce 2.3 (or 2.2... haven't looked under the hood for a long while)

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in /home/dcdc6815/public_html/shop/includes/application_top.php on line 290

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in /home/dcdc6815/public_html/shop/includes/application_top.php on line 290

 

Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dcdc6815/public_html/shop/includes/application_top.php on line 290

Share this post


Link to post
Share on other sites

I actually just accessed the site... but admin isn't working. Now getting the following error (same as before only a different line):

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in /home/dcdc6815/public_html/shop/admin/includes/application_top.php on line 167

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in /home/dcdc6815/public_html/shop/admin/includes/application_top.php on line 167

Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dcdc6815/public_html/shop/admin/includes/application_top.php on line 167

Share this post


Link to post
Share on other sites

This was a known problem with oscommerce 2.3.1 upgrade guide below

 

http://library.oscommerce.com/Online&en&oscom_2_3&release_notes

 

You need first to find out what version you are using before the 2.3... series this can be seen in includes/application_top.php  towards the start of the file.

 

If it is a 2.3... version this can be checked in admin (version checker)

 

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Thank-you Joli,

 

I've checked the file and it looks like I have 2.3 - however it was found in application_top.php. I'm not able to access the site admin. Unless you're referring to the version_check.php which I've looked over. No indication from the file what specific version of 2.3 I'm running. *sigh*

Share this post


Link to post
Share on other sites

If it is a 2.3 store download includes/version.php  open and check if it is a pre 2.3 store the version will be written in includes/application_top.php (download and check.)

 

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Thank-you Joli,

 

Done. It is infact 2.3.1. A quick look at the release notes and I don't see a direct mention of my problem. Will keep looking. 

Share this post


Link to post
Share on other sites

×