Jump to content
Latest News: (loading..)
Sign in to follow this  
pol1

PayPal Pro Hosted Blank Page

Recommended Posts

Our server was upgraded 2 nights ago to PHP 5.4.30, MySql 5.5 & Apache 2.4.9, consequently our shops stopped working. I have managed to get them going again however the Paypal Pro Hosted module were were using just gives a blank screen no error nothing. 

 

I have been battling with this since the upgrade and can find no solution or even a hint anywhere, can ANYONE help please. 

 

I am using V2.2 rc1 but this has been hugely updated as tech has moved on, I know we need to upgrade and we are in the process of doing so but I need a fix NOW to get these shops back up and running asap.

 

Thanks in advance for any help. 

Share this post


Link to post
Share on other sites

Hello Harald and thanks for your reply.

 

We are using the following module and have been since sept 2012, without any real issue  http://addons.oscommerce.com/info/8481

 

Last night I looked at this module http://addons.oscommerce.com/info/9072/v,23 and tried to integrate and followed this thread http://forums.oscommerce.com/topic/397141-hosted-solution-and-22ms2/ including all your solutions but all I got the same issue a blank screen.

 

Regards

 

Liz (Michael is the boss, I am IT) 

Edited by pol1

Share this post


Link to post
Share on other sites

Hi Liz..

 

Please have someone check your web server access and error logs and see if PHP is reporting any errors when accessing that page. We need to know what PHP is reporting to help further.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

Sadly Harald trying to get the most basic of help from hosting support these days is rather difficult. I have been chatting for nearly 2 hours now with support and they have only just said it may be a permissions issue but I am not holding my breath. 

 

I can see no PHP errors, the only errors I can see are Apache as follows 

 

[Thu Jul 17 11:31:24.306058 2014] [autoindex:error] [pid 17686] [client 79.77.4.159:59639] AH01276: Cannot serve directory /home/xxxxxx/public_html/catalog/images/: No matching DirectoryIndex (index.html.var,index.htm,index.html,index.shtml,index.xhtml,index.wml,index.perl,index.pl,index.plx,index.ppl,index.cgi,index.jsp,index.js,index.jp,index.php4,index.php3,index.php,index.phtml,default.htm,default.html,home.htm,index.php5,Default.html,Default.htm,home.html)

 

4 of these for each attempt to make payment. 

Share this post


Link to post
Share on other sites

Oh well that is good news or at least positive information.

 

The blank page is only showing on the payment module page, this file catalog/ext/modules/payment/paypal/checkout.php after checkout confirmation.

Share this post


Link to post
Share on other sites

Hi Harald, overnight I received the following information from the hosting co

 

[Thu Jul 17 15:33:40.605268 2014] [core:error] [pid 285847] [client 79.77.4.159:62215] malformed header from script 'checkout.php': Bad header:
[Thu Jul 17 15:33:40.619612 2014] [cgi:error] [pid 285847] [client 79.77.4.159:62215] AH01215: suexec policy violation: see suexec log for more details
[Thu Jul 17 15:33:40.619873 2014] [cgi:error] [pid 285847] [client 79.77.4.159:62215] End of script output before headers: 500.php
[Thu Jul 17 15:35:43.036929 2014] [core:error] [pid 305635] [client 79.77.4.159:62264] malformed header from script 'checkout.php': Bad header:
, referer: https://christmaschristmas.co.uk/catalog/checkout_confirmation.php
[Thu Jul 17 15:35:43.052197 2014] [cgi:error] [pid 305635] [client 79.77.4.159:62264] AH01215: suexec policy violation: see suexec log for more details, referer: https://christmaschristmas.co.uk/catalog/checkout_confirmation.php
[Thu Jul 17 15:35:43.052484 2014] [cgi:error] [pid 305635] [client 79.77.4.159:62264] End of script output before headers: 500.php, referer: https://christmaschristmas.co.uk/catalog/checkout_confirmation.php

Share this post


Link to post
Share on other sites

Hi Harald, well things are looking up. I have managed to install your new version of Pro Hosted and payments are being taken and received successfully. The only problem I face is once the payment has been made Paypal redirects to shopping_cart instead of checkout_success so the customer may get confused as to whether the order has gone through or not ... any ideas?

 

For anyone else in this position, I had already tried this module and it did not work however this time I uninstalled all PayPal modules and started afresh and that seemed to do the trick, just need to sort the redirect as previously mentioned. (PS Backup up first, just in case :) )

Share this post


Link to post
Share on other sites

Hi Harald, further to my lest message the order confirmation emails are also not being sent. 

 

I have tried many possible fixes for this that I have found searching around but nothing seems to work. Any ideas at all?

Share this post


Link to post
Share on other sites

Hi Liz..

 

Is an error message shown on the shopping cart page?

 

Have you entered your email address in the Debug E-Mail Address module parameter? If not can you, and try another order. This time you should receive an e-mail with the parameters used for the transaction. Could you post that here and delete and personal/sensitive information.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

Hi Harald, 

 

No errors on the shopping_cart page, debug email address is and always has been present in the module and no errors are received.

 

Sorry not very helpful I know :(

Share this post


Link to post
Share on other sites

This issue has been fixed. The reason why the customer was redirected to the shopping cart page was due to the transaction not being able to be verified. The Seller E-Mail Address module parameter was filled in with the store owners PayPal e-mail address however that address was not the primary PayPal account e-mail address. Entering the primary e-mail address into the Primary E-Mail Address module parameter allowed the transactions to be verified successfully.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×