Jump to content
Daniela2

Braintree error messages

Recommended Posts

With the very appreciated help from Harald, the Modules problems I had in the previous posts are fixed.

 

I did a few other things on the site and also started to create the Sandbox, using the manual provided with the Braintree Module. I checked several times that the settings in the payment module are the same as the one I set up in the sandbox.

 

Excited as I was .... logged into the store after creating a 10 cent product and tried to make a sandbox payment.... and got this error message, no matter whatever card I used

 

The card number was not able to be processed. Please try again and if problems persist, please try another payment method.

 

Does anyone have an idea what is going wrong ?

 

Share this post


Link to post
Share on other sites

All right... it looks like I got it to work within the sandbox.

I had to play around a little bit with settings and also had to change and replace ID´s which are required in the Payment Module.

 

The error messages within OSC are a little bit weird and are not really helpful in determining the problem but it is still possible to figure out what the problem is if you switch back and force between sandbox account and admin payment modul

 

This page might be useful for whom ever want´s to have Braintree as a Payment Processor in his shop:

 

https://developers.braintreepayments.com/javascript+ruby/reference/general/testing

 

Here are credit card numbers listed and what ever information is needed in order to create  errors and test transactions for the sandbox.

 

Also the support from Braintree is very very helpful and in my case very patients is explaining everything very detailed supported with links where I could get further instructions and examples.

Share this post


Link to post
Share on other sites

Hi Daniela,

 

I have just been attempting to use the Braintree module on my OSC today, and am running into exactly the same problem as you, receiving only the message "The card number was not able to be processed. Please try again and if problems persist, please try another payment method." May I ask how you fixed this, or, could you perhaps list all your module settings, so that I can try it out also? 

 

NB. I am currently running OSC2.3.3, not 2.3.4 - not sure if that is also a factor..

 

Many thanks,

Nicholas

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×