Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Daniela2

Braintree Configuration Won't Save

Recommended Posts

Hi

 

I kind off have the same problem with this module.

i opened an account with braintree and did made all the settings at the braintree home page,

than transferred the datas over to the edited breintree module in the control panel of the store.

This is the error message I get when I hit the save button:

 

This module will not load until a merchant account has been defined for the USD currency.

 

The funny thing is, that i am inserting a merchant account ID but when ever i click on safe..... the ID is not stored

and therefore the payment option is not showing up on the check-out page and produces an error in the

checkout_success.php  on line 31 (which is probably logical... since there is nothing to process and therefor no

succes can be reported)

 

Though... how do I get the merchand account ID into the system?

do i really have to dig into the database and insert it there manually ?

 

ohh... I have OSC version 2.3.4 and its pretty much a new installation so far

 

Thank you very much for any help or ideas

Share this post


Link to post
Share on other sites

Daniela, thank you for providing me access to your store admin. The problem you are describing is not in relation with the Braintree payment module but with a general installation of your store.

 

Your Administration Tool is trying to access the following files:

  • ext/jquery/ui/redmond/jquery-ui-1.10.4.min.css
  • ext/jquery/jquery-1.11.1.min.js
  • ext/jquery/ui/jquery-ui-1.10.4.min.js
  • ext/flot/jquery.flot.min.js
  • ext/flot/jquery.flot.time.min.js

However non of them are publicly available. This explains why your Administration Tool is malfunctioning. If there is a .htaccess file in ext/ then remove it and see if it helps.

 

On the other hand, this is what your shop is trying to load:

  • ext/jquery/jquery-1.8.0.min.js
  • ext/jquery/ui/jquery-ui-1.8.22.min.js 

which are also not publicly available. Both your shop frontend and admin backend are trying to load different versions of the javascript libraries it requires.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

Hi Harald

 

Thank you very much for looking into this problem.

I was looking for the ext folder via ftp, but there is no htaccess file in this directory, only folders.

 

I did install the oscommerceforyou_014 template wich is providing the tow files the shop is trying to load

Though this is the explanation of the difference between backend and frontend.

This means, that I have to replace the updated files with the original files again and than it should work

with the payment processor ?

But than the frontend is looking kind of cricked again.....  :-(

Share this post


Link to post
Share on other sites

The half way cut off letters on the left site have been like this from the beginning on right after the installation

 

Is there a possibillity that I did something wrong with the installation ?

would it help, if i set the permissioins again and run the installation again?

I am just assuming, that in this case all of the stored goods are gone than

Edited by Daniela2

Share this post


Link to post
Share on other sites

in /ext/jquery/ 

jquery-1.11.1.min.js

 

and in /ext/jquery/ui/

jquery-ui-1.10.4.min.js       plus the folders  "redmond"   and  "i18n"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×