Jump to content
uncommonhound

Can't get Braintree Payment Module to work.

Recommended Posts

Hello, I've used osCommerce for my online store for over 6 years. It is highly modified and still at v2.2 RC2a. (I've kept up with security updates) The php version is 5.3.28 (which is also being upgraded shortly) Now I'm in the process of a complete upgrade, which will take me quite a few months. In the meantime I'm trying to move over to Braintree Credit card processing as Elavon/Authnet fees are killing me. I just can't get it to work. 

 

Currently I use the authnet AIM module which shows on the checkout payment page (check_payment.php). I installed Braintree and added all the configuration in the admin area but I can't get it to show on the payment page at all. I've checked the database and everything is there. It doesn't have the same sort order as any other payment module. I am not getting any errors. Other payment modules show up fine there. 

 

I'm not sure where else to look... Braintree isn't found anywhere in any of the forum searches I've done. 

 

Please can someone help me? Thanks...

Share this post


Link to post
Share on other sites

Thanks Manoj, I have checked the admin configuration multiple times, and tried different sort orders.. 0, 1, 01, 3. I wasn't sure if this version maybe isn't compatible with v2.2 rc2?

Share this post


Link to post
Share on other sites

Do you mean it's not shown as an option on the checkout payment page?

 

Are there any important messages shown on the module configuration page?

 

Do you have a merchant account configured for your store currency in the module configuration page?


:heart:, osCommerce

Share this post


Link to post
Share on other sites

I seem to have the same problem.. with both the braintree module and the stripe module (which looks to be similar code). 2.2-MS2 on PHP 5.4, yes I know I will upgrade soon, but I would really like to get this going before I update.

 

Payment doesn't have a selection on checkout.. other payment modules work, so multiple payment modules show up fine. Both the braintree and stripe modules (braintree-1.1 and stripe-1.1) do not show up.. one curious note the braintree module will NOT display the "Merchant Accounts USD:" field.. I found the config option in the database and put in a value there and still nothing.

 

The payment count in checkout_payment.php does not show these modules when they are active (ie, if I have my regular CC, braintree and stripe, it will so payment count as 1, not 3 as it should) so it is as if they are not there.

 

Something is not right.. I'm just not sure where to look now. Anyone have luck with these modules on an older 2.2 shop? I may just have to force myself to hardcode stripe into checkout_payment.php or something.

 

Thanks for any help

 

Regards,

-Moses

Share this post


Link to post
Share on other sites

Same problem here. After saving the merchant account in admin it is not retained. Just like Moses I inserted the merchant account directly into the database but that didn't help either.

 

Thanks in advance for any help.

 

Best,

Johan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×