Jump to content
Latest News: (loading..)
gomjabar

Theme Switcher and Oscommerce 2.3.4

Recommended Posts

Looks like the latest version of Theme Switcher 1.4.3 isn't going to work with Oscommerce 2.3.4. Seems that the catalog/includes/template_top.php from the Theme Switcher package is coded for bxGallery/Fancybox rather than the new Colorbox setup in oscommerce 2.3.4. Anybody out there have theme switcher working with the 2.3.4 version?

 

Share this post


Link to post
Share on other sites

It's not all that hard to patch the new template_top.php. In any case, I've uploaded a new version that matches osCommerce 2.3.4. Have at it.

 

You're lucky I spotted this thread. Using the support thread for Theme Switcher works much better. Hint.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hey, Jim, thanks for the quick response and the template_top.php patch. No problems so far. Time to check out some nifty

themes at themeroller.

 

Best wishes

 

Tadeusz

Share this post


Link to post
Share on other sites

Hello there

 

My problem is, after correct installing in the file ht_theme_switcher ( includes/modules/ header_tag/) I have to remove the following lines: 

$theme_text = '<script type="text/javascript" src="ext/jquery/jquery-' . $jquery_version . '.min.js"></script>' . PHP_EOL;
$theme_text .= '<script type="text/javascript" src="ext/jquery/ui/jquery-ui-' . $jquery_ui_version . '.min.js"></script>' . PHP_EOL;
$theme_text .= '<link rel="stylesheet" type="text/css" href="ext/jquery/ui/' . $theme_name . '/jquery-ui-' . $jquery_ui_version . '.min.css" />' . PHP_EOL;

 

to make the theme switcher working. When I leave them, the add pictures in the product page are all the same size, no small pictures. Fine, this works but when I try to change the theme, nothing happend. I made all the steps as per description. Where could be that mistake?

 

Thank you for helping

Share this post


Link to post
Share on other sites

Removing those lines will completely disable the Theme Switcher. When you say you "have" to remove them, please explain what you mean.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

When I leave the code in original, then the product pictures are in a line from up to down and all have the same size. If I take this code out, the site (product pictures ) are as it has to be.

Also in the  source  code I have a problem, these codes are twice in the source code and that's why I was thinking to chang the code of the  ht_theme_switcher.

<script type="text/javascript" src="ext/jquery/jquery-1.11.1.min.js"></script>

<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.10.4.min.js"></script>


<link rel="stylesheet" type="text/css" href="ext/jquery/ui/redmond/jquery-ui-1.10.4.min.css" />

 

I hope you understand what I try to explain

Share this post


Link to post
Share on other sites

You changed the wrong place. You need to remove those lines from includes/template_top.php. Use the version of template_top.php that ships with the Theme Switcher addon, or compare it to yours to see what to change.

 

Anything that still doesn't work after that is a compatibility problem with the jQueryUI file. Make sure that you are using jQueryUI version 1.10 or higher, and that your template is from the same version.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Ok Jim, I done it as you told me. Now the theme switcher is working, very good, Thank you. But still the add pictures are still same size as the first picture. I do not know how to reduce the add pictures.

 

Any suggestion?

 

Thank you for helping

Share this post


Link to post
Share on other sites

Dear Jim

 

Something very strange: I removed them as you told me and now they are still in the source code. What I am doing wrong? :(

Share this post


Link to post
Share on other sites

Dear Jim, sorry for bothering you, now it works. I removed the line <?php echo $oscTemplate->getBlocks('header_tags'); ?>

because it was twice in the template_top.php.

 

Again thank you for your assistence. Great work

 

:)

Share this post


Link to post
Share on other sites

Decided to test out some new themes from themeroller via theme switcher 1.4.4 for osCommerce 2.3.4. I notice in the instructions that you are to take the new jquery ui file and rename it jquery-ui-###.custom.min.js. to jquery-ui-###.min.js. In my particular case the new jquery file is: jquery-ui-1.10.4.custom.min.js. This woud be be renamed: jquery-ui-1.10.4.min.js.. You are then to copy jquery-ui-1.10.4.min.js into the catalog/ext/jquery/ui/. However, there is already a file with the same name there. I take that that I should rename the old file before copying the new one into this folder. Also, I'm not quite sure what happens when you revert to a previous theme and you've replaced or renamed the original jquery-ui-###.min.js that came with it.

 

Sincerely,

Tadeusz

Share this post


Link to post
Share on other sites

There is no need to replace the jquery-ui-1.10.4.min.js if you already have that version. That instruction is mostly for people who are still running older versions.

 

As always, keep a backup of all of your old files and your database in case you need to revert. You shouldn't have to, but that's always the safest policy.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@kymation

 

I have OSC Edge version. How will I go about removing the rounded corners from the boxes, breadcrumb and buttons? I'm trying to achieve a "flat" look.

 

Excuse me if I posted in wrong thread.

 

Thanks

Share this post


Link to post
Share on other sites

The corners are generated by the theme, if I remember correctly. Use one of the theme generators available online to create a new theme and set corner radius to 0. I believe there is a link to a theme generator in the support thread for Theme Switcher, but there are many to choose from.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi All

I've just recently installed oscommerce and this fairly new to it, I've come across the theme switcher add on and wanted to know a few things with respect to using and installing it. 

I've installed oscommerce 2.3.4 but have come across a few posts on the forum about a bootstrap version? Can anyone shed some light on the differences and which would be better to use as a starting point to an online store. 

Also tried installing theme switcher  (v 1.5.3) )by replacing the necessary files in the necessary locations but for some reason, I couldn't find the module on the admin page under header tags, it just wasn't showing up. Thereafter I replaced the files with the bootstrap version and managed to get the module to show up in the header tags section but, as expected, my layout and template got severely messed up. 

I've currently downloaded the theme switcher 1.4.4 version and tried with that but again the module won't show up under install new module, and furthermore now my site won't load at all, I can only access the admin page, trying to access my main home page chrome says that "this page cannot be loaded".

Would really really appreciate it if some kind soul out there can assist in this regard.  

Share this post


Link to post
Share on other sites

Yes there is a Bootstrap version of osCommerce. The Bootstrap version is responsive, so pages automatically resize to fit the device screen. Since you are just starting out, I highly recommend using it.

I suggest using the edge version from this thread. I also recommend that you scan through the rest of that thread, as it contains a list of most of the Addons available for the Bootstrap version. If you really need something that is not on that list, check the Apps page to see if it has been updated.

The one disadvantage to using this version is that you cannot easily use old Addons from previous versions. That's due to the extensive changes needed to make it both responsive and modular. 

When adding Theme Switcher, as with any Addon/App, pay particular attention to the file locations. Read the instructions for more help on where the files must go. A misplaced file is the most common cause of an installation error.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
On 7/23/2017 at 11:15 PM, kymation said:

Yes there is a Bootstrap version of osCommerce. The Bootstrap version is responsive, so pages automatically resize to fit the device screen. Since you are just starting out, I highly recommend using it.

I suggest using the edge version from this thread. I also recommend that you scan through the rest of that thread, as it contains a list of most of the Addons available for the Bootstrap version. If you really need something that is not on that list, check the Apps page to see if it has been updated.

The one disadvantage to using this version is that you cannot easily use old Addons from previous versions. That's due to the extensive changes needed to make it both responsive and modular. 

When adding Theme Switcher, as with any Addon/App, pay particular attention to the file locations. Read the instructions for more help on where the files must go. A misplaced file is the most common cause of an installation error.

Regards

Jim

1

Thanks a lot, Jim, I really appreciate the time taken out to enlighten me. 

I've been very sure to place the files in the correct directories but still have had no luck, I will perhaps proceed with a fresh install and try again just in case some of the files may have been unknowingly tampered with, however as you've recommended, I think I will first attempt using the bootstrap version in the link you've provided and give theme switcher a go with that version.

 

Thanks a million ! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×