Jump to content
salvawebco

Google XML Sitemap SEO with Ultimate SEO in osc 2.3.3.4

Recommended Posts

the googlesitemap/index.php show me this error and the files generated are 0 bytes, somebody could helpme please, thanks

 

Notice: Use of undefined constant DIR_WS_HTTP_CATALOG - assumed 'DIR_WS_HTTP_CATALOG' in /opt/lampp/htdocs/tienda/googlesitemap/index.php on line 46

Opening   /opt/lampp/htdocs/tienda/sitemapproducts.xmlFS_CAT    /opt/lampp/htdocs/tienda/Server    http://localhostSave Path /opt/lampp/htdocs/tienda/WS_CAT    /tienda/ ERROR: Google Product Sitemap Generation FAILED!Opening   /opt/lampp/htdocs/tienda/sitemapcategories.xmlFS_CAT    /opt/lampp/htdocs/tienda/Server    http://localhostSave Path /opt/lampp/htdocs/tienda/WS_CAT    /tienda/ ERROR: Google Category Sitemap Generation FAILED!Opening   /opt/lampp/htdocs/tienda/sitemapmanufacturers.xmlFS_CAT    /opt/lampp/htdocs/tienda/Server    http://localhostSave Path /opt/lampp/htdocs/tienda/WS_CAT    /tienda/ ERROR: Google Manufacturers Sitemap Generation FAILED!Opening   /opt/lampp/htdocs/tienda/sitemappages.xmlFS_CAT    /opt/lampp/htdocs/tienda/Server    http://localhostSave Path /opt/lampp/htdocs/tienda/WS_CAT    /tienda/ ERROR: Google Pages Sitemap Generation FAILED!Google Sitemap Specials not generated - no specials found!ERROR: Google Topics Sitemap Generation FAILED!Opening   /opt/lampp/htdocs/tienda/sitemapindex.xmlFS_CAT    /opt/lampp/htdocs/tienda/Server    http://localhostSave Path /opt/lampp/htdocs/tienda/WS_CAT    /tienda/ ERROR: Google Sitemap Index Generation FAILED!Array(    [QUERY] => Array        (            [PRODUCTS] => Array                (                    [STATUS] => success                    [NUM_ROWS] => 15                )            [CATEOGRY] => Array                (                    [STATUS] => success                    [NUM_ROWS] => 38                )            [MANUFACTURERS] => Array                (                    [STATUS] => success                    [NUM_ROWS] => 7                )            [SPECIALS] => Array                (                    [STATUS] => success                    [NUM_ROWS] => 0                )            [TOPICS] => Array                (                    [STATUS] => false                    [NUM_ROWS] => 0                )        )    [SAVE_FILE_XML] => Array        (            [0] => Array                (                    [file] => /opt/lampp/htdocs/tienda/sitemapproducts.xml                    [status] => failure                    [file_exists] => true                )            [1] => Array                (                    [file] => /opt/lampp/htdocs/tienda/sitemapcategories.xml                    [status] => failure                    [file_exists] => true                )            [2] => Array                (                    [file] => /opt/lampp/htdocs/tienda/sitemapmanufacturers.xml                    [status] => failure                    [file_exists] => true                )            [3] => Array                (                    [file] => /opt/lampp/htdocs/tienda/sitemappages.xml                    [status] => failure                    [file_exists] => true                )            [4] => Array                (                    [file] => /opt/lampp/htdocs/tienda/sitemapindex.xml                    [status] => failure                    [file_exists] => true                )        ))

Share this post


Link to post
Share on other sites

It would be interesting to see what the value for DIR_WS_HTTP_CATALOG is set to in /includes/configure.php.

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

I ran the code and received this message

CONGRATULATIONS! All files generated successfully.

But went to the XML files generated and found they were blank Checked permissions and all are 777

Using new 2.3.4 any suggestions where to look?

Thanks in advance


"Do what I'm thinking Not what I said." https:windowanddoorparts.us

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×