Jump to content
Mort-lemur

Paypal Standard Not Emptying Basket

Recommended Posts

*** HERE IS THE SOLUTION ***

 

In your PayPal account Profile -> Selling Preferences -> Website Payment Preferences page:

 

Turn Payment Data Transfer OFF!

 

Who told you to turn that on in the first place? :D


:heart:, osCommerce

Share this post


Link to post
Share on other sites

@@joli1811 are you also experiencing problems when returning back to your store from PayPal?

 

@@Harald Ponce de Leon

 

No I am having no problems but keeping an eye on things

 

just thought I would post a positive debug mail from paypal  as well 2.3.4

 

Regards

Joli

 

PS: Should I be getting debug mails with a successful transaction??

Edited by joli1811

To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

osc 2.3.4 

 

Strange payment is going through order is recorded in admin everything is perfect another debug mail   below

.

I am using paypal standard version 3.1 with matts better checkout

 

Turn Payment Data Transfer OFF so will see now I do not have access to the paypal account as the site is for a customer.

$HTTP_GET_VARS:

Array
(
[tx] => 7E513117NS300015G
[st] => Completed
[amt] => 26.55
[cc] => USD
[cm] =>
[item_number] =>

[sig] => ER2oOaKNrNRU63OTXf31m6Vnw8Xh1skH5M98PD5dAsrar7ZK+CDYAKRqndgRD+AgvJOviu/i3k5Uncor7Vse7xNylIuMwkONO5ngaREX/y4pzyIuzUMWyOLUeKJq/MS/a/lte7eqYZYkp2SpANFRUYrxaq0sMFvxtKT2QnQF8uo=
)

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Payment Data Transfer was already turned off.  Still having problems.  Here is my Debug E-mail (minus some of the personal information).

 

Note: Auto Return for Website Payments is also turned off, should that be?

 

--------

 

RESPONSE:

INVALID

$HTTP_POST_VARS:

Array
(
   [mc_gross] => 0.01
   [invoice] => 440
   [protection_eligibility] => Eligible
   [address_status] => confirmed
   [item_number1] => 
   [payer_id] => MB2BR4KUDU5J6
   [tax] => 0.00
   [address_street] => --REMOVED --
   [payment_date] => 10:09:23 Jun 27, 2014 PDT
   [payment_status] => Completed
   [charset] => UTF-8
   [address_zip] => --REMOVED --
   [mc_shipping] => 0.00
   [mc_handling] => 0.00
   [first_name] => --REMOVED --
   [mc_fee] => 0.01
   [address_country_code] => US
   [address_name] => --REMOVED --
   [notify_version] => 3.8
   [custom] => 9
   [payer_status] => verified
   [business] => --REMOVED --
   [address_country] => United States
   [num_cart_items] => 1
   [mc_handling1] => 0.00
   [address_city] => --REMOVED --
   [payer_email] => --REMOVED --
   [verify_sign] => A--8MSCLabuvN8L.-MHjxC9uypBtAgg7p-GZtPYn2RnEb.yTd.2grkE.
   [mc_shipping1] => 0.00
   [tax1] => 0.00
   [txn_id] => 77R38419G07365722
   [payment_type] => instant
   [payer_business_name] => --REMOVED --
   [last_name] => --REMOVED --
   [item_name1] => Custom Plaque
   [address_state] => --REMOVED --
   [receiver_email] => --REMOVED --
   [payment_fee] => 0.01
   [quantity1] => 1
   [receiver_id] => 3BB5L8DHJPZZ6
   [txn_type] => cart
   [mc_gross_1] => 0.01
   [mc_currency] => USD
   [residence_country] => US
   [transaction_subject] => 9
   [payment_gross] => 0.01
   [auth] => AJzijKVSo7yNBhY0EsYKoqwqr-Yfe3VdEDRzDWnBU-O9czCNZ.7M2AMEHqapy2f5HZwDlF9qMwCPq7md4neV5Xw
)

Share this post


Link to post
Share on other sites

@@Renowne The parameters you are getting are in correct order.

 

Did you get a IPN entry in the order status history?

 

Do you have Verify SSL Certificate enabled in the payment module configuration settings? If so, can you successfully perform a connection test? (the link is available in the module configuration page)


:heart:, osCommerce

Share this post


Link to post
Share on other sites

@@Harald Ponce de Leon

 

Yes, I got a message that said PayPal IPN Verified with a transaction ID.

 

I do have the Verify SSL Certificate enabled in the payment module.  I did run the API test and was successful, but just tried it again and am getting a failure of about 50%.  Not sure what is going on.

Share this post


Link to post
Share on other sites

@@Harald Ponce de Leon

 

I disabled the Verify SSL Certificate.  The order transaction processed just fine (same as before).  But the shopping cart still did not empty when I returned to osCommerce.  The debug email still states RESPONSE: INVALID

Share this post


Link to post
Share on other sites

@@Harald Ponce de Leon

 

Hi Harald

 

Did another run with PayPal Standard v3.2 but this time in "live" mode. And everything went through. Line items OK, VAT OK, return to checkout success page OK, E-Mail received OK.

Maybe the sandbox mode didn't work as it should.

Share this post


Link to post
Share on other sites

@@Tsimi Did you disable PDT for the sandbox account?

 

Those testing with sandbox accounts need to make sure they disable PDT in their sandbox account (https://www.sandbox.paypal.com).

 

Those using live accounts need to make sure they disable PDT in their live account (https://www.paypal.com)

 

PDT should be off by default.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

Yep, PDT was "off" by default in "sandbox" and "live" account. Never really touched these settings.

 

Can you email me your sandbox account username and password? I'd like to perform some tests with the account.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

@@Harald Ponce de Leon

 

Yeah I know. Last time it was same. I got kicked back to a full or empty basket and when you tested it everything went fine.

I don't understand why this happens but it doesn't really matter anymore since in live mode everything seems to run just fine.

My shop went live today and I did some test orders just to make sure and it works as it should.

Thanks again for your patience and time.

Share this post


Link to post
Share on other sites

Ok - with the help of Tsimi's sandbox account from Japan (with a Japanese address), I tracked down another problem relating to encoding that could fail the verification of the transaction if it contained special characters.

 

The solution to this problem is to set your seller account profile to the same encoding as your shop (UTF-8 by default). In Tsimi's sandbox account it was set to Japanese / Shift_JIS.

 

This can be set on the PayPal -> Profile -> Selling Preferences -> Language Encoding -> More Options page.


:heart:, osCommerce

Share this post


Link to post
Share on other sites

This means the checking does not use the same verification as within the paypal verification.In this case the ipn.

 

This has nothing to do with the IPN, but anyway what happens if the IPN is delayed?


:heart:, osCommerce

Share this post


Link to post
Share on other sites

Width PDT disabled and the Language Encoding set to the stores encoding (UTF-8 by default), is anyone still experiencing problems with Payments Standard?


:heart:, osCommerce

Share this post


Link to post
Share on other sites

Hi Harald

 

My live shop is set with PDT disabled and the Language Encoding set to the stores encoding (UTF-8 by default).

 

The customs successfully makes payment and received the two emails. However the order status shows "Preparing [PayPal Transaction]" when is should actually be showing "pending shipping"

 

The payments were working find until I installed customer coupons and gift voucher contribution.

 

Please let me know whether you could diagnose the issue. I will be happy to provide you with any information that you may require

 

Thanking you in advance 

Share this post


Link to post
Share on other sites

I'm having the same problem - in IE10 and Chrome.

 

This message "Could not verify the PayPal transaction. Please try again." appears in pink at bottom of screen. It appears that:

 

1) the db status remains at 5 Preparing [Paypal Standard ]

2) the cart is not emptied

3) I don't see the success message but returned to populated Cart.

 

BobH

Share this post


Link to post
Share on other sites

*** HERE IS THE SOLUTION ***

 

In your PayPal account Profile -> Selling Preferences -> Website Payment Preferences page:

 

Turn Payment Data Transfer OFF!

 

Who told you to turn that on in the first place? :D

 

Harlad

 

Worked for me, thanks!!!!!!!

Share this post


Link to post
Share on other sites

I also encountered this problem when I upgraded from oscommerce 2.3.3.4 to 2.3.4 (both live and sandbox) but I eventually got it working, so I thought I'd post this in case it helps anyone else.

 

My PayPal seller settings:

 

IPN: Enabled

 

Website Payment Preferences:

 Auto Return: off
 Payment Data Transfer: off
 Block Non-encrypted Website Payment: off
 PayPal Account Optional: on

 

Language Encoding:

 Western European Languages (including English)

 Encoding: UTF-8
 

The PayPal Standard Module Settings:

 

Enable PayPal Website Payments Standard
True

E-Mail Address
xxxx (sandbox seller account)

Primary E-Mail Address

Page Style
PayPal

Transaction Method
Sale

Set Preparing Order Status
Preparing [PayPal Standard]

Set PayPal Acknowledged Order Status
Processing

PayPal Transactions Order Status Level
PayPal [Transactions]

Payment Zone
--none--

Gateway Server
Sandbox

Verify SSL Certificate
False

Proxy Server

Debug E-Mail Address
xxxx

Enable Encrypted Web Payments
False

Your Private Key

Your Public Certificate

PayPals Public Certificate

Your PayPal Public Certificate ID

Working Directory

OpenSSL Location
/usr/bin/openssl

 

After repeatedly getting the "Could not verify the PayPal transaction. Please try again." error, I wondered if perhaps an add-on or some modification of my own was conflicting with the new code in the upgrade, so I downloaded the complete oscommerce 2.3.4 and installed it in a different location but configured it to use the same settings.

 

My original files are in /shop/ and the new installation is in /catalog-test/ so I tried a test purchase with the sandbox on the /catalog-test/ store and it worked! Yay! I tried again and PayPal complained that this invoice had already been paid. I remembered encountering this error when I first installed oscommerce last year and a web search had suggested that I change the following line in includes/modules/payment/paypal_standard.php (around line 328)

 

                          'invoice' => substr($cart_PayPal_Standard_ID, strpos($cart_PayPal_Standard_ID, '-')+1),

 

to

 

                          'invoice' => $cart_PayPal_Standard_ID,

 

So I made this edit, retried the transaction and now I got the "Could not verify the PayPal transaction. Please try again." error and I was returned to my shopping basket which hadn't been emptied. I reverted the edit and changed the PayPal seller Payment Receiving Preferences from "Yes, block multiple payments per invoice ID" to "No, allow multiple payments per invoice ID". I retried the /catalog-test/ store and the transaction was successful.

 

So it seems that part of the problem was caused by this modification. I'd rather block multiple payments per invoice, but at least this now works. I went back to my /shop/ code and fixed the 'invoice' setting, and then tried a transaction, but I again got the "Could not verify the PayPal transaction. Please try again." error. After comparing the code in /shop/ and /catalog-test/ I finally found the problem. In /shop/checkout_confirmation.php I had the line

 

echo tep_draw_hidden_field('charset', 'utf-8');

 

When I removed this line, the error went away and the test transactions worked.

Edited by nlct

Share this post


Link to post
Share on other sites

I also get the dreaded and return to the cart with product still in..  with 

 

Could not verify the PayPal transaction. Please try again.

 

IPN Simulator says:

 

We could not send an IPN due to an HTTP error: 500: Internal Server Error

 

 

When I turn OFF the PPS module I get..

 

IPN sent successfully

 

Logs

 

/ext/modules/payment/paypal/standard_ipn.php HTTP/1.0" 500 - "-" "PayPal IPN ( https://www.paypal.com/ipn )"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×