Jump to content
Latest News: (loading..)

Recommended Posts

When the screen in shrunk, the Categories box moves down below the body of the page. Is it possible to have it move above the body? Thanks!

 

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

You'd need to move the left column from the template bottom into the template top, and remove the push pull...

 

What we have now CODE:

 

Main Content (1) | Left Column (2) | Right Column (3)

 

What we have now DISPLAY:

 

Medium and Above:

 

213

 

Small and below

123

 

What you need CODE:

 

213 at all times


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

@@ArtcoInc

Did you made it? The Categories box above the new products?

 

I spent a little time working on it, but was not able to get it to work. So, I moved on to other issues.

 

You'd need to move the left column from the template bottom into the template top, and remove the push pull...

 

What we have now CODE:

 

Main Content (1) | Left Column (2) | Right Column (3)

 

What we have now DISPLAY:

 

Medium and Above:

 

213

 

Small and below

123

 

What you need CODE:

 

213 at all times

 

That makes a little more sense. With this additional guidance, I will look into this when I have a little more time.

 

Thank you!

 

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

@@ArtcoInc

 

Did you made it? The Categories box above the new products?

 

@@Tsimi

 

I think I got it ... o:)

 

 

 

 

 

Now, I just need to find someone with a smart phone (or similar device) to try this, and see which layout is easier. Mind you, I only have two categories and 12 products on my site.

 

Malcolm

Edited by ArtcoInc

If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

Hi Malcolm :)

 

I have no access to my PC right now.

I can test it in about 2 hours.

I have a smart phone and i will test it and report back.

 

You know that you can simulate the view of a small device with firefox browser by pushing ctrl+shift+m.

Edited by Tsimi

Share this post


Link to post
Share on other sites

Took a look at it and works fine on a smart phone.

Just kinda weird seeing the categories box over the greeting text stuff, but i don't use that in a real shop and therefore it would look good. It would be great though to have the categories inside the collapsed menu but there is nothing that worked properly so far I know.

 

Well done!

Share this post


Link to post
Share on other sites

@@ArtcoInc what's the URL we should be looking at ?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

@@ArtcoInc what's the URL we should be looking at ?

 

http://www.ShelboWhisperTips.com

 

I have also implemented your 'slide the circle into the square' code in the Contact Us page.

 

You know that you can simulate the view of a small device with firefox browser by pushing ctrl+shift+m.

 

Indeed, I use this too to see how the page resizes. But, there's a difference between using a mouse and keyboard when sitting at your desk, and swiping your fingers across a little screen. :)

 

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

The drag does not work in smartphone (xs) or tablet (sm) or tablet (md), it does work in laptop...

 

It works in all views on my test site (as far as I can see), so there are two possible reasons why it doesn't work at yours;

 

1. I may have missed a step in the instructions above. Can someone else try it and see if it works in another site

 

2. You may have introduced a change which is stopping it from work in small screens


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

I can only test it here by shrinking the screen here on my desktop. Using Firefox 29 and Chrome 35, the drag works. Using Internet Explorer 8, the drag does *not* drag (I know IE8 is old. But, I'm still on WinXP, and that's the latest version it will run).

 

This is why I needed some re-world testing. :)

 

Thanks, burt!


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

Drag IE works for me including submit

 

Firefox perfect using the yellow background colour style

 

but IE is using what looks like redmond style

 

Small android tablet no drag and drop visible but does seem to send mail after dragging appears to be standard redmond styling ??

 

The small curser for the mouse is missing when moving mouse but noticed a few times on bootstrap so nothing to do with this issue


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

@@ArtcoInc@@Tsimi

 

Thought Id give post 6 a go and this is what I got. Before and After.

 

attachicon.gifbefore.jpg

 

attachicon.gifAfter.jpg

 

Cheers

Grandpa

You 'should' only see a difference when you minimize the screen, or view the site on a small-screen device.

 

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

@@ArtcoInc

 

Sorted my wee problem by moving

 

<?php require(DIR_WS_INCLUDES . 'header.php'); ?>

 

from line 54 to line 57 in template_top.php

 

and all seems to now work good.

 

Cheers

Grandpa

Share this post


Link to post
Share on other sites

@@ArtcoInc

 

Sorted my wee problem by moving

 

<?php require(DIR_WS_INCLUDES . 'header.php'); ?>

 

from line 54 to line 57 in template_top.php

 

and all seems to now work good.

 

Cheers

Grandpa

 

Do you like it?

 

I'm looking at people on phones and such, that don't want to scroll way down to see what I'm selling ... I mean, they come to my site to buy stuff, right?

 

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

@@ArtcoInc

 

Hi Malcolm

 

I agree enrirely. Loodks good to me.

 

Well done

 

Grandpa

 

Do you like it?

 

I'm looking at people on phones and such, that don't want to scroll way down to see what I'm selling ... I mean, they come to my site to buy stuff, right?

 

Malcolm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×