Jump to content
Roaddoctor

Shipping Quote in Cart 2.3.3.4 - Support Thread

Recommended Posts

Hummm....interesting that it won't return to an SSL page...a security feature perhaps?  In any case, I'm glad to hear that you found a solution.

 

Dan

Share this post


Link to post
Share on other sites

Has anyone succesfully integrated this with MVS?

 

If so, I'd really like to see your versions of the "shipping_quotes.php" file

 

Thanks!

Share this post


Link to post
Share on other sites

Sorry to again bring up this 2-year old problem, but ...

 

I had been running my site in a mixed SSL configuration. But, sales have all but died as of late. I'm thinking that it might have something to do with the fact that I am using a pop-up Modal login, and with all of the current browsers alerting (alarming!) users that their login were insecure, people are leaving. So, I'm moving back to a full-time SSL configuration.

 

So, once again, I'm back to this problem with Shipping Quote in Cart is not receiving any quotes from the US Post Office. The spinner just spins and spins and spins ...

 

The shipping module *does* retrieve a valid cost from the Post Office while full SSL, so the problem is only in this Shipping in Cart module.

 

Help!!! Please?

 

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

Ok, I *think* I fixed this ...

 

in catalog/includes/modules/shipping_in_cart.php

 

 

around line 98, find

        $.getJSON("' . tep_href_link(FILENAME_SHIPPING_QUOTES) . '", {country:country, postcode:postcode, residential:residential}, function(data){
            $(".loading").hide();
            $(".quotes").html(data.quotes);
            $(".order-totals").html(data.totals);
        });

replace with:

        $.getJSON("' . tep_href_link(FILENAME_SHIPPING_QUOTES,"",$request_type) . '", {country:country, postcode:postcode,
residential:residential}, function(data){
            $(".loading").hide();
            $(".quotes").html(data.quotes);
            $(".order-totals").html(data.totals);
        });

and, around line 119, find:

        $.getJSON("' . tep_href_link(FILENAME_SHIPPING_QUOTES) . '", {country:country, postcode:postcode, residential:residential, shipping:shipping}, function(data){
            $(".order-totals").html(data.totals);
        });

replace with:

        $.getJSON("' . tep_href_link(FILENAME_SHIPPING_QUOTES,"",$request_type) . '", {country:country, postcode:postcode,
residential:residential, shipping:shipping}, function(data){
            $(".order-totals").html(data.totals);
        });

Basically, I've added the $request_type variable to the tep_href_link() call.

 

Please let me know if anyone sees something wrong with this. :-

 

Thanks!

 

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

@@Dan Cole

 

@@ArtcoInc

 

Malcolm...did your original mixed content error message also go away?

 

Dan

 

Just following up ...

 

When running full-time SSL, I was receiving the original Mixed Content error message for the Contact Us page. I resolved it here:

 

http://forums.oscommerce.com/topic/411091-ssl-bug/

 

But, that still left the Shipping Quote in Cart not working under full-time SSL. I think I fixed that here:

 

http://forums.oscommerce.com/topic/396632-shipping-quote-in-cart-2334-support-thread/?p=1756871

(the post just above this one)

 

Both stemmed from the fact that the SSL/NONSSL/$request_type variable was not being passed in the tep_href_link() call.

 

HTH

 

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites
1 hour ago, stefan1959 said:

Looking for a shipping quote for CE v1, would this work?

It might do but this is a better option, is up to date and is supported by @raiwa

https://apps.oscommerce.com/YLYGm&ship-in-cart-bs-reloaded


OsC 2.3.4.1 CE Frozen   PHP 7.2   MySQL 10.1.36-MariaDB-cll-lve. Phoenix in development

Is your version of osC up to date? You'll find the latest osC community version (CE Phoenix 1.0.2.0) here.

Share this post


Link to post
Share on other sites

@stefan1959

7 hours ago, mhsuffolk said:

It might do but this is a better option, is up to date and is supported by @raiwa

https://apps.oscommerce.com/YLYGm&ship-in-cart-bs-reloaded

I can confirm that Ship in Cart v5 (see link above) does indeed work with Phoenix.

M


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×