Jump to content
DriWashSolutions

Linkpoint API and OSC V2.3.3.4

Recommended Posts

Has anyone been able to get the Linkpoint API working with the latest version of OSC (v2.3.3.4)?

 

I've installed the API and the first error encountered was a deprecated "split" function with PHP. I've changed that to 'explode' and have got by that error.

 

Now, it appears that the OUTGOING XML is bad. I get an error SGS-020003 on the INBOUND PreAuth.

 

The Checkout_Payment page is reloaded with a red banner at the top with the following text:

 

PREAUTHORIZATION FAILED - Card not approved, please contact your bank for detailed information or use another card. Please correct the listed problems and try again or contact us by phone to process this order.

 

Anyone got any idea's?


John Skurka

Share this post


Link to post
Share on other sites

Ok - well, thanks for the responses.

 

Figured it out - it was indeed bad characters in the title of my products. I had a ® symbol in the title and the Linkpoint API didn't like that.

 

That fixed the Bad XML error, and combined with other things changed (uncommenting the CURL) the contrib works with the new store.

Edited by DriWashSolutions

John Skurka

Share this post


Link to post
Share on other sites

HI can you please tell me what Module you are using to integrate linkpoint please.

 

I am trying to integrate http://addons.oscommerce.com/info/2423 and the payment seems to work, but I get returned to login page after payment, and even though I am charged on the card, the orders are not created on the admin.

 

Have been fighting with this for a week now. Please help.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×