Jump to content
Latest News: (loading..)
Sign in to follow this  
Tobias_Henricsson

Impossible to add category/product after language change

Recommended Posts

Hi there!

I have OSC installed, and everything seemed to work just well. I have two languages installed; English (from installation) and Swedish (downloaded). Since all my costumers live in Sweden I decided to remove the English language.

 

Since then, no products can be found on the main catalog page. If I try to add a new product or category in the admin section and click Save, no product or category is added. I get no error message. I have checked phpmyadmin, and all the products and categories are there. I have made no change to the database, all I did was removing the English language. I didn't remove any files from the server, just the post in the admin section.

 

I have seen this problem before in the forums, but without any answer.

 

Can anyone please help? I really need my shop up and running!

 

Thanks in advance,

 

Tobias Henricsson

Share this post


Link to post
Share on other sites

Had this as well with Dutch but not sure how I fixed it was a weird one.

 

Try reinstalling the English in admin make sure the Swedish is set to default and check what you see frontend and admin you can change the admin language top right

 

If you can see the products in at least x 1 language then uninstall the English but make sure the Swedish is set as default.

 

PS: Have a feeling it is something to do with the database default language settings just can not remember exactly

Edited by joli1811

To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Thank you! I'll investigate this!

 

Had this as well with Dutch but not sure how I fixed it was a weird one.

 

Try reinstalling the English in admin make sure the Swedish is set to default and check what you see frontend and admin you can change the admin language top right

 

If you can see the products in at least x 1 language then uninstall the English but make sure the Swedish is set as default.

 

PS: Have a feeling it is something to do with the database default language settings just can not remember exactly

Share this post


Link to post
Share on other sites

If I add ?language=sv or &language=sv depending on the path, at least the category show. Swedish has language ID 2, and in phpmyadmin the table categories_description has languageID 2 (see below). But how to make OSC understand that I will use this language "all over the place"? Swedish (code: sv) is set as standard in the admin pages.

post-327104-0-38554600-1393502233_thumb.jpg

Edited by Tobias_Henricsson

Share this post


Link to post
Share on other sites

I may have solved it by deleting the English language (so OSC have nothing to choose from... :-)) and setting the Swedish language as the default one.

 

After that, I checked products_descrition and categories_description in the database and made sure they have the same language_id as the Swedish language (language_id=2). Maybe this can help anyone? I will post again when... sorry, IF, I run into more problems in this matter...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×