Jump to content
burt

Responsive osCommerce - Bootstrap

Recommended Posts

49 minutes ago, Rachael w. said:

I have downloaded Responsive Oscommerce Master which has a zip date of 2/4/18. Is this the one I should start working with?

this is the correct version to be used

 

49 minutes ago, Rachael w. said:

Can I run this with php7?  I believe my current sites code will not let me upgrade it from php5.

It's good to run at least up to PHP 7.1

 

50 minutes ago, Rachael w. said:

My biggest fear is that I have a massive images folder. Is there something for BS which will organize that folder?

There are many resources for the database update including extra images.

See this thread:

https://forums.oscommerce.com/topic/408979-upgrading-to-the-latest-version/

and this add-on newest version:

https://apps.oscommerce.com/2qqbU&sql-upgrades-from-2-2ms-to-2-3-3

Share this post


Link to post
Share on other sites

if your store is 2.2 based and you are using additional product images, there is this add-on for ultra pics migration. But I believe it can be modified for other extra images add-ons:

https://apps.oscommerce.com/gS66B&ultrapics-to-oscommerce-2-3-x-migration&p=2

Share this post


Link to post
Share on other sites

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

With thanks to the handful of guys who have bought my latest 28d Modules, thereby giving me some time to spend on the Project, the following has been achieved;

  1. Update Font Awesome to v5
  2. Update deprecated "each" loops to "foreach" loops, for php7.2 compat
  3. Update emails to accept -f parameter, this should solve emails being marked as spam by (eg) hotmail
  4. Update login content module for has-feedback and placeholders, cosmetic change requested by many.
  5. Add in more Custom Data Points

If you want to see more work being done on the Project, pitch in and help.  Or if you cannot code, help by spending a few dollars.

The next task is a big one.  I need YOUR help.

Updating from Bootstrap 3 to Bootstrap 4.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
10 minutes ago, burt said:

Updating from Bootstrap 3 to Bootstrap 4.

Man that sounds like a nightmare! So many things to check and double check. :wacko:

Share this post


Link to post
Share on other sites
14 minutes ago, burt said:

With thanks to the handful of guys who have bought my latest 28d Modules, thereby giving me some time to spend on the Project, the following has been achieved;

  1. Update Font Awesome to v5
  2. Update deprecated "each" loops to "foreach" loops, for php7.2 compat
  3. Update emails to accept -f parameter, this should solve emails being marked as spam by (eg) hotmail
  4. Update login content module for has-feedback and placeholders, cosmetic change requested by many.
  5. Add in more Custom Data Points

If you want to see more work being done on the Project, pitch in and help.  Or if you cannot code, help by spending a few dollars.

The next task is a big one.  I need YOUR help.

Updating from Bootstrap 3 to Bootstrap 4.

Only help I can offer would be installing on source tree and testing


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites
1 hour ago, burt said:

With thanks to the handful of guys who have bought my latest 28d Modules, thereby giving me some time to spend on the Project, the following has been achieved;

  1. Update Font Awesome to v5
  2. Update deprecated "each" loops to "foreach" loops, for php7.2 compat
  3. Update emails to accept -f parameter, this should solve emails being marked as spam by (eg) hotmail
  4. Update login content module for has-feedback and placeholders, cosmetic change requested by many.
  5. Add in more Custom Data Points

If you want to see more work being done on the Project, pitch in and help.  Or if you cannot code, help by spending a few dollars.

The next task is a big one.  I need YOUR help.

Updating from Bootstrap 3 to Bootstrap 4.

Happy to help


 

Share this post


Link to post
Share on other sites

@burt

G I went through the while()each() becomes foreach() commit and update all my files.

I am not php tech savvy but if the routine is always the same then I think there are couple of resets running loose inside the following files.

admin/includes/classes/phplot.php 

Line 1348 / 1346

 	reset($this->data_color);  //data_color can be an array of colors, one for each thing plotted
-	 //while (list(, $col) = each($this->data_color)) 
+    // foreach($this->data_color as $col) 

reset has not been removed

Line 1362 / 1360

         reset($this->data_border_color);
         $i = 0;
-        while (list(, $col) = each($this->data_border_color)) {
+    foreach($this->data_border_color as $col) {

reset has not been removed

Line 2286 / 2274

         reset($this->data_values);
-        while (list($j, $row) = each($this->data_values)) {
+    foreach($this->data_values as $j => $row) {

reset has not been removed

 includes/functions/database.php
 Line 61

     reset($data);
     if ($action == 'insert') {
       $query = 'insert into ' . $table . ' (';
-      while (list($columns, ) = each($data)) {
+      foreach (array_keys($data) as $columns) {

reset has not been removed on line 58

 

Edited by Tsimi

Share this post


Link to post
Share on other sites

@Tsimi @justcatering @altoid TY.  You guys have done your part already for which I am grateful and I hope all the other shopowners who have not yet been able to help, are grateful.

If I can get 10 more shopowners involved in the 28d offerings...I can take a week off and pay someone else to take a week off to get bs3 to bs4 done in that week.  Then we can pronounce "final" and be done with the whole thing, other than hotfixes.

 

ps, thank you to the other guys whom I have not mentioned for helping!  You know who you are, I am grateful to you.

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
3 hours ago, Tsimi said:

@burt

G I went through the while()each() becomes foreach() commit and update all my files.

I am not php tech savvy but if the routine is always the same then I think there are couple of resets running loose inside the following files.

TY @Tsimi

https://github.com/gburton/Responsive-osCommerce/commit/70c5a7a1fc9548365e2e8450f535c7073dda430e


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Just spotted a posiable problem in product info page, When you hover over the image and the hover text pops up the text is messing up when " is used. It appeares to add \" into the text. Only happens on the product info page. Hover text is fine on same image in all other pages. Is this a known issue?

Hover error.jpg

Hover normal.jpg

Edited by justcatering

 

Share this post


Link to post
Share on other sites

In product_info.php find the word;

addslashes

and change it to

htmlspecialchars

See if that solves it.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

This is just an observation but I have noticed my sites slowing down at times and sitting with this notice at bottom of browser, it would appear they are having difficulty get on the fa server! Anyone else seeing this?

image.png.b78a6b818ece99d0250b6093050205c7.png


 

Share this post


Link to post
Share on other sites

You can host it locally if you like; see https://fontawesome.com/get-started


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@burt

I think that is what I'm gonna do too. Page load has slowed down a bit since the FA 5 upgrade.

The guys from FA mentioned something on their website about page load might get slower if you exceed certain amount of icons per page. I highly doubt that we reach that amount with osC though.

I'll try to set it up local once and see if that improves load times.

 

Edited by Tsimi

Share this post


Link to post
Share on other sites

@burt

What about the reset around line 1361 inside phplot.php file, stay or remove?

//Set color of the error bars to be that of data if not already set. 
if (!$this->error_bar_color) { 
reset($which_data);
$this->SetErrorBarColors($which_data);
}

 

Share this post


Link to post
Share on other sites

I think this one is OK left alone.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
On 2/13/2018 at 11:42 PM, Tsimi said:

@burt

I think that is what I'm gonna do too. Page load has slowed down a bit since the FA 5 upgrade.

The guys from FA mentioned something on their website about page load might get slower if you exceed certain amount of icons per page. I highly doubt that we reach that amount with osC though.

I'll try to set it up local once and see if that improves load times.

 

Please report back on your findings when on live server, as I am thinking we could potentially do something with a Hook...

Default Hook:
load the fa from the fa site

Non standard Hook (maybe an addon or such):
load the fa from your own server

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@burt

Will definitely do.
If everything goes as planned I should get a "real" server space somewhere during March, latest April.

Yesterday when I worked on the shop loading was normal and I didn't feel any slow downs, using the js script.

Edited by Tsimi

Share this post


Link to post
Share on other sites

I am having a problem when “Force Cookie Use” is set to true, I set it to true so that the URLs would not have the long “osCsid=5c06d7bc7dc631eb69d799df138a52bb” attached to the urls.

 

However when “Force Cookie Use” is set to true customers can no longer buy from the store! All they get is a warning page saying please turn on your cookies!

 

I have checked my self and I have cookies enabled in my browser but it still only gives this warning page. Anyone else had this problem or is there a known solution that I have not found?

cookie.png


 

Share this post


Link to post
Share on other sites

With the default settings (force cookies false) you'll get session ids on the first page display but after that they go away.

You want prevent spider sessions True and check you don't have them indexed in google.

Edited by BrockleyJohn

For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

 Sorry too early to think! with set to false, I get the id on all page. It was set to True to make the URls short. However customers complaind they could not buy! They said cookies are on but still get error.

I too only get the error page with it set to true. Making it false goes back to long Urls,

Edited by justcatering

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×