Jump to content
burt

Responsive osCommerce - Bootstrap

Recommended Posts

Thank you to a very generous soul who has allowed me to give a number of hours solid coding into the Project:  THANK YOU.

 

Colorbox v1.6.3 is now Core

 

Customer Testimonials is now Core (part of SEO updates)

 

New Navbar Module for Testimonials is now Core

 

Thank you.  Thanks also to all the testers of the above, as always.

 

Being Tested

Products Meta (part of SEO updates)

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt,

I also noticed that when you have 2 items in the cart, the stripes for the second item are light, and there is no visual clue as to where the content ends and the subtotals begin.

I just took a mental note, but since I'm not versed in bootstrap css, didn't know if/hw easy it would be to change this ...


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

I have just installed the default 2.3.4BS, and nothing has been modified yet in the default database.  However, in admin, when I click on the link for Categories/Products, I get a blank page, with no errors.

 

Ron

Share this post


Link to post
Share on other sites

@@rwest

 

Blank page as in a total white screen or normal store page but just without any products being displayed?

 

Dan

Share this post


Link to post
Share on other sites

http://forums.oscommerce.com/topic/409235-categoriesproducts-in-admin-give-error-500/ 

@@rwest

 

PHP 5.3 is the Minimum Version

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Blank page, as in totally white blank page.

 

If 5.3 is minimum PHP version, my problem is that my live site (OSC v.2.2) is on the same server.  I am concerned that upgrading PHP might break something. 

 

I will be upgrading from PHP 5.2.17.  How should I proceed?

 

Ron

Edited by rwest

Share this post


Link to post
Share on other sites

@@bruyndoncx

http://getbootstrap.com/css/#tables should do it.

 

Other Ideas:

put a <hr> above the subtotals

or

swap the nth-child on table-striped (in user.css)


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Set up a localhost test server. I suggest "Uniserver" as it is simple.

 

It's a mistake to try to make a side-by-side site on the same hosting account, as you may very easily, with 1 wrong move or lack of concentration or not backing up or whatever...nuke your live site. Then you really are in trouble.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Sounds like sage advice, Burt.  Thank you.  Nobody at my host site's support ever told me about this.

 

Is Uniserver the same as Uniform Server?  That's what my search matches.

 

Ron

Share this post


Link to post
Share on other sites

Sorry yes - Uniform Server.

 

In my opinion, always wisest to keep "live site" and "test site" as far apart as possible.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

I have installed a test site on Uniform Server. Thanks again.

 

Using Uniform Server, I take it there is no way to change permissions on files?  Or make the admin's security check happy?

 

Ron

Share this post


Link to post
Share on other sites

No need.  It's on your own computer so no-one can access it.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

SEO is now fully integrated into the Core (of Edge).  Thank you to the one from this forum who made it possible for me to devote some time to this, and to @@altoid and @@Dan Cole for all the time you guys spent testing and commenting. 


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

SEO is now fully integrated into the Core (of Edge).  Thank you to the one from this forum who made it possible for me to devote some time to this, and to @@altoid and @@Dan Cole for all the time you guys spent testing and commenting. 

 

Does that mean it incorporates the SEO reloaded module? thanks

Share this post


Link to post
Share on other sites

where I can download the latest version of GOLD or Edge version of 2.3.4-Responsive?


Best regards


Valqui


Running Old EDGE, setting up a new Frozen site with many nice addons available on the market and waiting to be admitted to Phoenix club!

Community Oscommerce fan :heart:

 

Share this post


Link to post
Share on other sites

Dear Dan,

 

where I can find a list o document of which Add-Ons and Extra Commits are in the EDGE version.

 

Regards,

 

Valqui


Running Old EDGE, setting up a new Frozen site with many nice addons available on the market and waiting to be admitted to Phoenix club!

Community Oscommerce fan :heart:

 

Share this post


Link to post
Share on other sites

@@valquiria23 The Github development can be found here.  There a list of contributions that play nicely with the responsive version.  Let me see if I can find it. 

 

Dan

Share this post


Link to post
Share on other sites

@@valquiria23  Here is the list I was thinking about.  It doesn't look like it is completely up to date but I'll get you started.  If you're looking for something in particular have a look in the add on area.  It is pretty dated too but will give you an idea of what might be available or what you might be able to use with a little work.

 

Dan

Share this post


Link to post
Share on other sites

Thank you Dan !!! You're a genius :D


Running Old EDGE, setting up a new Frozen site with many nice addons available on the market and waiting to be admitted to Phoenix club!

Community Oscommerce fan :heart:

 

Share this post


Link to post
Share on other sites

Thank you Dan !!! You're a genius :D

 

@@valquiria23

 

If you have a look at my Github and SourceTree Leader needed thread you won't think so. :x

 

Dan

Share this post


Link to post
Share on other sites

Hi Burt, I've just downloaded a copy of EDGE and compared the checkout_shipping_address.php file to mine that is installed, they are identical. In my store, you cannot change the address during checkout because there is no input field for town/suburb. So the customer cannot move forward in entering a new shipping address.

 

Since the files are identical, this seems to be a bug in BS EDGE, would that be right?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×