Jump to content
burt

Responsive osCommerce - Bootstrap

Recommended Posts

@@burt

 

Apart from the folders, manufacturers logo and category images are all the rest of the images such as, the stars, arrows, pixel_black etc, header images and table background images obsolete and can be removed?

 

Yes, I've checked the code and these images are not use anymore since 2.3.0.

Share this post


Link to post
Share on other sites

I think a large part of this it due to the excellent effort @@burt puts forward at getting and keeping the community involved. At this point I think we're just scratching the surface of what can be accomplished as the community gets more and more involved.  IMO we owe a huge thumbs up to Gary. :thumbsup:

 

I completely agree. He's doing a great job!. That's why I was suggesting to join both projects so development is not limited to just bootstrap the site. There are many barriers that limts the evolution, some of them are deep changes and others are minimum changes and community efforts could break a lot o those walls.

Share this post


Link to post
Share on other sites

hi. ive just installed the latest master zip file and set bootstrap to container and it works great.

 

however, ive looked in the admin section and cant see any option to

 

add header navbar with links and any search bar alongside it as in example link.

 

Do i have to add all this manually by editing the Html?

 

I was looking at the example link in the first post on this thread.

http://www.template.me.uk/2334bs3/index.php

 

if someone can point me to the post with info on whereabouts to all these bits (specifically header navbar and search bar) that would be great.

 

 

many thanks

Edited by vampirehunter

Share this post


Link to post
Share on other sites

Try reading the README file. It's on the very first page of https://github.com/gburton/osCommerce-234-bootstrap and is in your download as well.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Try reading the README file. It's on the very first page of https://github.com/gburton/osCommerce-234-bootstrap and is in your download as well.

Hi

 

I was wondering what do you think is best method of adding a full width banner which shows only on the index/home page?

 

Would you recommend to code a new module and then activate this rather than edit the actual php file?

 

I saw your Saul template, it looks great, did you do a module for that or just straight edit the index php file?

 

 

 

many thanks

Share this post


Link to post
Share on other sites

This is not a thread for discussing this and that on what you want in your own site.

This thread is for discussion about the core fileset, changes in bootstrap and so on.

 

If you want something that is not already covered by the core files, start a new thread, otherwise your part of the discussion will get lost amongst other posts.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Hi,

 

Great template! BTW, how do I activate the top navbar and footer like in the demo? All I can see is the content when I install it.

 

Thanks!

Share this post


Link to post
Share on other sites

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Follow up question, how hard this would be to upgrade or change from an existing installation? Do I just overwrite the vanilla osc?

Share this post


Link to post
Share on other sites

@@burt

 

Issue:

 

If you set Bootstrap Setup -> Bootstrap Content value to 4, the New Product Listing grid view breaks up, fluid or container fluid mode.

Edited by rustyk

Share this post


Link to post
Share on other sites

@@rustyk if you make a decision to have the content in a one third container (4/12), then you have to make further design decisions;

 

- should i replace new_products for something else

- should i remove it entirely

- should i remove one or both side columns

 

etc


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

I didn't know if this counts as a BUG or just as improvement of the module so i post it here in the normal BS topic. If this is the wrong place, my apologies.

 

I think there was once talk about beeing able to set up the layout for the colorbox module.

Like 15555 or 13333 and so on...but i couldn't find such setting anywhere.

After a small chat with Henry i came up with this small fix.

 

inside the ht_product_colorbox.php file add the following code inside the function install() {

tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) values ('View Layout Setting (default is 133333)', 'MODULE_HEADER_TAGS_PRODUCT_COLORBOX_VIEW', '133333', 'Set the Image View Layout.', '6', '0', now())");

then add the following code inside the function keys() {

'MODULE_HEADER_TAGS_PRODUCT_COLORBOX_VIEW',

now inside the product_info.php look for

<div id="piGal" data-imgcount="<?php echo $photoset_layout; ?>">

and change that to

<div id="piGal" data-imgcount="<?php echo MODULE_HEADER_TAGS_PRODUCT_COLORBOX_VIEW; ?>">

Share this post


Link to post
Share on other sites

Hmmm, I thought we had that already ?  I'll look into it.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Looks like it was lost in the update to 2.3.4 :(

 

 


ht_product_color_box module changed to use same settings in script tag as 2.3.4


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

The stars on review page and other places may break into 2 lines viewing on mobile.

Adding text-nowrap class to the tep_draw_stars function fixes that:

includes/functions/html_output.php line454-462:

  // review stars
  function tep_draw_stars($rating = 0, $meta = false) {
    $stars = str_repeat('<span class="glyphicon glyphicon-star"></span>', (int)$rating);
    $stars .= str_repeat('<span class="glyphicon glyphicon-star-empty"></span>', 5-(int)$rating);
    if ($meta !== false) $stars .= '<meta itemprop="rating" content="' . (int)$rating . '" />';
    $stars = '<span class="text-nowrap">' . $stars . '</span>';

    return $stars;
  }

I believe it is not only a cosmetic/design issue.

Share this post


Link to post
Share on other sites

Can Anyone check this. checkout_confirmation page. the TAX rate appears in the wrong place or is that me

 

 

post-268503-0-02422400-1423343330_thumb.jpg

Share this post


Link to post
Share on other sites

@@OSC-Sevilla

 

It doesn't do that on my site...you could try downloading the lastest code for checkout_confirmation.php and see if the problem persists or post your code for that page so we can have a look.   If you chose to post the code it might be better if you posted it to your own thread since I don't think this one is for problems of this nature.

Share this post


Link to post
Share on other sites

@@OSC-Sevilla

 

It doesn't do that on my site...you could try downloading the lastest code for checkout_confirmation.php and see if the problem persists or post your code for that page so we can have a look.   If you chose to post the code it might be better if you posted it to your own thread since I don't think this one is for problems of this nature.

 

The issue appears if you setup a different Tax rate for shipping.

post-268503-0-84255400-1423404521_thumb.jpg

post-268503-0-91951400-1423404528_thumb.jpg

Share this post


Link to post
Share on other sites

@@OSC-Sevilla

 

The issue appears if you setup a different Tax rate for shipping.

 

This is not a bug, it's intended. It would be probably better, if in such a case in the header bar "tax rate" or similar would appear. :-

If you want that in the summary "21% ES Tax" is displayed you must enter this text in Admin => Tax Rates into the description of the different tax rates.

 

J.J.

Share this post


Link to post
Share on other sites

@@OSC-Sevilla

 

 

This is not a bug, it's intended. It would be probably better, if in such a case in the header bar "tax rate" or similar would appear. :-

If you want that in the summary "21% ES Tax" is displayed you must enter this text in Admin => Tax Rates into the description of the different tax rates.

 

J.J.

 

Ok so if you have sepearate tax on shipping it is intended not to be shown in the summary (but included in the total price). And despite adding a descriptions it is inteded that 21% (or whatever) be shown on the product line as shown in the picture above (that has no bearing on the price reflected next to the the product displayed without tax).

 

I am not sure that makes any sense.

 

DO NOT UNDERSTAND THIS (as per what is shown in pics above):

1 x  Owen 21% $10.00

Sub-Total: $10.00 ES

TAX: $2.10

Zone Rate by Country (Shipping to ES - Sevilla : 2 kg(s)): $10.00

Total: $24.20

 

 

 

Logic:

 

Sub-Total: $10.00

Product ES TAX (21%): $2.10

Zone Rate by Country (Shipping to ES - Sevilla : 2 kg(s)): $10.00

Shipping ES TAX (21%):$2.10

Total:$24.20

 

CLEAR

 

Sub-Total: $10.00  

Zone Rate by Country (Shipping to ES - Sevilla : 2 kg(s)): $10.00

ES TAX (21%):$4.20

Total:$24.20

Edited by OSC-Sevilla

Share this post


Link to post
Share on other sites

Product(s) added to catalog, but not in a Category (Folder) do not appear in search results by default - Why?

post-268503-0-70041300-1423409596_thumb.jpg

Edited by OSC-Sevilla

Share this post


Link to post
Share on other sites

Ok so if you have sepearate tax on shipping it is intended not to be shown in the summary (but included in the total price). And despite adding a descriptions it is inteded that 21% (or whatever) be shown on the product line as shown in the picture above (that has no bearing on the price reflected next to the the product displayed without tax).

 

No, it's intended to display the tax rates in the products overview, if you have products with different rates in one order.

If you want the display the tax for shipping separatly in the summary, you must change the order:

- Sub-Total

- Shipping

- Tax

- Total

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×