Jump to content
burt

Responsive osCommerce - Bootstrap

Recommended Posts

John is this working before the fix, or with my fix included?

@@burt

 

Without  fix working out of the box  just tested when I read the post the only thing is the site has a themeswitcher installed 

 

The options site I was talking about a few days back.

 

I think you have log in details it is an upgrade site from older bootstrap but most of the stuff was overwritten take a look if you want

 

and feel free to install uninstall etc...

 

demo  

 

php 5.3.28

 

PS: tested with nav bar in and out no problems either way just took it has far as shopping cart could not repeat the error

Edited by joli1811

To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

@@burt

 

Without  fix working out of the box  just tested when I read the post the only thing is the site has a themeswitcher installed 

 

The options site I was talking about a few days back.

 

I think you have log in details it is an upgrade site from older bootstrap but most of the stuff was overwritten take a look if you want

 

and feel free to install uninstall etc...

 

demo  

 

php 5.3.28

 

PS: tested with nav bar in and out no problems either way just took it has far as shopping cart could not repeat the error

 

When I view this page with googlebot as user agent page is black, no content, with an error

 

Fatal error: Call to a member function count_contents() on a non-object in /xxxx/xxxxx/public_html/penny/includes/modules/content/header/templates/buttons.php on line 4


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

Turned on strict error reporting few undefined constant is all I see


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

how do you view as google bot through webmaster tools??


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Fetch as google in Webmaster Tools, or fetch the page using aw-snap.info/file-viewer/ (using Googlebot as user agent).

 

I have a user agent spoofer addon for my browser, very handy.


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

Bit wierd this what browser are you using 

 

I am using firefox and the first website I came across shows ok

 

http://www.evolvedwebsites.com.au/googlebot/

 

just those undefined constant  but they are not so important

 

PS:

 

ok going to test with webmaster

post-185951-0-24689900-1417140260_thumb.png

Edited by joli1811

To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Ok confirmed  by big boss google webmaster

[28-Nov-2014 02:20:46 Europe/London] PHP Fatal error:  Call to a member function count_contents() on a non-object in /home/xxx/public_html/xxxx/includes/modules/content/header/templates/buttons.php on line 4

Strange by me no errors in log

 

the buttons appear fine

 

but I see a blank page and the error Frank mentioned from google webmaster fetch and render

 

The fix does not seem to work still testing a bit though


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Try global the $_SESSION as well.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt

function execute() {
     // global $oscTemplate;  
//  global $oscTemplate,  $_SESSION, $cart;
      global $oscTemplate, $cart, $_SESSION;
      $content_width = (int)MODULE_CONTENT_HEADER_BUTTONS_CONTENT_WIDTH;
 
complete blanko with buttons but error message is gone  without buttons it is  good
 
link


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Henrys the man of the moment :thumbsup:

 

Looks good the buttons I give x 4 columns so guess they need a bit more space especially with the log of .

 

wonder if google uses the same snapshot  thing as screenshot cache used to have not sure now.

 

Regards

John

post-185951-0-37255200-1417169981_thumb.png

Edited by joli1811

To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Excellent, I'll commit those changes in a moment. :thumbsup: @ @@wHiTeHaT


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

https://github.com/gburton/osCommerce-234-bootstrap/commit/b133ee05804fcdfcb338ea8c38171e17248e4ee8

 

this commit introduces the concept of templatable boxes, for anyone who wants to try them, let me know your thoughts.

 

Note that this is not committed to Master, only in a branch (for testing purposes).

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt

 

May I ask is the sort field in the navbar module supposed to work as no matter what sort order I use it is always at the top of the page.

 

Thanks

 

Mark


Bootstrap 3 ROCKS!

(or it will if I ever get my head around it lol)

(and I think I have now (w00t) )

Share this post


Link to post
Share on other sites

@@PupStar sort order is useless in that module unless there is another module in the navigation folder as well...make sense ?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@PupStar looks like one of us is going to have u make a logo content navigation module.

 

@@burt is that the right way?

 

@@greasemonkey

 

The logo is already a content module is it not?


Bootstrap 3 ROCKS!

(or it will if I ever get my head around it lol)

(and I think I have now (w00t) )

Share this post


Link to post
Share on other sites

@@burt - trying to catchup with you guys :)

 

Do i understand the templated boxes correctly, that if you want to change it, you edit each box in includes/boxes/templates ?

There is no infobox equivalent anymore ?

 

does this allow for template switching ?


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

@@PupStar

 

 

The logo is already a content module is it not?

 

No its a box module not a content module.

 

I quickly hacked up a navigation logo "content" module and now I can place (via sort order) before or after the cm_navbar.

 

I'm happy to share but would definitely want someone with more experience to check it over.

Share this post


Link to post
Share on other sites

@@PupStar

 

 

No its a box module not a content module.

 

I quickly hacked up a navigation logo "content" module and now I can place (via sort order) before or after the cm_navbar.

 

I'm happy to share but would definitely want someone with more experience to check it over.

 

@@greasemonkey

 

zip it up and attach it and I will give it a go, although I am no expert :thumbsup:

 

are you sure you are running the latest version as I have a cm_header_logo

Edited by PupStar

Bootstrap 3 ROCKS!

(or it will if I ever get my head around it lol)

(and I think I have now (w00t) )

Share this post


Link to post
Share on other sites

@@PupStar @@greasemonkey

Logo is already a content module. You need to drop the navigation content module into the header folder (not forgetting to do the same with it's language file). Then use the sort order system.

 

Be aware that in general, Bootstrap expects the Navbar to be at the top of the page...hence why it is outside of the main container...

 

@@bruyndoncx

In effect, yes. The "control" file is the usual box module, it now has a template so that a template maker can change the appearance of individual boxes as they please. Eg, in my Zack template I have 1 box that is black and all the others are grey. Bear in mind that this templateable box system is only in a branch of the master.

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt

 

tried adding the navigation to the header folder with poor results.

 

I solved it by adding

<div class="clearfix"></div>

at the top of the navbar template

Edited by PupStar

Bootstrap 3 ROCKS!

(or it will if I ever get my head around it lol)

(and I think I have now (w00t) )

Share this post


Link to post
Share on other sites

@@PupStar please ignore my ramblings... I see Gary moved logo (and a bunch of others too... which I will not ask questions about not that I've looked  :blush:  :blush:  :blush: ) to content with the latest updates.

 

@@burt yes I've not updated to the latest changes (still struggling with sourcetree - maybe more time this weekend).

Share this post


Link to post
Share on other sites

That will cause issues as the existing navigation module is built to be outside the container structure. You need to do something slightly different with an "internal" navbar, add a couple of clearfix div's (one before the first line of code in the template file, one after the last the line of code) which might be enough to get the look in place. Won't be perfect as it's trying to ram a oval peg into a round hole (ie, nearly there but not quite). Hope it makes sense?

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×