Jump to content
burt

Responsive osCommerce - Bootstrap

Recommended Posts


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Ah did I no do that yet ? Tonight


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt

on your test site http://template.me.uk/2334bs3/ , the icons in the top bar (black background) don't show properly, it looks like the characters don't exist in the font.

Also the home icon is missing - I've refreshed the page, so I would think I do have the latest css files needed

I'm on FF28.0 on windows 7 starter

 

then when I accessed the create account page, the icons are fetched properly ...

so issue is solved, but I'm puzzled why/what happened


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

@@burt

I searched for DVD on your test site. In advanced search result, there are 17 results, with a previous next icon on the bottom right.

The hover image for the previous and next button look like a red no-parking traffic sign(?disabled), the buttons actually work, but should not.


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

if you go from the home page to Reviews, and then 'read more' on a review, you see the product reviews for one particular product.

At the bottom left of the screen is a back button that goes to the product info page which is kinda odd as the route arriving at the page was different


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

Contact us page is missing the * Required Information label as it is e.g. seen on create account


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

last minor issue I found, if you resize the product info page, making it really small, then the product price is shown before the product name. I would at least expect the product name to be shown first at all times.


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

@@burt

I searched for DVD on your test site. In advanced search result, there are 17 results, with a previous next icon on the bottom right.

The hover image for the previous and next button look like a red no-parking traffic sign(?disabled), the buttons actually work, but should not.

 

@@toyicebear - this is your department, would you take a look at the code please.

 

Don't bother, I amended the code.

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

last minor issue I found, if you resize the product info page, making it really small, then the product price is shown before the product name. I would at least expect the product name to be shown first at all times.

 

Cannot recreate. Can anyone else ?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

if you go from the home page to Reviews, and then 'read more' on a review, you see the product reviews for one particular product.

At the bottom left of the screen is a back button that goes to the product info page which is kinda odd as the route arriving at the page was different

 

https://github.com/gburton/osCommerce-2334-bootstrap/commit/3b90f91c179ee4ca9c800e5c2c63fa01a6a1a7f6


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Contact us page is missing the * Required Information label as it is e.g. seen on create account

 

https://github.com/gburton/osCommerce-2334-bootstrap/commit/6921b3b0a227a5bd66a4107c20fcf9c21c207d65


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Well done. (i checked yesterday but did not see).

 

BTW: because of these good changes you could now put jquery to the bottom aswell. :)

 

https://github.com/gburton/osCommerce-2334-bootstrap/commit/232456a2c28ab59ca6bf54a3aa7b0de6d0a516b2


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

[shame the hiding of the infoBoxes didn't make it.]

 

?? What was the request ?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Cannot recreate. Can anyone else ?

Now, I'm testing on my android phone, the name is on the left half of the screen, the price on the right.

So i guess it only goes to one line if it is soo small that it is practically speaking never that small, even on a old small smart phone like mine.

 

more cosmetics on the phone:

on create account page: * asterisk for male/female is not right aligned, in the input field the * is inside the field right aligned, the * on my phone wraps to the next line underneath male radio button

the icons on the phone are funny, search loop is a pair of scissors, home icon is like tophalf of a circle

 

real issue on my android phone

the collapsed nav bar (black top right) isn't working at all. I try to click/tap on it, nothing happens

I'm using the built-in browser on a samsung GT-I5800 2.1update1 android eclair

javascript is enabled

 

the search results also display strangely, searching on 'DVD' 17 results in portrait mode

row 1, 1 result

row 2; 2 results, left one at approximately 30% width of screen, right result remaining width

row 3: 3 results evenly distributed

 

now i change to landscape

back to portrait

layout changes to

row 1: 1 result 100%

row 2: 2 results each 50%

row 3: 1 result 100%

row 4: 2 results approximately 30% each, left aligned

row 5: 1 result 100%

 

the buynow button, is not fully visible, mostly buy is visible, now drops out of the grid cell


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

Hi Gary

 

The heading in the page can be over-ridden with .css and this is something to do at the end of the project when the basic "foundation" is in place. No problem. Quick example: add to user.css:: h1 { font-size: 15px; } - but we'll do something more special than that in the core code.

 

Just a reminder that something was to be done with fonts and sizes

 

Regards

 

Ken

Share this post


Link to post
Share on other sites

Hi

 

In the footer, in the contact area my page shows, as per the attached thumbnail, what do I need to do to correct, or is this a wee bug.

Also is it possible to use banner manager (in current coding) to place a large banner (650px X 250px)just above the footer.I did this but it screwed the footer, so I removed the banner and all was good.Must be something else I need to do.

In the footer I also dont have the Info box as shown onthe left side of the footer as in

http://www.template.me.uk/2334bs3/index.php

 

Look forward to your comments.

 

Congratulations to everyone involved in the coding etc. Looks like a job extremely well done.

 

Kind regards

Grandpa

post-276414-0-75511100-1396555191_thumb.jpg

Edited by grandpaj

Share this post


Link to post
Share on other sites

@@bruyndoncx of all that the only thing I can reproduce is:

 

on create account page: * asterisk for male/female is not right aligned, in the input field the * is inside the field right aligned, the * on my phone wraps to the next line underneath male radio button

 

I'll let you fix it...


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Hi Gary

 

 

 

Just a reminder that something was to be done with fonts and sizes

 

Regards

 

Ken

 

By the end user, or his/her developer.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Hi

 

In the footer, in the contact area my page shows, as per the attached thumbnail, what do I need to do to correct, or is this a wee bug.

Also is it possible to use banner manager (in current coding) to place a large banner (650px X 250px)just above the footer.I did this but it screwed the footer, so I removed the banner and all was good.Must be something else I need to do.

In the footer I also dont have the Info box as shown onthe left side of the footer as in

http://www.template.me.uk/2334bs3/index.php

 

Look forward to your comments.

 

Congratulations to everyone involved in the coding etc. Looks like a job extremely well done.

 

Kind regards

Grandpa

 

You haven't made the necessary database change. https://github.com/gburton/osCommerce-2334-bootstrap/commit/f8bf8a9e6f8efbb99e8ddc6b9222cd3ab9cb91ed


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt

 

Cannot recreate. Can anyone else ?

 

I see that too (ie the price moving above the product description) but only on a real small screen...ie below 240 pixels.

Share this post


Link to post
Share on other sites

In real life use, would that ever happen. As Carine points out, on a tiny smartphone it's ok


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

silly remark, but colon ':' is used on the contact us page, but not on create account

I think the tendency is to drop the colon,

 

Also during checkout when changing address

http://www.template.me.uk/2334bs3/checkout_shipping_address.php

 

there is no indication of required information, the actual validation works


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

silly remark, but colon ':' is used on the contact us page, but not on create account

I think the tendency is to drop the colon,

 

Fixed. upcoming commit.

 

Also during checkout when changing address

http://www.template.me.uk/2334bs3/checkout_shipping_address.php

 

there is no indication of required information, the actual validation works

 

Can't require anything on this page because the page does two things;

 

1. select an already made address

2. create a new address

 

If we require the address inputs, the user would never be able to select an already made address

 


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
In real life use, would that ever happen. As Carine points out, on a tiny smartphone it's ok

 

Exactly...I was just testing it for you and trying to point out that it was a non issue.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×