Jump to content
burt

Responsive osCommerce - Bootstrap

Recommended Posts

And for those who are not developers but want to help;

 

visit (in your phone, tablet, computer) http://template.me.uk/2334bs3/ and report any bugs or display problems.

 

Thanks

 

Hi Gary,

 

First time I have seen this problem maybe caused by some recent changes on first page load the glyphicon icons are not appearing after first click all is ok

 

Using firefox normal laptop

 

John

post-185951-0-44539400-1395860675_thumb.jpg


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Hi Gary,

 

First time I have seen this problem maybe caused by some recent changes on first page load the glyphicon icons are not appearing after first click all is ok

 

Using firefox normal laptop

 

John

 

that sometimes happens to me but is ok after couple of refreshes.


Bootstrap 3 ROCKS!

(or it will if I ever get my head around it lol)

(and I think I have now (w00t) )

Share this post


Link to post
Share on other sites

One small point. On wider resolutions, when the footer spreads itself out, the Mastercard and part of the Paypal icons are hidden by the floating return to top device

 

The return to top thing is not going to make it into Core as it stands as it does not work on mobile devices :(


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

First time I have seen this problem maybe caused by some recent changes on first page load the glyphicon icons are not appearing after first click all is ok

 

I don't know why that is.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@joli1811@@PupStar

 

That happens if the URL doesn't have the www first.

 

@mattj83 but not on yours ;)


Bootstrap 3 ROCKS!

(or it will if I ever get my head around it lol)

(and I think I have now (w00t) )

Share this post


Link to post
Share on other sites

I don't know why that is.

 

:D :P yes confirmed it is Burts lazy link

 

 

That happens if the URL doesn't have the www first.

 

@@mattjt83


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

That's strange. Oh well ;)


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Online demo of some header and footer changes: http://bettercheckout.com/demo/2334_BS3/

In the small view when the top navigation is collapsed, selecting one of the dropdowns (settings or account) gives a scrollbar on the right, I personally feel it would be better if the area just expanded as needed, so you only keep one (browser) scrollbar.


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

Good. Remember always; because something is not in the core does not mean it is not valuable. That is why there will be a marketplace for addons commercial and free.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

The return to top thing is not going to make it into Core as it stands as it does not work on mobile devices :(

 

On my mobile it works like a charm.

Tested in vertical and horizontal view.

Share this post


Link to post
Share on other sites

@@joli1811@@PupStar

 

That happens if the URL doesn't have the www first.

 

We have already see this bug while using fontawesome + bootstrap. To solve it we had this in htaccess

 

<FilesMatch "\.(ttf|otf|eot|woff)$">
<IfModule mod_headers.c>
Header set Access-Control-Allow-Origin "*"
</IfModule>
</FilesMatch>

Share this post


Link to post
Share on other sites

@@burt

 

Tested the search on your test site: Searched for "Microsoft" - 4 items found - displayed in a list: 1. item displayed in a full width box, 2. item in a 2/3 box, 3. has an undefined width and 4. nearly half width.

Now I click on the grid button, but it doesn't switch to the grid view, but I will headed back to the default site.

Share this post


Link to post
Share on other sites

@@De Dokta - the answer to that is pretty obvious if you think about it ;)


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

 

 

We have already see this bug while using fontawesome + bootstrap. To solve it we had this in htaccess

 

<FilesMatch "\.(ttf|otf|eot|woff)$">
<IfModule mod_headers.c>
Header set Access-Control-Allow-Origin "*"
</IfModule>
</FilesMatch>

 

I added this to the test shop .htaccess, could those who were getting a problem, test it again;

 

http://template.me.uk/2334bs3/index.php

 

and report if it is now OK (or still broken).


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Hint: admin > modules > header_tags > grid/list > {edit} > look at the page list. Even an amateur can do this ;)


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

I added this to the test shop .htaccess, could those who were getting a problem, test it again;

 

http://template.me.uk/2334bs3/index.php

 

and report if it is now OK (or still broken).

 

Fixed in firefox but IE bug explorer seems to have lost the plot

 

Viewing with laptop

Edited by joli1811

To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

I added this to the test shop .htaccess, could those who were getting a problem, test it again;

 

http://template.me.uk/2334bs3/index.php

 

and report if it is now OK (or still broken).

 

Looks good for me No problems so far.

 

Firefox

IE8

Google Chrome

 

Grandpa

Edited by grandpaj

Share this post


Link to post
Share on other sites

The solution was to move the loading of HTML5Shiv from the <head> section to just before the </body> tag.

 

Just something I have picked up on google worth a quick try maybe

 

<!-- Bootstrap -->

<link href="ext/bootstrap/css/bootstrap.min.css" rel="stylesheet">

 

 

 

<!-- Custom -->

<link href="custom.css" rel="stylesheet">

<!-- User -->

<link href="user.css" rel="stylesheet">

 

<script src="ext/jquery/jquery-1.8.0.min.js"></script>

<script src="ext/bootstrap/js/bootstrap.min.js"></script>

 

<link rel="stylesheet" media="screen,projection" href="ext/uitotop/css/ui.totop.css" /></head>

<!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries -->

<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->

<!--[if lt IE 9]>

<script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script>

<script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script>

<![endif]-->

<body>


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Hint: admin > modules > header_tags > grid/list > {edit} > look at the page list. Even an amateur can do this ;)

 

Stupid of me! :blush:

But the real problem is the presentation of search results.

 

 

Share this post


Link to post
Share on other sites

@@De Dokta - it seems to be just you having problems with this, so I consider this a problem between your monitor and your keyboard ;) :D


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

This effect particularly annoys me, see attached image. This is where (in smaller viewports) 1 line of nav moves under the other. What do others think ?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt

 

This effect particularly annoys me, see attached image. This is where (in smaller viewports) 1 line of nav moves under the other. What do others think ?

 

I don't get that Gary....my screen very nicely goes from this to this...

post-182953-0-81612200-1395922706_thumb.jpg

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×