Jump to content
burt

Bootstrap 3 in 2.3.4 - Responsive from the Get Go

Recommended Posts

Yes, the user.css should be there, when I updated things to 2.3.4 I somehow accidentally removed the stylesheet and the call to it in template_top.php


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

Thanks everyone! :)

 

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

Two more observations ...

 

1) The MODULE_CONTENT_CREATE_ACCOUNT_LINK_SORT_ORDER record is missing in the Configuration table

 

2) Is there supposed to be a closing ?> at the end of the catalog/included/filenames.php file?

 

Plus ... if anyone is using Burt's "SEO Header Tags - Reloaded" add-on ...

 

1) The BOX_HEADING_ORDERS and BOX_ORDERS_ORDERS definitions are missing from catalog/admin/includes/languages/english.php

 

2) If you *also* use the "Information Pages Unlimited" add-on (which Burt includes patches for in "SEO Header Tags - Reloaded"), the file catalog/includes/modules/boxes/bm_information.php *will* require changes in order to: 1) work, and 2) be able to move the Information box to the footer (as it currently is able to do in 234bs).

 

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

And another observation....

 

In template_top.php one can find:

<meta charset="utf-8">
<meta charset=<?php echo CHARSET; ?>>
 

which results in html in:

<meta charset="utf-8">
<meta charset=utf-8>

 

Is there any reason for that double entry?

 

J.J.

Share this post


Link to post
Share on other sites

And another observation....

 

In template_top.php one can find:

<meta charset="utf-8">

<meta charset=<?php echo CHARSET; ?>>

 

which results in html in:

<meta charset="utf-8">

<meta charset=utf-8>

 

Is there any reason for that double entry?

 

J.J.

This is fixed.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Yes, I missed the user.css too! But no problem - create a new one (or copy it from your previous BS2334) and add an entry to your template_top.php after <link href="custom.css" rel="stylesheet">

                                    <link href="user.css" rel="stylesheet">

 

I think it was a very good idea of burt to say "Keep the core including the custom.css untouched and write all your style changes into the user.css". This way you can simply transfer your styles from shop to shop and also very simply restore the original state of BS2334.

 

J.J.

This is now fixed. user.css reintroduced.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

1) The MODULE_CONTENT_CREATE_ACCOUNT_LINK_SORT_ORDER record is missing in the Configuration table

Suggest to uninstall and reinstall the module.

 

2) Is there supposed to be a closing ?> at the end of the catalog/included/filenames.php file?

No


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

1) The readme.md file still says it is 2.3.3.4bs

 

2) I do not see a user.css file in the /catalog directory. Is it just missing, or is this function no longer used?

Both fixed.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Suggest to uninstall and reinstall the module.

 

Thanks, that fixed it.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

It's possible that the installation SQL does not contain all the necessary bits for this module @ ?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

@@burt

 

Oddly enough it is in there, last line of the oscommerce.sql

https://github.com/gburton/osCommerce-2334-bootstrap/blob/master/install/oscommerce.sql

 

I double checked the module, and the key is there.

 

hmmmm

 

That part of the install was a direct copy from the 2.3.4 sql


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

Let's put it down to experience and see if the same problem ever crops up again.  Thanks @


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

@@burt,

 

Could you please review this commit to add it to the project? If someone upgrades from an old 2.2 database or has disabled action recorder module login is not allowed to the new admin.

 

https://github.com/Piernas/osCommerce-2334-bootstrap/commit/ef508fcd38f367d6df019b67b42ba1cd5a6b51e6

 

It took me an hour of research first time it happened, and I have to do it again and again every time I do a clean install, so Im sure others may be on the same situation and this small change wil fix the problem.

Share this post


Link to post
Share on other sites

This does not have anything to do with Bootstrap @@piernas

 

Report this as a bug so that it can be tested and go into the official core.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Sonething like that will be added.  All pages are due to be modularised for 2.4

 

That wont happen in the community build though.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Thank you. I'm planning to upgrade my current shop and as a lot of work adapting addons and mods will be done I'm trying to figure out what will change in the near future and what not. If this will not happen soon I'll use this code in my shop.

 

One suggestion: image directory is still filled up wth a lot of unused files (table_background_XXXXXX,gif, account_XXXXXX.gif, box_XXX.gif)  that can be safely removed as OSC bootstrap version does not use them anymore.

Share this post


Link to post
Share on other sites

Just starting a new small project and was thinking to use this community build. I've just downloaded v2.3.4 from github and all looks good... I'm in the process of installing and the only issue I've seen is - I previously downloaded the v2.3.3.4 build and became momentarily confused when I notice the zip file still called 2.3.3.4 (osCommerce-2334-bootstrap-master.zip). Maybe it should be updated to osCommerce-234-bootstrap-master.zip?

 

I don't know anything about github... so maybe this is off base. If so, my apologies.

Share this post


Link to post
Share on other sites

Just starting a new small project and was thinking to use this community build. I've just downloaded v2.3.4 from github and all looks good... I'm in the process of installing and the only issue I've seen is - I previously downloaded the v2.3.3.4 build and became momentarily confused when I notice the zip file still called 2.3.3.4 (osCommerce-2334-bootstrap-master.zip). Maybe it should be updated to osCommerce-234-bootstrap-master.zip?

 

I don't know anything about github... so maybe this is off base. If so, my apologies.

It should be changed, but I am not exactly sure how to do that. I updated the readme.md file to reflect that is now 234 instead of 2334.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

https://github.com/gburton/osCommerce-234-bootstrap

 

I think I managed to change it. The old URL should redirect to this also.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

https://github.com/gburton/osCommerce-234-bootstrap

 

I think I managed to change it. The old URL should redirect to this also.

yes it does


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×