Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Archived

This topic is now archived and is closed to further replies.

nikhilkh

Upgradation of OSC v2.2-ms2 to latest osc v2.3.3.4

Recommended Posts

I m currently using osc version 2.2-ms2. I want it upgraded to latest version 2.3.3.4.

It it possible to upgrade from osc v2.2-ms2 to osc v2.3.3.4.

 

Thanks in advanced,

Nikhil Khandare

Share this post


Link to post
Share on other sites

You will have to do the upgrade in steps, starting with RC2 and then updating each following version step by step.

 

Or simply start of with a brand new 2.3.3.4 cart and just import over customers/orders/products from the old shop.

Share this post


Link to post
Share on other sites

Hi

 

I have the same question but a little more basic. What would be the criteria one would use to make the decision to upgrade from v2.2-ms2. to a later version. We have a highly customized site w/ a lot of traffic and transactions, the site works well. However I am concerned about working off 12 year old software, in the context of site speed, outdated php, Etc. Some criteria would be helpful.

Share this post


Link to post
Share on other sites

well you will have to upgrade sooner or later one day the site will stop working or if you really invest the time wrongly in trying to patch you have then a patched store !!

 

You are correct in thinking ahead best way is to start now.

 

you have time to build a new store in a sub directory / and tweak and test until satisfied so install a new 2.3.3.4 in an extra directory put in a no index robot text and start first importing your database into the new store and then follow with the design and addons that you need most should work with 2.3.3.4

 

The ones that may not you will have to ask for help here on the forum or maybe pay a developer to make new the design can be cloned 99% again enough info here in the various threads.

 

Most important is to start now so you do not end up trying to catch your tail.

 

My opinion only.

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

It is possible to manually patch a 2.2MS2 store to add security patches and make it PHP 5.4+ compatible. However, you will reach a point of diminishing returns as the effort to keep it patched exceeds the benefits of the store continuing to run. If you suck up the pain of jumping to 2.3.3.4, you should be much better positioned for not only future PHP upgrades, but the increasing number of osC 2.3.* add-ons available, and migration to osC 2.4 and eventually 3.1.

 

You can (and should) make a test/development installation of osC 2.3.3.4 to run in parallel with your production store (but on a copy of your database). Then you have the time to carefully investigate what you need in the way of add-ons and theme tweaks and any custom coding (which is hopefully well documented), rather than being in a mad rush to do this when your 2.2-based store finally and irrepairably breaks down.

Share this post


Link to post
Share on other sites

Please I need this help too!

 

I´ve tried a lot to upgrade from 2.2ms2 to newers versions but I´ve got no sucess...

 

The main question is: How can I restore the template and database of my 2.2 to a 2.3 version? I installed 2.3 but when I click restore backup database there´s no change, I can´t see my old data in the new version...seems like there´s no changing...

 

Please hel! I´ve been trying this for a month!!!

 

Thanks a lot!!!

Share this post


Link to post
Share on other sites

First of all, does your database backup (.sql file) drop the old tables, create new ones, and then insert data into them? Those are steps to get your old data under a new osC. Then you have to modify that database to be compatible with osC 2.3.3.4 (see the add-on to help you with that). After all that, you should have a working 2.3.3.4 version with your own data.

Share this post


Link to post
Share on other sites

×