Jump to content

Archived

This topic is now archived and is closed to further replies.

lildog

Page forbidden

Recommended Posts

I am having a permissions issue....I think. When I try to check out, the checkout shipping page renders correctly. Then When I press continue I get a 403 Page forbidden error...Specifically:

 

Forbidden

 

You don't have permission to access /checkout_shipping.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

The server just upgraded to php 5.4 from 5.3, Apache from 2.2.25 to version 2.4.7and also MySQL from 5.1.70 to version 5.5.32.

 

The permissions on checkout shipping are set to 755. I solved a few other issues but cannot figure this one out.

 

Thank you very much for your help,

 

Todd

Share this post


Link to post
Share on other sites

If you're running osC 2.2, you will have needed to make a lot of patches to the code to run on PHP 5.3, much less 5.4. Assuming you've done that, see what the ownership of checkout_shipping.php is. You say the permissions are 755 -- they should be 644, but 755 should do no harm. If you were downloading/editing/uploading files to make them compatible with PHP, maybe FTP changed ownership on a few files.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozenpatches or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

The permissions are definitely 755. The site did run well under php5.3. Last year did a bunch of patching. Just cannot figure out why the checkout shipping loads the first time but not when the continue button is pressed. I am at a total loss. The server is not generating any error other than the vague forbidden message. The site is duds4buds.com. The site is not working so the test account is lildog01@gmail.com and the password is doodlebug. Once I get it working I will change the credentials.

 

Todd

Share this post


Link to post
Share on other sites

Except in a few strangely configured PHP installations, 755 is unnecessary. You don't need "executable" enabled. 644 (r/w for owner, r/o for everyone else) is normally sufficient. Are your other PHP files 644? Maybe your system is restricting execute-enabled PHP for some reason.

 

The other big cause of 403 errors is that your host has a foolishly configured "mod security" set up. This looks for certain words, etc. in the URL Query String (among others) and kills it with a 403. Talk to your host and find out how to shut off "mod security", and see if that helps.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozenpatches or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

×