Jump to content
bbsrover

7.1.0 USPS module 11/14/2013 Fix: Domestic OK But Intl Not

Recommended Posts

Thanks for BDuell's and lousterg's fixes on 11/13/2013 and 11/14/2013 respectively. http://addons.oscommerce.com/info/487

 

lousterg's fix was uploaded. Domestic rate is working now. But international still has error.

 

I noticed 'RateV4Response' in the international shipping section in the usps.php at line 1525:

 

$tmp = $this->_decode_intl_response($doc['RateV4Response']['Package']['Service'], $nonuspsinsurancecost, $pkg['item_price']);

 

Not sure if 'RateV4Response' should be 'IntlRateV2Response' in this line since it's intl shipping.

However, I changed it to 'IntlRateV2Response' but it still has same error.

 

Any feedback is appreciated.

 

Bill

Share this post


Link to post
Share on other sites

My international is still down. I'm running Lousterg's fix, but there's no change. I removed and reinstalled. no affect.

Share this post


Link to post
Share on other sites

My domestic was fixed this morning with the patch after I removed and installed via the admin panel. (it would be nice if it would display the current version you have while logged in!!!)

Perhaps this might have some info and might affect the international as well??

 

The USPS shipping module has detected that the USPS Rates API has returned a domestic service response name that is not listed in the module's complete list of domestic response types. As this could create problems with providing customers with USPS rate quotes you should check as soon as possible the documentation for the Rate Calculator on the USPS Web Tools internet page for changes that could affect the working of this module.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×