Jump to content
daclinz

USPS Shipping Methods - not working

Recommended Posts

OK, Downloaded and installed USPS shipping methods this morning. Tried several different settings and I get this message on checkout

 

"United States Postal Service

(1 pkg, 8.00 lbs total)

 

"An error occured with the USPS shipping calculations.

If you would like to use USPS as your shipping method, please contact the store owner."

 

Would I have something set incorrectly in the module options, The only thing I am looking for is Priority Mail (Domestic) and Priority Mail (International).

 

To be perfectly honest I use USPS Prices as a general shipping quote.

 

Currently using OSC V2.3

Edited by daclinz

Share this post


Link to post
Share on other sites

I got it too. There was a fix posted. Just replaced the usps.php file and it worked easy peasy. What I would do is go into the admin area open the usps settings then duplicate the window...uninstall the module in the second window, then install again and copy the settings from the first window.

 

http://addons.oscommerce.com/info/487

Share this post


Link to post
Share on other sites

This mess was caused by changes in the response that USPS made on Saturday. There are fixes available for the commonly used modules. Check the support thread for the USPS module you are using.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

You need to uninstall and reinstall the module. I had to update it again this morning since the fix still had a few errors.

 

Open the shipping module hit edit, then right click on the tab and open a duplicate tab, then in the duplicate tab uninstall the module.

 

When you uninstall the module it loses all the settings (which is stupid) reinstall the module click edit... then go to edit on the first tab you left open which should contain all the old info and then save it.

 

Where is the official support thread? It should be posted in the help file and or description of the add on...

 

I am having same issues even after adding the update file.

Share this post


Link to post
Share on other sites

Dears,

I install update USPS module. also got this error:

United States Postal Service (1 pkg, 0.50 lbs total)

-2147219101 Missing value for Service.

 

Would you please help to give your suggestion asap?

Share this post


Link to post
Share on other sites

Just fix it. You need change admin/modules.php

 

from old

// USPS START

if( is_array( $value ) ) $value = implode( ', ', $value);

// USPS END

 

 

To

 

 

 

// USPS START

if( is_array( $value ) ){

$value = implode( ", ", $value);

$value = preg_replace ("/, --none--/", "", $value);

}

 

// USPS END

Share this post


Link to post
Share on other sites

hello Jim @kymation

 

I installed your USPS Shipping method and I got the following error

 

An error occured with the USPS shipping calculations.
If you prefer to use USPS as your shipping method, please contact the store owner.

 

How can I fix it?

Share this post


Link to post
Share on other sites

I don't own a USPS Shipping method, or any part of the USPS for that matter. I would be making a lot of changes if that were the case.

 

If you are referring to the USPS Methods Rates V4 Intl Rates V2 - 01-27-13 Update, the support thread is here. Read the last few posts and try the suggested fixes there.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×