Jump to content
Tsimi

SEO Header Tags - RELOADED support?

Recommended Posts

Looks fine in all 3 languages ... I see no difference in any of them (other than translated words).


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Looks fine in all 3 languages ... I see no difference in any of them (other than translated words).

 

:huh: you mean you don't see any bold font??

 

i don't mean the description on the left, i mean the description further below where the two chopsticks and the test item are listed.

Edited by Tsimi

Share this post


Link to post
Share on other sites

oh, down below. didn't notice.

 

you have not closed a <strong> tag, by means of a malformed ending /strong

 

<strong>Pas au lave-vaisselle!</ strong>

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Hi,

Yes I see it not at the top right but further down the page (which Burt may have been looking at )

 

.slaveName {

font-family: Lucida Grande, Lucida Sans, Verdana, Arial, sans-serif;

font-size: 14px;

font-weight: bold;

}

 

where is this coming from still searching looks maybe a bit suspicious


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

@@burt was right! (w00t)

 

jesus how could i miss that!? :blink: :sweating:

i was looking all the time at the product that has the bold font trouble instead of looking at the product above! :-

 

many thanks burt!

 

@@joli1811

 

Thanks for helping! :thumbsup:

Edited by Tsimi

Share this post


Link to post
Share on other sites

.slaveDescr {

margin-top: 10px;

font: normal 13px Arial, sans-serif;

}


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

une facile explication, n'est-ce pas ?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

lol :lol: :P yes indeed.

 

@@burt

 

need to ask you a couple things regarding the package, IF you got a time.

Edited by Tsimi

Share this post


Link to post
Share on other sites

catalog/includes/classes/breadcrumb.php say's:

 

$trail_string .= '<span itemscope itemtype="http://data-vocabulary.org/Breadcrumb">

 

---------------------------------------------------------------

http://data-vocabulary.org/Breadcrumb accepted

 

Seems to be OK when run thru http://www.google.com/webmasters/tools/richsnippets


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

I installed this addon and it does almost what I want.

The almost is for the html part.

I readed somewhere that I can not use html with this addon and I'm to affraid to try it.

I spent 2 day's to get my site working again, (then I also installed this and used html)

I'm new to OS and tried to read as much as I can last 2 weeks, but for a relative noob like me it's a lot:p

Can someone pls. tell me if it's possible to use html by the (sub) category pages, without the need of complex instalations first?

(only part I use from this addon, to afraid to try the rest and mess up again:p)

Thanks in advance

Share this post


Link to post
Share on other sites

Hi Loet ,

 

The html can be used in product description and category description

 

BUT should NOT be used in the new seo fields (meta description )

 

Using in the mini description if it is activated will also probably break the format so better no html there.

 

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Hi Loet ,

 

The html can be used in product description and category description

 

BUT should NOT be used in the new seo fields (meta description )

 

Using in the mini description if it is activated will also probably break the format so better no html there.

 

Regards

Joli

 

Thanks for your respons.

I messed it up again:p

Somehow 2 addons can't work together.

I also have a addon "frontpage", wich allows me to make the frontpage exactly as I like (with the use of html)

I tried several way's, installing frontpage first then this one, and vice versa.

I cant have both, editing the frontpage and editing the categories, it's 1 of the 2 only.

Wich looks strange to me and I'm certain I do something wrong, just can't figure out what:p

 

I tried

Share this post


Link to post
Share on other sites

Well this works fine with Seo header tags reloaded

 

http://addons.oscommerce.com/info/1026 the version from SLiCK_303 27 May 2011

 

there is an extra module in the reloaded package specifically for this addon

 

Do the reloaded install first as it is slightly more complicated if it is a new install just simply overwrite your files with the new reloaded.files

 

Then make sure you put the additional code for the information add on in the right place paying special attention to your index.php

 

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Hi im not sure if my site is using "normal" osCommerce or "bootstrap" osCommerce,

www.footballgifstore . com

 

would appreciate your help

thanks

Edited by fubar1010

Share this post


Link to post
Share on other sites

The link does not work www.footballgifstore.com if you mean http://footballgiftstore.com the site is broken so impossible to say

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Hi All,

 

Mini fix: for reloaded

 

After Live Chat with Burt in chat room  to fix quotes throwing an error when updating or  changing reviews and testimonials we need to add

 

 

"Burt says "

burt
add tep_db_input() around $review

Line: #56     admin/reviews.php replace with

 //tep_db_query("insert into " . TABLE_REVIEWS_DESCRIPTION . " (reviews_id, languages_id, reviews_text) values ('" . (int)$insert_id . "', '" . (int)$languages_id . "', '" . $review . "')");
   tep_db_query("insert into " . TABLE_REVIEWS_DESCRIPTION . " (reviews_id, languages_id, reviews_text) values ('" . (int)$insert_id . "', '" . (int)$languages_id . "', '" . tep_db_input($review) . "')");
       

and with

 

line:  #68  admin/reviews.php 

 //tep_db_query("insert into " . TABLE_REVIEWS_DESCRIPTION . " (reviews_id, languages_id, reviews_text) values ('" . (int)$insert_id . "', '" . (int)$languages_id . "', '" . $review . "')");
   tep_db_query("insert into " . TABLE_REVIEWS_DESCRIPTION . " (reviews_id, languages_id, reviews_text) values ('" . (int)$insert_id . "', '" . (int)$languages_id . "', '" . tep_db_input($review) . "')");
      

Regards

Joli

Edited by joli1811

To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Ok, on my initial testing, I have identified a couple of items ...

 

1) the definitions BOX_HEADING_ORDERS and BOX_ORDERS_ORDERS are not added to catalog/admin/includes/languages/english.php.  Simple thing to add, though.

 

2) *If* you are using the "Information Pages Unlimited" add-on (which Burt includes patches for in "SEO Header Tags - Reloaded), you will need to edit catalog/includes/modules/boxes/bm_information.php in order to: 1) make it work, and 2) allow you to put the Information box in the footer (which you can in 234bs). Let me know if you need the edited file.

 

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

If I may ask ... can someone else duplicate and/or confirm this for me ...

 

When I install a clean version of 234bs, the 'Contact Us' screen looks like this:

 

 

 

As soon as I install SEO Header Tags - Reloaded, it looks like this:

 

 

 

Notice where the asterisk that was in front of the 'Required Information' has moved to ...

 

 

(Apparently, I also had this bug back with 2334bs too, but hadn't noticed it ...)

 

Malcolm

 


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

Another finding ...

 

When installing SEO Header Tags - Reloaded into a Bootstrap site (either 2334bs or 234bs), the file: catalog/includes/languages/english/specials.php  is missing the TEXT_NO_PRODUCTS definition.

 

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

seo header tags reloaded is for 2334bs, not 234bs.

 

If someone wants to sponsor the code changes, then the code changes would be done.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt

 

there is this piece of code inside the pages title module

      if ( (defined('META_SEO_TITLE')) && (strlen(META_SEO_TITLE) > 0) ) {
        $oscTemplate->setTitle(tep_output_string(META_SEO_TITLE)  . ', ' . $oscTemplate->getTitle());
      }

is it intended to be like this?  I mean the STORE_NAME  (which it takes from the english.php, line 50) comes "after" the META_SEO_TITLE

When I create fav icons for apple products or windows 8 tiles i get the company logo and underneath it shows the META SEO TITLE instead of the Company name.

Can the position be switched without harming the SEO?

Or should i just keep an empty define inside the english.php and add the company name inside the META_SEO_TITLE?

Share this post


Link to post
Share on other sites

Or should i just keep an empty define inside the english.php and add the company name inside the META_SEO_TITLE?

 

this sounds right ... give it a go and report back.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt

 

Thanks G. Will do.

 

UPDATE:

 

That did the trick. Now Store Name is first and then the rest.

 

STORE_NAME | bla, bla, bla, bla,.....

 

Text on the Icons show just fine now...thanks again.

Edited by Tsimi

Share this post


Link to post
Share on other sites

@@joli1811

 

John, in admin/reviews.php with a testimonial in place

 

- Under the testimonial header in the table, does the gif show red or green?  Mine is red.

- When you double click the testimonial taking it to preview

 

https://www dot myshop dot com/myadmin/reviews dot php?page=1&rID=6&action=preview

 

 

I am getting these warnings:

 

 

 

Warning: array_merge(): Argument #2 is not an array in /home/username/public_html/myadmin/reviews.php on line 166

Warning: reset() expects parameter 1 to be array, null given in /home/usernamepublic_html/myadmin/includes/classes/object_info.php on line 17

Warning: Variable passed to each() is not an array or object in /home/username/public_html/myadmin/includes/classes/object_info.php on line 18

 

And below it looks like so:

 

 

 

Reviews pixel_trans.gifProduct: 
From: 

Date: Review:

 

Meaning no data.  However when editing works fine.

 

https://www dot myshop dot com/myadmin/reviews dot php?page=1&rID=6&action=edit

 

Wondering if you've noticed this?

 

 

 

Hi All,

 

Mini fix: for reloaded

 

After Live Chat with Burt in chat room  to fix quotes throwing an error when updating or  changing reviews and testimonials we need to add

 

 

"Burt says "

burt
add tep_db_input() around $review

Line: #56     admin/reviews.php replace with

 //tep_db_query("insert into " . TABLE_REVIEWS_DESCRIPTION . " (reviews_id, languages_id, reviews_text) values ('" . (int)$insert_id . "', '" . (int)$languages_id . "', '" . $review . "')");
   tep_db_query("insert into " . TABLE_REVIEWS_DESCRIPTION . " (reviews_id, languages_id, reviews_text) values ('" . (int)$insert_id . "', '" . (int)$languages_id . "', '" . tep_db_input($review) . "')");
       

and with

 

line:  #68  admin/reviews.php 

 //tep_db_query("insert into " . TABLE_REVIEWS_DESCRIPTION . " (reviews_id, languages_id, reviews_text) values ('" . (int)$insert_id . "', '" . (int)$languages_id . "', '" . $review . "')");
   tep_db_query("insert into " . TABLE_REVIEWS_DESCRIPTION . " (reviews_id, languages_id, reviews_text) values ('" . (int)$insert_id . "', '" . (int)$languages_id . "', '" . tep_db_input($review) . "')");
      

Regards

Joli

Edited by altoid

I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×