Jump to content
Tsimi

SEO Header Tags - RELOADED support?

Recommended Posts

Hi

 

I recently installed the above addon. However when I click on manufacturers in the web site I get this

 

1054 - Unknown column 'manufacturers_seo_description' in 'field list'

select manufacturers_seo_description, manufacturers_seo_keywords from manufacturers_info where manufacturers_id = '35' and languages_id = '1'

 

[TEP STOP]

 

I have already inserted into DB the following.

 

ALTER TABLE `reviews`
ADD `is_testimonial` TINYINT( 1 ) NOT NULL DEFAULT  '0';

ALTER TABLE `products_description`
ADD `products_seo_title` VARCHAR( 128 ) NULL,
ADD `products_seo_description` TEXT NULL,
ADD `products_seo_keywords` VARCHAR( 128 ) NULL,
ADD `products_mini_description` TEXT NULL;

ALTER TABLE `categories_description`
ADD `categories_description` TEXT NULL,
ADD `categories_seo_title` VARCHAR( 128 ) NULL,
ADD `categories_seo_description` TEXT NULL,
ADD `categories_seo_keywords` VARCHAR( 128 ) NULL;

ALTER TABLE `manufacturers`
ADD `manufacturers_seo_title` VARCHAR( 128 ) NULL;

ALTER TABLE `manufacturers_info`
ADD `manufacturers_description` TEXT NULL,
ADD `manufacturers_seo_description` TEXT NULL,
ADD `manufacturers_seo_keywords` VARCHAR( 128 ) NULL;

 

And to check I tried inserting again, and got the following message;

SQL query:

ALTER TABLE `products_description` ADD `products_seo_title` VARCHAR( 128 ) NULL ,
ADD `products_seo_description` TEXT NULL ,
ADD `products_seo_keywords` VARCHAR( 128 ) NULL ,
ADD `products_mini_description` TEXT NULL ;

MySQL said: Documentation
#1060 - Duplicate column name 'products_seo_title'

 

If I turn of  Module>Header Tags>Manufacturer Meta the problem dissapears.

 

What should I do to fix this prob. Im sure Ive installed correctly.

 

Many thanks

 

Grandpa

Share this post


Link to post
Share on other sites

@@grandpaj  John did you try turning on the module after running the query a second time....the error messages you posted seem to relate to the product_seo stuff and not the manufacturers_seo components....I'm wondering if it fixed it but you just don't realize it.

 

Dan

Share this post


Link to post
Share on other sites

@@Dan Cole

 

Hi Dan

 

Thanks for your thoughts, tried as suggested but made no difference.

 

Just wondering if I managed to somehow, somewhere,  stuff up a .php file if that would create the above problem.

 

The other thing is, how would I find and delete the above SQL, then try reinstallin again.

 

Cheers

 

Grandpa.

Share this post


Link to post
Share on other sites

@@Dan Cole

Hi Dan

 

Don't ask me how, but I  took a look at application top.php changed to an "old version"  then  reinstalled Manufacturers Meta then changed the application top.php back, now all seems to work. Lets hope its all good.

 

Many thanks for your help.

 

Grandpa

Share this post


Link to post
Share on other sites

I tried to install it but have already an error in the sql upload!!

 

SQL-query:

 

ALTER TABLE `categories_description`
ADD `categories_description` TEXT NULL,
ADD `categories_seo_title` VARCHAR( 128 ) NULL,
ADD `categories_seo_description` TEXT NULL,
ADD `categories_seo_keywords` VARCHAR( 128 ) NULL;

 

MySQL meldt: dot.gif

#1060 - Duplicate column name 'categories_description' 

 

Installed a virgin osc234bs edge, nothing else & tried to made the sql changes.

 

SQL-query:

 

ALTER TABLE `categories_description`
ADD `categories_description` TEXT NULL,
ADD `categories_seo_title` VARCHAR( 128 ) NULL,
ADD `categories_seo_description` TEXT NULL,
ADD `categories_seo_keywords` VARCHAR( 128 ) NULL;


 

MySQL message: dot.gif

#1060 - Duplicate column name 'categories_description' 

 

I'm running php 5.4.45

Share this post


Link to post
Share on other sites

Sounds like you already have the column 'categories_description' in your database....have a look at the table to see if you also have the other columns...if not you could change the sql query to.

 

ALTER TABLE `categories_description`
ADD `categories_seo_title` VARCHAR( 128 ) NULL,
ADD `categories_seo_description` TEXT NULL,
ADD `categories_seo_keywords` VARCHAR( 128 ) NULL;

 

That should add the additional columns for you.

 

Dan

Share this post


Link to post
Share on other sites

I tried to install it but have already an error in the sql upload!!

 

Edge contains code that makes addons incompatible.

 

In any case, most of this addon is built into Edge, with the rest going in over the weekend.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Edge contains code that makes addons incompatible.

 

In any case, most of this addon is built into Edge, with the rest going in over the weekend.

Well, good sake, did'n know EDGE makes addons incompatible!!

How I did it as a newbie to integrate 27 addons in EDGE?

All working properly (finally).

Not easy as some addons prevent other addons to works properly or to get integrated.

From A 2 Z the shop is working fine & smoot on small & xtra small devices.

Looks professionally, the greatest innovation is that there no need to setup a mobile version of your shop.

Now have to finish the layout

Great work @@burt & Co

I thank you all to made this possible & to them that have spend time to support me

saludos 

Share this post


Link to post
Share on other sites

Sounds like you already have the column 'categories_description' in your database....have a look at the table to see if you also have the other columns...if not you could change the sql query to.

 

ALTER TABLE `categories_description`

ADD `categories_seo_title` VARCHAR( 128 ) NULL,

ADD `categories_seo_description` TEXT NULL,

ADD `categories_seo_keywords` VARCHAR( 128 ) NULL;

 

That should add the additional columns for you.

 

Dan

Hola @@Dan Cole

 

seems me logic there categories & categories description. In every shop you will find that.

I deleted that line, got other errors into the shop.

I decide to quit & leave this addon.

When It goes wrong with the first thing you have to do to integrate an addon & you dont get support, then it's over & out

 

nice weekend

Share this post


Link to post
Share on other sites

Hello,

When i create new product, there is  filed ( Product Mini Description:Used in the "product list" in Category Pages.)

 is it mean that  Product Mini Description will show in the products_listing? if it is, will show it  in grid view also?

 

thanks 

BR

Omar


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Dear @@burt

 

Comparing the files that are included in the zip SEO Header Tags - Reloaded - 2016 04 07 and the last version of EDGE (Responsive-osCommerce-master) downloaded from : 

 

https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip

 

I found that some files are missing,  like:

 

catalog\includes\modules\header_tags\ht_category_meta.php

catalog\includes\modules\header_tags\ht_manufacturer_meta.php

catalog\includes\modules\header_tags\ht_pages_meta.php

 

that's okay ?

 

Best regards

 

Valqui


Running Old EDGE, setting up a new Frozen site with many nice addons available on the market and waiting to be admitted to Phoenix club!

Community Oscommerce fan :heart:

 

Share this post


Link to post
Share on other sites

Hi,

I have duplicate meta tags title and description on my index page.

 

I can eliminate duplication by changing the code in the ....includes/modules/header_tags/ht_pages_title.php

 

if ( (defined('META_SEO_TITLE')) && (strlen(META_SEO_TITLE) > 0) ) {
        $oscTemplate->setTitle(tep_output_string(META_SEO_TITLE)  . ', ' . $oscTemplate->getTitle());

to

 if ( (defined('META_SEO_TITLE')) && (strlen(META_SEO_TITLE) > 0) ) {
        $oscTemplate->setTitle($oscTemplate->getTitle());

 

but i don't know if i would be doing the right thing, also it wouldn't solve my duplicate description problem.

 

My version is 2.3.4.BS and i have SEO URL5 installed

 

Please help!!!! Thanks.

Share this post


Link to post
Share on other sites

that's okay ?

Yes.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@Lary_an

 

So far as I recall, getTitle outputs the name of the shop, nothing more.

So, you may have made changes to this. Do you know?

 

Anyway, update to Edge version of this, as it is more tested.

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

@@burt

 

Thank you for quick reply.

 

We started the upgrade to our shop on 02/09/16 with download of 

https://github.com/gburton/osCommerce-234-bootstrap/archive/master.zip (still confused if it was gold or edge - we took the version recommended in the forums)

and there are a lot of addons already installed, so if we start another upgrade we have to start from scratch again.

 

As far as i can tell we have not made any changes to getTitle - i don't know where getTitle is located, so can't be sure.

 

Also how do i get rid of duplicate meta description in my index file? it look like this:

 

<meta name="description" content="mysite.com my text description." />
<meta name="description" content="mysite.com my text description." />

 

Thank you very much for your help.

Share this post


Link to post
Share on other sites

No one has any real clue as to what you've done, so you'd need to work back through your changes until you find it corrects itself.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Hello,

     I need help to understand how I have to fill the SEO Header Tags fields:

"Products Title for SEO" : I usually leave it blank because it is the same of the "Product Name"

"Product Mini Description": I usally write a (mini) description about the product; in same case it is the same of the "Product Name".

"Product Meta Description for SEO": I usually write a description about the product, in same case it is the same of the "Product Description".

"Product Meta Keywords for SEO": I usually write the keywords for SEO, but some Keys are not comma separated. For ex. I write "Engine mount" and NOT "Engine, mount".

I never write any meta in all SEO's fields.

Is everything right?

 

For example:

Product Name: ABS 64dp spur gear

"Products Title for SEO"  :

"Product Mini Description": ABS 64dp spur gear.

"Product Meta Description for SEO": 64dp spur gear made in ABS

"Product Meta Keywords for SEO":  64dp, ABS spur gear, "trademark of the spur gear", "item code of the spur gear"

 

Really many thanks in advanced.

Ciao

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×