Jump to content

Archived

This topic is now archived and is closed to further replies.

quetevendo

osCommerce Online Merchant v2.3.3.1

Recommended Posts

I have to say that you are right and not. There are two choices. The first is do nothing the second is do something.

 

We can do nothing with connection problems, and do nothing with jQuery, fancybox and other issues or do nothing with subreleases. We could leave them alone or we could do small steps for future.

 

The subrelease refressing serves for security and stability. We know that many non-conform addons used for oscommerce and will be many conflicts but we should go forward. Non-comform addons brakes the oscommerce and not helps for community.

The subrelease following is not obligated and shop owners could update later when the core will be finalised to v2.3.4 version. I hope after some modifications we could get experiencies about issues. Later the addons will be fixed and shop owners could safety use the new release.

 

I dont want to say that everything is all right but we can't stay here.


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

@@joli1811

As far as I remember the jquery-migrate-1.2.1.min.js also did not solve this problem the image pop up did not work until I changed the fancy box script.

 

Maybe my configuration but lost the pop up effect

 

 

May I ask what you changed to make the pop up work?

I upgraded jquery to 1.10.3 for theme roller and cannot find the answer to updating fancybox.

 

Tim

Share this post


Link to post
Share on other sites

Hi Tim,

 

The problem is a conflict with the jquery and the fancy box script .

 

The fancy box update is no longer open source although available

 

https://github.com/fancyapps/fancyBox/tree/master/source

 

to the best of my knowledge this is now commercial so the simplest solution would be to downgrade your jquery to

 

<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.8.22.min.js"></script>

 

although I believe the jquery 9....... versions will also work it is a bit of a pain with the jquery updates.

 

As far as I know the next version of oscommerce will be using color box instead of the fancy box which will solve the problem the 10.js + +++ jquery versions will break the pop up effect so just call one off the older versions never noticed a difference with the .JS anyway.

 

Regards

Joli

 

PS: the whole jquery stuff is just adding a new / quicker type of .css so not really that complicated takes a bit of getting used to (w00t)


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

downgrade your jquery to

 

<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.8.22.min.js"></script>

 

 

Thanks so much for the reply. I am currently under huge stress trying to keep up with upgrades and need all the help I can get.

I tried your solution a couple times, then doing alt F5 but still no pop up. I use KISS thumbnailer so tried again deleting the thumbnails, no luck. then out of desperation I tried changing this line:

<script type="text/javascript" src="ext/jquery/jquery-1.8.0.min.js"></script>

 

My buttons did not lose their formatting and the pop up works again.

 

Tim

Share this post


Link to post
Share on other sites

:thumbsup: Nice you got fixed the upgrades are a bit of a pain but necessary a lot of it is security just trying to keep ahead of the baddies .

 

v2.3.4 version brings a few more problems with some addons as it is now using mysqli.

 

As Harold says "caused problems Add-Ons that were not using the standard tep_db_*() functions"

 

It is only out a few weeks so guess will take a while to get the fixes needed for some addons

 

So you need to watch the support threads!

.

Regards

Joli


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Yes, I have 2 broken ones now. Recover cart sales and easy poplulate.

I found a work around for easy pop.

 

Worst is going to be color box. My thumbnailer uses fancy box. (KISS thumbnailer from Robert)

 

Tim

Share this post


Link to post
Share on other sites

@@knifeman

Tim, I'm not sure if this will help and I only mention it because I was trying some new updates via GitHub last summer and ran into an image issue after the updates, especially to the latest jquery that was out then. Not sure what's the latest as of today though.

 

Anyway, I am using this from Herald's commits on 4 July 2013. Scroll down on the page and you'll see the commits pertaining to the change over to PhotoSetGrid and Colorbox.

 

https://github.com/osCommerce/oscommerce2/commits/master?page=8

 

It's working fine in one of the shops I have going.

 

Note the jquery updates on this as opposed to rolling back as John advised.

 

As well it effects product_info.php images and thereby effects at last part of Robert's Kiss thumnailer. so that's a trade off and may be a negative. I decided to go with self optimized product images as much as I could on this matter.

 

Not sure what to tell you beyond that but tossing an option out there for you.


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

@@altoid

 

So to be clear, if I upgrade my stores to the new version with colorbox:

1 my thumbnailer is useless

2 There is no built in thumbnailer. ( you use self optimized, I take that to mean creating and uploading a small and large image for every product)

 

Tim

Share this post


Link to post
Share on other sites

@@altoid

 

So to be clear, if I upgrade my stores to the new version with colorbox:

1 my thumbnailer is useless

- not totally, on product_info.php for sure, other functionality is still there I believe. So if your main images need thumbed and you have a lot of them, this option is a negative.

 

2 There is no built in thumbnailer. ( you use self optimized, I take that to mean creating and uploading a small and large image for every product)

- correct, no built in thumbnailer but you can still use Robert's KISS thumber with limitations as above. In my case my main images were already pretty much optimized before hand so losing product_info thumbing was not a big deal for me, my page speed load time is still fine without that.

 

Tim

 

 

 


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Hi,

 

After I update V2.3.3 to v2.3.3.1 the tax function stop working. When creating or editing products the tax NET and GROSS have the same value.

 

To continue to work I can't change the follow code in admin/includes/functions/general.php on tep_get_tax_rate_value():

 

function tep_get_tax_rate_value($class_id) {
$tax_query = tep_db_query("select SUM(tax_rate) as tax_rate from " . TABLE_TAX_RATES . " where tax_class_id = '" . (int)$class_id . "' group by tax_priority");
if (tep_db_num_rows($tax_query)) {
$tax_multiplier = 0;
while ($tax = tep_db_fetch_array($tax_query)) {
 $tax_multiplier += $tax['tax_rate'];
}
return $tax_multiplier;
} else {
return 0;
}
}

 

to

 

function tep_get_tax_rate_value($class_id) {
return tep_get_tax_rate($class_id, -1, -1);
}

 

Can someone tell me what is wrong?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

×