Jump to content
lost_in_normalcy

First Data Global Gateway e4 AIM - New Module release

Recommended Posts

Hey everyone, looking for a payment module for First Data Global Gateway E4? I wrote the following module based on their latest Version 12 API, it is for OsCommerce 2.3 but could easily be adjusted to work in 2.2:

 

First Data Global Gateway e4 AIM

 

In their documentation, First Data put out a hack for the Authorize.net SIM module, which works and is all well and fine for those that do not mind their customers leaving the site, but not so great if you want to keep your customer on your site. There was no way I was going to take customers away from my site, especially with some hacked up module, but no one had written a module with advanced integration for OsCommerce yet...well not until now!

 

This new module keeps everything on your site, I have tested it up down and sideways and cannot find any bugs. The instructions are very in depth so setup will be a breeze. I know there were quite a few people looking for this, hope it helps the community as much as the community has helped me.

 

Problems? Message me or post here! :D

Share this post


Link to post
Share on other sites

Hello, we are having an issue with uploading an API module into oscommerce to our Wordpress Online Store. When we follow the instructions, some of the other modules that are already there show up as corrupted. Do you have any advice?

Share this post


Link to post
Share on other sites

HI - look at one of the existing modules in the WP Online Store and compare it to a standard osCommerce one - there's an extra line of code at the top of the WP Online version (I cannot recall it at the moment but comparing the two should find it) - you need to add that into any new payment modules you add to WP Online Store

Share this post


Link to post
Share on other sites

HI - look at one of the existing modules in the WP Online Store and compare it to a standard osCommerce one - there's an extra line of code at the top of the WP Online version (I cannot recall it at the moment but comparing the two should find it) - you need to add that into any new payment modules you add to WP Online Store

 

Hey Bob can you please post the code so others searching for a solution can find the answer? Also, please specify the plugin you are referring to. Sorry guys I don't use WordPress.

Share this post


Link to post
Share on other sites

Hi

 

there's a version of osCommerce that somebody has shoehorned into a Word Press plugin (it's called WP Online Store) - it works like a normal WP plugin and as far as I know most of the code used is standard osC - where it differs is that if you upload a normal osC payment module then it won't be visible in the admin - you have to add this to the top of the main module file:

 

Standard osC includes/modules/payment/cod.php

 

/*
 $Id$
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com
 Copyright (c) 2003 osCommerce
 Released under the GNU General Public License
*/
 class cod {
   var $code, $title, $description, $enabled;
// class constructor
   function cod() {

 

Now for WP version

 

/*
 $Id$
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com
 Copyright (c) 2003 osCommerce
 Released under the GNU General Public License
*/
$cod_code =  'All right reserved by IMC group';
/*if(!has_filter('the_content','wp_gold_store_filter')){
echo 'You need to install WP payment plugin. Please download it from <a href="http://wponlinestore.com/">IMC Media Group</a>';
exit;
}*/
 class cod {
   var $code, $title, $description, $enabled;
// class constructor
   function cod() {

 

The bit you need is $cod_code = 'All right reserved by IMC group'; - whichever module you want to add in just create a line like that and change the $cod_ bit to whatever the class name is e.g.

 

$authorizenet_cc_aim_code = 'All right reserved by IMC group';

 

That should get the module visible in admin so you can install it - I've not had anything else to do with WP Online Store other than install a payment module for a client so I couldn't tell you how else it differs from a standard osC

Share this post


Link to post
Share on other sites

Thanks Bob! Awesome, so for this module if you are trying to install it into: WP Online Store (Version 1.3.1)

 

Go to the new module file: catalog/includes/modules/payment/gge4_cc_aim.php

======================================================================================================

FIND - LINE 49:

class gge4_cc_aim extends SoapClientHMAC {

var $code, $title, $description, $enabled;

 

ADD BEFORE:

$gge4_cc_aim_code = 'All right reserved by IMC group';

 

SO NOW YOU SHOULD HAVE:

$gge4_cc_aim_code = 'All right reserved by IMC group';

 

class gge4_cc_aim extends SoapClientHMAC {

var $code, $title, $description, $enabled;

======================================================================================================

 

Keep in mind neither me or Bob use the WP Online Store, so we are offering this to test, if there are issues or more code to be added, post it!

Share this post


Link to post
Share on other sites

I had some problems with this module in an osCommerce 2.3 installation:

 

1.  Problem:  The title of the payment method did not show up on the checkout payment page.

     Fix:  

            *  edit includes/modules/payment/gge4_cc_aim.php

             * Find: 'module' => $this->public_icon . $this->checkout_title);

             * Change to: 'module' => $this->public_icon . $this->public_title);

 

2. Problem:  After entry of card info and upon clicking "Confirm Order" the following error message is generated:

Warning: stream_context_set_option() [function.stream-context-set-option]: called with wrong number or type of parameters; please RTM in .../catalog/includes/modules/payment/gge4_cc_aim.php on line 43
Fatal error: Uncaught SoapFault exception: [HTTP] in .../catalog/includes/modules/payment/gge4_cc_aim.php:45 Stack trace: #0 .../catalog/includes/modules/payment/gge4_cc_aim.php(45): SoapClient->__doRequest('<?xml version="...', 'https://api.glo...', 'http://secure2....', 1, 0) #1 [internal function]: SoapClientHMAC->__doRequest('<?xml version="...', 'https://api.glo...', 'http://secure2....', 1, 0) #2 .../catalog/includes/modules/payment/gge4_cc_aim.php(201): SoapClient->__call('SendAndCommit', Array) #3 .../catalog/includes/modules/payment/gge4_cc_aim.php(201): SoapClientHMAC->SendAndCommit(Array) #4 .../catalog/includes/classes/payment.php(181): gge4_cc_aim->before_process() #5 .../catalog/checkout_process.php(81): payment->before_process() #6 {main} thrown in.../catalog//includes/modules/payment/gge4_cc_aim.php on line 45

Line 43 is this:

stream_context_set_option($context,array("http" => array("header" => "authorization: GGE4_API " . $keyid . ":" . $authstr . "\r\nx-gge4-date: " . $hashtime . "\r\nx-gge4-content-sha1: " . sha1($request))));

 

I'm still trying to sort this out.  Any ideas??

 

Share this post


Link to post
Share on other sites

Jhaugen,

 

I've gotten the same exact error as you. And Google wasn't very helpful until I finally constrained the Google search and came upon a Russian speaking forum where some guy had the same exact error as us and he solved the issue. After going through 4 online translators I surmised  that he said it was a password issue. Hmmm...so I thought well I have the right password that I'm using so it must not be put in the place in the code where it needs to be or the code isn't getting it correctly from the database. So I downloaded FD Sample Code and filled in the demo transaction info and got the same error. Rechecked the the file and saw I had put in the wrong password. Changed it and viola! it worked! No errors. So now I had to figure out how to get that code into this module. Well, after some fussin' I hacked it and got this module working! Tested it and it works(payment is taken and recorded at FD and in the Admin of the store, orders are processed, emails sent etc,). I'm hesitant to post the redo of the code because it really is a hack and it makes the module in the Admin irrelevant (i don't pull any owner data(ID,Pass, MD5 Hash, Trans Key) from the database...neither does FD Sample Code). If you want the redo, PM me.

Share this post


Link to post
Share on other sites

The module installed perfectly for me on an old 2.2 site - I copied the files into the includes/modules/payments/ and includes/languages/english/modules/payments, everything showed up in the admin payment module area OK. I then added the config info from the merchant account as the docs suggest.

 

When testing, I got an error at first about about the account not being activated but after logging into "https://globalgatewaye4.firstdata.com" and changing the "terminal" settings, to enable this terminal as an "ecommerce" terminal, it worked fine.  I did also see no payment type name so I edited the file as jhaugen stated above.  (cheers for that)

 

First Data actually wants users to go to their subcontractor and purchase a different module for $57, so this was a savings and works better because it is seamless and doesn't take the customer from the site.

 

Many thanks to Lost_In_Normalcy!

Share this post


Link to post
Share on other sites

I seem to be been getting ahead of myself with that previous post, in fact the module is not working for me and I am getting the same soap error. Working on it right now.

Share this post


Link to post
Share on other sites

This was a bust, I couldn't get it to work, even with hiring a more experienced programmer to hack at it. I called first data and they were very friendly, quite knowledgeable but stated they did not support AIM at all, and we should be using SIM.  So I am working this right now, making changes to the authorize.net SIM module to point to the first data servers. Then I am working through this link a nice fellow was kind enough to post:

 

http://globalcreations.com/blog/integrating-first-data-e4-sim-with-oscommerce/

 

I will post back if I get it all working.

Edited by fiodh

Share this post


Link to post
Share on other sites

I got it working finally after using the walkthrough at the link above. I am still working on some error occurring when auto-posting back to the OSC site. It does go back if the user clicks "Return to website" but otherwise not so much. Will post back here if I find the solution.

Share this post


Link to post
Share on other sites

To get it to send back, choose this on the

 

Receipt Page Settings

Return Link Method (for receipt page):

 

- Automatic linking to the receipt page including result parameters using HTTP POST method (AUTO-POST)

 

it works!

Share this post


Link to post
Share on other sites

I prefer the AIM process. We've switched to FirstData but I haven't dropped our current virtual merchant provider until I get this module working. Getting the same SOAP error discussed above even after checking and changing the password.

 

Warning: stream_context_set_option() [function.stream-context-set-option]: called with wrong number or type of parameters; please RTM in /home/XXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php on line 43

Fatal error: Uncaught SoapFault exception: [HTTP] Authorization Required in /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php:45 Stack trace: #0 /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php(45): SoapClient->__doRequest('<?xml version="...', 'https://api.dem...' 'http://secure2....' 1, 0) #1 [internal function]: SoapClientHMAC->__doRequest('<?xml version="...', 'https://api.dem...' 'http://secure2....' 1, 0) #2 /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php(185): SoapClient->__call('SendAndCommit', Array) #3 /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php(185): SoapClientHMAC->SendAndCommit(Array) #4 /home/XXXXXXXXX/public_html/includes/classes/payment.php(191): gge4_cc_aim->before_process() #5 /home/XXXXXXXXX/public_html/checkout_process.php(81): payment->before_process() #6 {main} thrown in /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php on line 45

 

Any new thoughts or success stories?

 

Thanks!

Share this post


Link to post
Share on other sites

I did get module to install on my site after Gary pointed me to the issue of needing to have soap installed on the server, but then I got the same error as stated in previous post. Anyone know how to fix this?

 

I prefer the AIM process. We've switched to FirstData but I haven't dropped our current virtual merchant provider until I get this module working. Getting the same SOAP error discussed above even after checking and changing the password.

 

Warning: stream_context_set_option() [function.stream-context-set-option]: called with wrong number or type of parameters; please RTM in /home/XXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php on line 43

Fatal error: Uncaught SoapFault exception: [HTTP] Authorization Required in /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php:45 Stack trace: #0 /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php(45): SoapClient->__doRequest('<?xml version="...', 'https://api.dem...' 'http://secure2....' 1, 0) #1 [internal function]: SoapClientHMAC->__doRequest('<?xml version="...', 'https://api.dem...' 'http://secure2....' 1, 0) #2 /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php(185): SoapClient->__call('SendAndCommit', Array) #3 /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php(185): SoapClientHMAC->SendAndCommit(Array) #4 /home/XXXXXXXXX/public_html/includes/classes/payment.php(191): gge4_cc_aim->before_process() #5 /home/XXXXXXXXX/public_html/checkout_process.php(81): payment->before_process() #6 {main} thrown in /home/XXXXXXXXX/public_html/includes/modules/payment/gge4_cc_aim.php on line 45

 

Any new thoughts or success stories?

 

Thanks!

Edited by allaboutwicker

Share this post


Link to post
Share on other sites

I bought the module and it doesn't work. Tech support takes a day or 2 to reply. Even after giving them ftp access they couldn't make it work and stopped replying. If I ever have a customer tell me thay are using First Data again I'll tell them find something else or use Pay Pal. Why pay for a card processor when you go off site to pay.

Share this post


Link to post
Share on other sites

I have now found that First Data has changed their software again recently due to security updates and now it is called the Payeeze Gateway. https://support.payeezy.com/hc/en-us We have had to purchase the upgraded software from them directly to be able to use it and am awaiting the code for integration into our new store. I am hoping it will work. We get a better rate through them vs PayPal as far as fees and a monthly charge of $20 vs $30 if we go with PayPal, so it should in theory pay for itself within 10 months or sooner. If it doesn't work we may get a PayPal Pro account to use for direct payments online, but trying to use First Data if possible as have been with them for several years now. I will update once they send the code and we see how it goes.

Share this post


Link to post
Share on other sites

I have not yet been able to integrate First Data Payeezy gateway into my oscommerce store. They refer me back to the software developer which of course I am using oscommerce. I can't believe it could be all that impossible for someone that may understand it all better then me. As you can see by the following link that many other ecommerce shops have been able to do it. https://www.firstdata.com/en_us/customer-center/merchants/ecommerce-partner-directory.html  Isthere no oscommerce shop using this payment gateway? I have put it out there as a job request the other day, but no responses yet. I hate to think of having to switch our payment processor after using them for years on our old oscom site or go to using PayPal for all of our payments. Any ideas folks? Thanks

Share this post


Link to post
Share on other sites

We have still not found a way to integrate the new Firstdata Payeezy payment module at this time. We have chosen to go with PayPal Pro for now so we can take credit cards directly on site. We were able to get that going and It appears to work well, but would like the ability to use the Payeezy gateway as we get a little better charge rates through them and it all adds up over time out of our expenses. Anyways, if anyone can figure out how to integrate that payment gateway please let us all know.

 

Thanks!

Share this post


Link to post
Share on other sites

We have still not found a way to integrate the new Firstdata Payeezy payment module at this time. We have chosen to go with PayPal Pro for now so we can take credit cards directly on site. We were able to get that going and It appears to work well, but would like the ability to use the Payeezy gateway as we get a little better charge rates through them and it all adds up over time out of our expenses. Anyways, if anyone can figure out how to integrate that payment gateway please let us all know.

 

Thanks!

 

Just thought I would let you know that after most of an entire day I finally got this working with my version 2.2. I discovered that the SOAP Exception error everyone was getting was due to the code the person is using to obtain the configuration data from the database. It just doesn't pass along the keys and passwords correctly. The sample code First Data provides does work if you use that instead and plugin your data.

 

Beyond that I also discovered for whomever might need to know that the process_button() function just returns false and instead needs to post the cc details the customer enters back to the confirmation page as hidden fields. You can find this example in the Authorize.net AIM code.

 

If you would like further information please feel free to pm me.

Share this post


Link to post
Share on other sites

Hi All! Not sure what issues you guys are having, but this module is installed and working perfectly in my OSC 2.3.3 store. If it is not working for you, I think a setting is wrong either in your merchant account or in the module settings in admin. Also, in the read me file in the module, please note this little snippet of info:

 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Please note that during testing there were several times the Demo wsdl
file was offline, so check that first if all of the sudden your are
getting a SOAP Exception fatal error and you were not before, paste
this link into your browser:

https://api.demo.globalgatewaye4.firstdata.com/transaction/v12/wsdl

if the page is blank, wait a few minutes and refresh, if it is not, you
do have an error. I have only noticed this with the demo server, not the
live server.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

I would be happy to try and help, I will try to check in more regularly. I just wanted to let all know the module has worked flawlessly for me since I wrote it.

 

Peace

Share this post


Link to post
Share on other sites

Well, a few years later and I am back updating to 2.3.  Installed the module and it's giving me the same darn soap errors. Working on it now.

Share this post


Link to post
Share on other sites

I would prefer to use the AIM process here.  Obviously SIM is outdated, we had to use it last time because I had no luck with this. I see that AIM apparently works if certain settings are correct but - what are the variables that are causing this soap error?

 

The aftermarket module FirstData is suggesting only has two variables to enter into the config, the gateway ID and a generated password.   This module here at OScommerce also requires the gateway key ID # and a hash code.   They are named differently in the firstdata admin.

 

 

I have installed SOAP so it should be available....  still looking...

 

LostInNormalcy if you see this and have any ideas, don't be shy!!!  LOL

Edited by fiodh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×