Jump to content
kymation

[Addon} Superfish Categories Box

Recommended Posts

Yo Jim.

 

I noticed that bootstrap.min.css was appearing twice in the source code.  There is a ; in the template_top.php, line 32.  It was causing the css to be listed twice.

 

<?php if ( !defined ( MODULE_HEADER_TAGS_THEME_SWITCHER_STATUS ) || MODULE_HEADER_TAGS_THEME_SWITCHER_STATUS != 'True' ); { ?>
 

What's funny is it was making me scratch my head for a while since the line is very simple....until I took a few mins away from my screen and suddenly noticed that lil guy.  

Share this post


Link to post
Share on other sites

I assume that you meant this to go under the Theme Switcher support thread, as there's no template_top.php in this addon. As if I need any more confusion today.

 

As to that errant semicolon, I obviously missed it as well. Thanks for the bug report. I'll go delete that extra character and upload a new version.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello, I installed superfish_box_1.2.2 and part osCommerce 2.3.x Standard.
All the vertical menu works and looks good.
But I have a problem on the main page. In the middle part and above I have a big banner for star and down products of the month product, these products are placed in threes.
The problem is that when active this contribution from the manager putting it true, products of the month will rise to the banner of the star product, mixing and looks bad.
If I turn to false from the manager looks good.
I have gone mad and not checking it all it can be.

 
 
 
 
 

 

Share this post


Link to post
Share on other sites

It sounds like you have something else that is interfering. I would need to look at your site to even get an idea of what is wrong.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I can't get that page to load completely, but what does load seems to work. I think you have way too much content on that page anyway, so maybe you need to remove some of it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

post-336896-0-50427000-1437602018_thumb.jpgJim, the website I've tried and load pretty fast. It does not have much content. The problem not think it's content. I think it is in the code that was added to the catalog / includes / template_top.php modifying part of the code because you look good with it the website but the arrow disappear File menu.
By the way I have another question. How do I get out in this new menu the number of products by categories and subcategories. This is activated from the administrator configuration / my store / show category counts.
But this menu does not appear.

Share this post


Link to post
Share on other sites

You have to modify your includes/template_top.php to include the code for this addon and the code for the other addons you are using. You cannot just overwrite that file.

 

The product count uses a tremendous number of database calls, which slows the whole site down if you have more than a few products. It was removed from this addon to prevent this problem.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That's correct for the Superfish code. I can't tell if it's correct for everything else you have installed. Either you've left out one or more lines here that your on-page code needs, or something in that code is using the same ID/class as the Superfish code. I can't help with that as I don't know anything about that other code.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Ok. Well, I look at it. Sorry to insist, but if I could spend the code necessary to add the number of products in the categories would appreciate.
you can send me to david29475@gmail.com. Thank you very much for your attention.
When solve the problem that I have I will inform you.

Share this post


Link to post
Share on other sites

Sorry, but I don't have the time to customize an addon for you. I suggest that you post on the commercial forum and someone will give you a quote on this work.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi I after some research found that the fault is in the catalog / includes / template_top.php file.
Removing a script in the code entered in this file, the error is removed and all good is displayed. But the arrows do not appear.
The deleted code:

<script type = "text / javascript">
     jQuery (document) .ready (function () {
       jQuery ('ul.sf-menu'). superfish ({
         animation: {height: 'show'}, // slide-down effect without fade-in
         delay: 1200 // 1.2 second delay on mouseout
       });
     });
   </ script>

Jim because you think that the arrows do not see?
By the way the original file template_top.php contribution when you open it with dreamweaver get an error at line 36.
I will continue investigating.
A greeting.

Share this post


Link to post
Share on other sites

Removing that script will disable Superfish. I don't think that you want that.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi to all,

I have a problem with superhish category box.

Everything is working perfect till last Monday, i was add two new subcategory and they are not visible in menu tree.

But when I click on a category which includes the two new sub-categories , they can be seen in the central part of the site.

Also i try to create new category and have same problem not visible in category tree menu.

Url of my web site is www.pakraprom.com

Name of category is (Rucni alati), and names of sub-categories are (Pinovi and Zatezaci ekspenderi) "see attached pictures"

Please help. I was try to find why is that hapend but no luck.

If more information needed ask please i will provide it.

 

post-336931-0-66630900-1437713104_thumb.jpg

post-336931-0-74179200-1437713235_thumb.jpg

Share this post


Link to post
Share on other sites

Do you have the osCommerce cache turned on? If so, clear your cache.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Do you have the osCommerce cache turned on? If so, clear your cache.

 

Regards

Jim

Ok Mr. Jim i will try to clear cache and i hope that solve a problem

Share this post


Link to post
Share on other sites

First, turn off the cache function unless you absolutely need it. It's a horrible solution.

 

Your other problem is something I've never seen before. It's changing the accented characters to the Latin equivalent. That's very odd. I can't see anything in this Addon that would make that happen.

 

In any case, I suggest that you add a .htaccess rule to rewrite www.pakraprom.com to www.pakraprom.com/index.php. That's nothing to do with this addon, so please post a question in the general forum if you can't figure out how to do that.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi

I would like to use this add on for my bootstrap oscommerce shop, but i wonder if there is any way of getting it without having to buy winzip to extract the .gz and .tar compressed files ? Is there any change the add on could be downloaded from somewhere as a "normal" windows xp extractable .zip file ?

Best regards

Brian

Share this post


Link to post
Share on other sites

7zip will extract the files and is free to use. I don't have a bootstrap demo at this time; maybe someone else will volunteer one.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

OK, thanks. I can share a link to my site when i get this implemented, if it works satisfying :-) Any idea if the search engines will recognize the category tree content as good with this add on as with the original oscommerce ?

Share this post


Link to post
Share on other sites

Modern search engines will recognize links in Javascript, so this should not be a problem. Stores using this addon in osCommerce 2.3.x seem to have search engine results for categories at all levels. If you are worried about this, adding a sitemap should take care of it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×