Jump to content
Sign in to follow this  
dreamscape

Who would like to see a dynamic MoPics?

Recommended Posts

well without seeing product_info.php I can't be sure...

 

also if u are not going to be using the old Mopics anymore and are replacing it with the dynamic mopics, then yes you would want to remove the old mopics code from product_info.php


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

the image directories go inside catalog/images

 

so if you are naming your big image directory "big_images", you make it inside images so that its like catalog/images/big_images


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

I am pretty new at php - so I'll try to remove the original code. If that doesn't work, I'll look for a a clean version of product_info.php and modify that with your dynamic code.

I did get the location of the sub directories correct -

thanks,

Murray

Share this post


Link to post
Share on other sites

I am a bit confused about:

define('MORE_PICS_EXT', '_screen');

define('BIG_PIC_EXT', '');

 

where do the _screen images go?

also, I want to list a bunch of small jpg imges which are color swatches for available for each product. (in this case they are cosmetics colors) but I don't want them to link to larger images - How do I keep them from being clickable. I assume I don't need to deal with the big_images.

thanks,

Murray

Share this post


Link to post
Share on other sites

they go in the directory you defined as:

 

define('IN_IMAGE_BIGIMAGES','images_big/');

 

so what ever that directory is, they go in there:

 

ie: catalog/images/images_big/IMAGE_screen1.jpg

catalog/images/images_big/IMAGE_screen2.jpg

catalog/images/images_big/IMAGE_screen3.jpg

 

etc...


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Still having problems - I discovered I had the original mo pics installed ( a phesis loaded version - installed by someone else for me) -- I have reverted back to the original and want to start again.

1) How do you recommend I remove the original mopics.

2. Once installed, does dynamic mo pics have an admin of any sort? Do I need to keep the original mopics admin?

thanks,

Murray

Share this post


Link to post
Share on other sites

Hello, i'm an osCommerce virgin. About to convert my customer's site from quikstore to osC. The first thing I searched for here is a mod just like this, because my customer typically has 2-6 images for a product. I've written a javascript module for my current site, but i'd like to use this one with osC. I've read through the post twice now, and can't seem to find a link to download.

 

Hoping someone can tell me where to acquire this jewel, thanks!

 

Wade

"comfortably poor, plugin through life with my head held high!"

Share this post


Link to post
Share on other sites
Still having problems - I discovered I had the original mo pics installed ( a phesis loaded version - installed by someone else for me) -- I have reverted back to the original and want to start again.

1) How do you recommend I remove the original mopics.

2. Once installed, does dynamic mo pics have an admin of any sort? Do I need to keep the original mopics admin?

thanks,

Murray

 

1) the original moPics makes several if statements in product_info.php... look for them and remove them..

 

2) no dynamic moPics has no admin. you do not need to keep the original moPics admin. the product's normal thumb image is all that needs defined in admin for this to work


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites
Hoping someone can tell me where to acquire this jewel, thanks!

 

sure... I had another thread when I uploaded this, and was hoping questions would be asked there, but that's not how it happened...

 

so guess this is THE thread now, so guess we'll need the link over here:

 

http://www.oscommerce.com/community/contributions,1114


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Hi Joshua... Superb contri!

 

Just installing it into an up to a post-MS1 snapshot and the team have moved the section specified in your install.txt, step 1.

 

Anybody installing into the latest snapshots needs to edit catalog/includes/filenames.php rather than application_top.php - you might want to do a quick edit on your text file!

 

All the best,

 

Colin


staggering along with 2.2-CSV...

Share this post


Link to post
Share on other sites

I have been spending too much time on this but I am tenacious.

I have a phesis load - ver 2.2, with the latest v5 patch.

I tried removing the old mo pics code per your suggestion from categories.php - the install kept giving me error messages, so I uploade the original categories.php v. 1.37 2002/08/19

there is only a single image listing in this one, but I thought it might work anyway as you only require the single listing.

I uploaded everything per your instructions.

The images are in the following folders.

catalog/images

blush.jpg

 

catalog/imamges/thumbs

blush1_screen.jpg

blush2_screen.jpg

blush3_screen.jpg

 

catalog/images/images_big

blush1_big.jpg

blush2_big.jpg

blush3_big.jpg

 

the mopics dynamic code is below

define('IN_IMAGE_BIGIMAGES','images_big/');

define('IN_IMAGE_THUMBS', 'thumbs/');

define('MAX_DISPLAY_THUMBS', '42');

define('THUMBS_PER_ROW', '7');

define('MORE_PICS_EXT', '_screen');

define('BIG_PIC_EXT', '_big');

 

Still not working. Do you see any errors in the image naming?

Any idea what else would keep them from displaying?

BTW, I am trying to add a series of small color swatches and don't want them to be clickable as there is no reason to enlarge them. Is there some way to lose the big images altogether?

Thanks,

Murray

Share this post


Link to post
Share on other sites
catalog/imamges/thumbs

blush1_screen.jpg

blush2_screen.jpg

blush3_screen.jpg

 

catalog/images/images_big

blush1_big.jpg

blush2_big.jpg

blush3_big.jpg

 

the numbers should come at the end... it is set up to search for these pictures:

 

catalog/imamges/thumbs

blush_screen1.jpg

blush_screen2.jpg

blush_screen3.jpg

 

catalog/images/images_big

blush_screen1.jpg

blush_screen2.jpg

blush_screen3.jpg

 

the mopics images should be the same name.

 

the define('BIG_PIC_EXT', '_big'); is just as it says beside it:

"this is if you name your big thumb like IMAGE_big.jpg, you would put '_big' here. otherwise leave it blank"

 

I mean you main big thumb by that... so for example u have the thumb in images/blush.jpg... you would place the big image in images/images_big/blush.jpg, but if you had it in images/blush_big.jpg, that is where u'd use the BIG_PIC_EXT. it is only for the main thumb, not for the mopics. MORE_PICS_EXT is for the mopics.


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

I renamed the images as follows:

blush_screen1.jpg

blush_screen2.jpg

blush_screen3.jpg

 

catalog/images/images_big

blush_screen1.jpg

blush_screen2.jpg

blush_screen3.jpg

 

I removed the "_big" from below

define('IN_IMAGE_BIGIMAGES','images_big/');

define('IN_IMAGE_THUMBS', 'thumbs/');

define('MAX_DISPLAY_THUMBS', '42');

define('THUMBS_PER_ROW', '7');

define('MORE_PICS_EXT', '_screen');

define('BIG_PIC_EXT', '_big');

 

I know get the message 'Coming soon' - which you said to someone else that means it isn't finding the images. There was also a note to replace the line with <?php echo TEXT_NO_MOPICS; ?> -- I tried placing that line like this define('TEXT_NO_MOPICS','<?php echo TEXT_NO_MOPICS; ?> ');

That didn't seem correct (I need to learn php) but I did it anyway and ended up with a totally blank screen.

 

I am wondering if my admin/categories.php might be the wrong version. Can you tell me what version it should be?

Share this post


Link to post
Share on other sites

no that wasn't were u put the echo text no mo pics... in goes in the module...

 

I just realized that if you main thumb is not listed in admin as 'thumbdirimage.jpg', then this will not work..

 

let me work up a fix for this


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

I am glad you figured out why this wasn't working. I have put in so much time on this and was about to quit. I am mostly a web designer and don't know much about php but I am very good at following instructions for installing software. I was about to give up and look for another solution to displaying color swatches. You said the file name didn't matter so I went with the name of the product. Looking forward to the fix.

 

When you get back to me with the fix, please explain where in the module I am supposed to put the echo text

 

Also, do I still put the define('TEXT_NO_MOPICS', 'coming soon!'); in english/product_info.php ?

 

I am glad you figured out why this wasn't working. You said name didn't matter so I went with the name of the product. Looking forward to the fix.

thanks,

Share this post


Link to post
Share on other sites

ok I've got a fix up:

http://www.oscommerce.com/community/contributions,1114

 

if upgrading, just overwrite the popup_image and dynamic_mopics files

and add the new defines for configure.php

 

this should fix your problems and get ya going.


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites
When you get back to me with the fix, please explain where in the module I am supposed to put the echo text

u put it nowhere... it's been placed where it needs to be in the fix :wink:

 

Also, do I still put the define('TEXT_NO_MOPICS', 'coming soon!'); in english/product_info.php ?

yes that is the text that the echo will display if need be

 

I am glad you figured out why this wasn't working. You said name didn't matter so I went with the name of the product. Looking forward to the fix.

correct name does not matter, so long as they all follow that 1st name. I did not account for users putting the main thumb in catalog/images and the mopic thumbs in catalog/images/thumbs.

 

I accounted for either all in a thumb directory or all in the main directory. this has been fixed now though and u can place the main thumb in the main image directory and the mopic thumbs in a different directory (as you have).


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Thanks,

I will give it a try.

You are so fast that our messages crossed. Please let me know the following which I asked in my last email.

 

When you get back to me with the fix, please explain where in the module I am supposed to put the echo text

 

Also, do I still put the define('TEXT_NO_MOPICS', 'coming soon!'); in english/product_info.php ?

thanks,

Murray

Share this post


Link to post
Share on other sites
When you get back to me with the fix, please explain where in the module I am supposed to put the echo text  

 

Also, do I still put the define('TEXT_NO_MOPICS', 'coming soon!'); in english/product_info.php ?  

thanks,

Murray

 

both have been answered in my above post :wink:


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

It is still not working.

I still see "coming soon"

overwrote the files

pasted the changes in configure.php

changed the MAIN_THUMB_IN_SUBDIR', false)

what now?

thanks,

Murray

Share this post


Link to post
Share on other sites

a URL please of a product u are trying to use it on?


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

if it says "coming soon" still, then the 1st mopic is not being found...

 

according to the info u've given me, it should be located at and named:

catalog/images/thumbs/blush_screen1.jpg


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

I just checked the directories and the file is named correctly and is named: catalog/images/thumbs/blush_screen1.jpg

 

I wonder if I might have you take a peek at my files. If so I can email the information to you privately.

thanks,

Murray

Share this post


Link to post
Share on other sites

yes either PM me where I can see it at or email me


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×